• Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 01.02.17, 10:36
  • Reason: Closed
  • Comment: Glad to help!

FS#10037 - Error modifying product info in B/O

Hi,
I have a strange fault affecting my B/O. If I try to modify (say change an association) in a product details I get an error saying “You don’t have permission to access /admin2471/index.php on this server.
It seems to be to do with the Custom Tab in the product details. If I try to save a product with data in the custom tabs I get the above error. I can save if I disable the product but this wipes out any info in the product tabs. It seems to save ok with the Custom tab turned off in Theme settings/product but does wipe out the custom tab info.
I have tried logging in as a Super admin and an Admin but no change. I do not know when this problem started or what I might have done to cause it.
I am sorry this is so long, I hope you can help me out.

thanks
John Evans

This ticket does not depend on any other tickets.

John Evans (jevans_11242)
Sunday, 06 November 2016, 20:41 GMT+1

Hello,
Here is further information.
The problem definately seems to be associated with Custom Tab box in the product section of the B/O. The fault only occurs if there is text in this box. To get round it I delete the text then save the product details. Then I can re-enter the text & all seems well. Products that do not use the Custom tab are not affected.
Also if I change a product (with text in the Custom Tab box) to "disabled" status then the text is wiped away. Is this correct?
As I have got round the problem please reduce the fault status from High.

thanks again

John Evans

Alex Support (Admin)
Monday, 07 November 2016, 12:36 GMT+1
Support Team

Hi. We will try to check the issue and fix it today

Marek (marek)
Monday, 07 November 2016, 21:04 GMT+1
Support Team

Hi John,
I have tried to find fast solution, but unfortunately spend a couple of hours and still have no result. I'll continue to work on that.
Please provide access to your BO and FTP, I need to see module files

John Evans (jevans_11242)
Tuesday, 08 November 2016, 19:14 GMT+1

Marek,
B/O & ftp details updated.
Please be aware that this is a new problem that came a few days ago. the site has been working fine up until then. I would not like you to chase a glitch caused by my "finger" trouble.
Also if I change a product (with text in the Custom Tab box) to "disabled" status then the text is wiped away. Is this correct?
many thanks

John Evans

John Evans (jevans_11242)
Wednesday, 09 November 2016, 10:42 GMT+1

Good morning,
The Sales stats in my B/O has changed since last night. It now shows a different value of sales each time I refresh the page. Also the value has been multiplied by 100. Any thoughts?
regards
John Evans

Marek (marek)
Thursday, 10 November 2016, 21:53 GMT+1
Support Team

Hi John.
I have no ideas about your statistics, I didn't touch anything in your back office.
Regarding the issue with Custom Tab, I'll fix it, but on the next week, because now I have a little vacation and back to work on Monday. I hope it's not critical for you.

John Evans (jevans_11242)
Friday, 11 November 2016, 10:03 GMT+1

Marek,
No the problem is not critical, I am grateful for your help. Also I have resolved the stats issue by restoring a day old d/b.
Enjoy your break.
John Evans

Marek (marek)
Thursday, 17 November 2016, 17:41 GMT+1
Support Team

Hi John.
I'm back.
I have tried to reproduce the issue with several products, but is works fine for me. Could you please check the issue now?

John Evans (jevans_11242)
Thursday, 17 November 2016, 20:15 GMT+1

Marek, Welcome back!!
I wonder if I had a glitch that corrupted part of the Custom Tab operation - don't know. Some product entries still exhibit the "do not have permission " problem but I can get round this by clearing the Custom Tab info & re-entering.
What is still happening is that if I change the "status" of a product from enable to disabled or vice versa then any info in the custom tab section of that product is lost. (B/O catalogue/products/status). I do not know if this is correct or the result of an error on my shop.

regards

John

Marek (marek)
Thursday, 17 November 2016, 20:27 GMT+1
Support Team

Ok, I'll check that out

Marek (marek)
Thursday, 17 November 2016, 20:35 GMT+1
Support Team

There is no issue in our demo.
I need access to your server via FTP to check module files

John Evans (jevans_11242)
Thursday, 17 November 2016, 22:33 GMT+1

Hi Marek,
I have done some more investigation.
The problem that wipes out the Custom Tab data seems to be caused by the following mod:-
Refer FS#9146 Custom tabs can’t empty the fields
Fix: file\modules\pk-themesettings\pk-themesettings.php line 2837
Delete the code:-
if (!$custom_tab && is_array($check[0]))

	        		$custom_tab = $check[0]['custom_tab'];
	        	if (!$custom_tab_name && is_array($check[0]))
	        		$custom_tab_name = $check[0]['custom_tab_name'];
	        	if (!$video_id && is_array($check[0]))
	        		$video_id = $check[0]['video'];

I have an up to date copy of my site off line. My current site has this mod applied. When I restore the text into line 2837 etc it seems that the problem does not occur and all is OK.
Can you test this on one of your test sites?
regards

John

Marek (marek)
Thursday, 17 November 2016, 22:36 GMT+1
Support Team

latest version of themesettings.php file is already contain that fix.

John Evans (jevans_11242)
Friday, 18 November 2016, 20:03 GMT+1

Marek,
It seems that I should not have applied this mod, I will reverse it. Thank you for your time & effort.
regards
John

John Evans (jevans_11242)
Saturday, 19 November 2016, 20:44 GMT+1

Marek,
I am confused . Please which is the latest version of themesettings.php and where can I get it?

regards
John

Marek (marek)
Saturday, 19 November 2016, 21:01 GMT+1
Support Team

You can download it from themeforest

John Evans (jevans_11242)
Saturday, 19 November 2016, 21:05 GMT+1

Many thanks
John

Loading...