• Status: Closed
  • Opened by: pix (pix)
  • Open Date: 10.01.17, 04:26
  • Closed by: Marek (marek)
  • Closed on: 12.02.17, 11:12
  • Reason: No answer from a customer
  • Comment: Glad to help!

FS#10145 - Alysum javascript error

Platform: Prestashop 1.6.1.7

Theme: Alysum 4.6
Issue: the layer cart and the top blockcart dropdown doesn’t display.

There is a javascript error:

global.js:104 Uncaught ReferenceError: FancyboxI18nPrev is not defined

  at HTMLDocument.<anonymous> (global.js:104)
  at j (jquery-1.11.0.min.js:2)
  at Object.fireWith [as resolveWith] (jquery-1.11.0.min.js:2)
  at Function.ready (jquery-1.11.0.min.js:2)
  at HTMLDocument.K (jquery-1.11.0.min.js:2)

(anonymous) @ global.js:104
j @ jquery-1.11.0.min.js:2
fireWith @ jquery-1.11.0.min.js:2
ready @ jquery-1.11.0.min.js:2
K @ jquery-1.11.0.min.js:2

I have checked the theme’s global.tpl and everything is declared all right there.

The issue is similar to the one here, http://support.promokit.eu/index.php?do=details&task_id=4402 but the solution is not posted.

url - https://goo.gl/e0BEbP

Please advise.

This ticket does not depend on any other tickets.

Alex Support (Admin)
Tuesday, 10 January 2017, 16:43 GMT+2
Support Team

Hi. Fixed.
I just took the condition from default PS file

if (typeof(FancyboxI18nClose) !== 'undefined' && typeof(FancyboxI18nNext) !== 'undefined' && typeof(FancyboxI18nPrev) !== 'undefined' && !!$.prototype.fancybox)

and added it instead of

if (!!$.prototype.fancybox)

in the file to /themes/alysum/js/global.js

pix (pix)
Monday, 16 January 2017, 21:33 GMT+2

Hi,
On January 09 we have contacted you in regards to an JS issue we're having with the cart block in Alysum 4.6.
You fixed it by inserting the code here, http://support.promokit.eu/index.php?do=details&task_id=4402 into the global.js but that led to another issue in the single checkout page where the new account form is not working anymore as it can be seen in the picture attached.
Currently we have replaced the modified (by you) global.js with the original theme's one and renamed your changed one to global.js.mod.
That meansof course that we are back to the original blockcart issue.
Please have a look and let us know the result.
The original message is below.
Regards,

Alex Support (Admin)
Tuesday, 17 January 2017, 18:06 GMT+2
Support Team

Hi. Why you describe all the previous our conversation? I can read everything in this ticket :D
We will try to fix it today

pix (pix)
Tuesday, 17 January 2017, 18:10 GMT+2

I wrote this before seeing that the thread is still open. Thank you

pix (pix)
Wednesday, 18 January 2017, 20:01 GMT+2

Bump + Ping :)

Alex Support (Admin)
Wednesday, 18 January 2017, 21:42 GMT+2
Support Team

Hi. Sorry for waiting. There is some strange bug. Our developer will try to investigate and fix the issue

pix (pix)
Thursday, 19 January 2017, 16:23 GMT+2

Alex, any ETA? It's live site :(

Marek (marek)
Friday, 20 January 2017, 10:59 GMT+2
Support Team

Hi Pix.
sorry for the delay, but the issue is too strange, we are working to fix it

Marek (marek)
Sunday, 22 January 2017, 11:16 GMT+2
Support Team

Hi Pix.
sorry for the delay again.
I just make temporary fix, please check it out, is everything fine?

media.promokit.euscreenshotsscreencloudscreenshot20170122_111620.jpg

pix (pix)
Monday, 23 January 2017, 13:56 GMT+2

No it's not, it should not show the registration field before clicking the button as per your demo sites. Like login on the left.
Status it's now ======Critical======.

Marek (marek)
Monday, 23 January 2017, 14:09 GMT+2
Support Team

ok, I'll try now

Marek (marek)
Monday, 23 January 2017, 14:59 GMT+2
Support Team

I just checked how it works with default prestashop theme, and it's the same. Look at this
media.promokit.euscreenshotsscreencloudscreenshot20170123_145736.jpg

pix (pix)
Monday, 23 January 2017, 16:03 GMT+2

Don't you know how your theme works? Check this - http://alysum.promokit.eu/column/en/quick-order I wouldn't write if it was like this since beginning

So you push button as login, and then AJAX form pops out.
It was working before your colleagues ALEX AJAX registration fix above

Marek (marek)
Monday, 23 January 2017, 21:01 GMT+2
Support Team

Yes, now I see.
Now it should work fine. Please check it out

Loading...