Support will be provided with delays until 3 October. We are sorry for the inconvenience.
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 05.08.17, 18:52
  • Reason: Closed
  • Comment: Glad to help!

FS#10182 - Transport problem .

I have a problem in the carrier.
Client loged with a carrier up to 11€ address barcelona cp 08016. He can select home shipping (3€ ) or pick up at our shop 0€.
When a person select a option (pick up at the shop) f. e . After select payment metoth... but before pay he decided go back to the carrier and change the payment method. After that select payment method f.ex pay by redsys...
The sistem not include the fee transport.
I think that when a person change the transport i have problem about the carrier refesh...
¿Can you help me? i am lossing money on transport...
Thanks.

This ticket does not depend on any other tickets.

Alex Support (Admin)
Thursday, 26 January 2017, 12:41 GMT+2
Support Team

Hi. Please check the issue with the default PS theme. I think you will get the same behavior.

javier Molina (jafmolina)
Thursday, 26 January 2017, 13:55 GMT+2

I notice that changing the addres or the transport the page doesn´t refresh and the carrier doesn´t include the changes or not imprube the amount.

It happend in a ps theme. So thank for your help. If you now somehting more about that please tell me because i am lost.

Thanks for you time.

Alex Support (Admin)
Thursday, 26 January 2017, 20:18 GMT+2
Support Team

Please make the video of the issue. You can easy to do that with the chrome addon https://chrome.google.com/webstore/detail/screencastify-screen-vide/mmeijimgabbpbgpdklnllpncmdofkcpn/reviews or soft http://screencast-o-matic.com/

javier Molina (jafmolina)
Thursday, 26 January 2017, 23:26 GMT+2

Look the video https://screencast-o-matic.com/watch/cbVOrNQLUt

I don´t know why it is not refrest when i change the transport o or the address.

Thanks a lot

javier Molina (jafmolina)
Friday, 27 January 2017, 10:33 GMT+2

I have a rspond of the hosting... I am complety lost.

Any help it welcome how to fix it ... Thanks

Hola,

ya he finalizado las operaciones acordadas telefónicamente. He probado y no ha surtido efecto. El error que arroja la consola de depuración del navegador es el siguiente:

v_102_32689fc….js:796 Uncaught TypeError: Cannot read property 'hasError' of null
at Object.success (v_102_32689fc….js:796)
at j (v_102_32689fc….js:2)
at Object.fireWith [as resolveWith] (v_102_32689fc….js:2)
at x (v_102_32689fc….js:4)
at XMLHttpRequest.b (v_102_32689fc….js:4)
success @ v_102_32689fc….js:796
j @ v_102_32689fc….js:2
fireWith @ v_102_32689fc….js:2
x @ v_102_32689fc….js:4
b @ v_102_32689fc….js:4
v_102_32689fc….js:796 Uncaught TypeError: Cannot read property 'hasError' of null
at Object.success (v_102_32689fc….js:796)
at j (v_102_32689fc….js:2)
at Object.fireWith [as resolveWith] (v_102_32689fc….js:2)
at x (v_102_32689fc….js:4)
at XMLHttpRequest.b (v_102_32689fc….js:4)

Alex Support (Admin)
Friday, 27 January 2017, 14:45 GMT+2
Support Team

Please check now is it ok?
I've copied the file order-carrier.tpl from the default theme and now it seems ok. Please check all the functionality in the checkout with the shipping carriers. As I see everything works great.

javier Molina (jafmolina)
Friday, 27 January 2017, 14:59 GMT+2

GGGGGGGGGGGGGGGUUUUUUUUUUUUAAAAA

The best..... I owe you a lunch. In case you came to MAdrid.

Tanks a lot. amazing.

Alex Support (Admin)
Friday, 27 January 2017, 19:40 GMT+2
Support Team

:D That was our theme issue so you don't owe me. So I should present something to you :)

Oh I wish to get to Madrid within next 2 years. Maybe I will ask you a few nice local not touristy places THANKYOU

javier Molina (jafmolina)
Sunday, 29 January 2017, 17:33 GMT+2

Of course :-)

I have a small problem yet appear a messenge but the carrier it is update... It is apperar when I change the addres.

Thanks.

Alex Support (Admin)
Sunday, 29 January 2017, 18:12 GMT+2
Support Team

I can't reproduce the bug. Please make a video.

javier Molina (jafmolina)
Sunday, 29 January 2017, 18:39 GMT+2

Look http://screencast-o-matic.com/watch/cbVUbzQ8xo

Client add a product a carrier 0 € and pick up on shop > decide pay by transfer > but change main and step back....
Change to transport 1€ > decide pay by Credit card...

You fix the refresh natural but at this point appear the error.

Thanks a lot like always...

If you decide to go to barcelona i will tell you a good place as well :-) Rememeber me.

Marek (marek)
Wednesday, 01 February 2017, 10:40 GMT+2
Support Team

Thank you for invitation! :) Strange issue, and it's hard to reproduce it on my localhost. I'll continue to investigate that

javier Molina (jafmolina)
Wednesday, 01 February 2017, 10:53 GMT+2

Thanks it is happend when you change the decicion from the payment page. Go to transfer, or paypal or redsys and change the value of shipping or methot to pay.

It is happend sometimes.

I notice a new thing... when i go to the when appear all product with the pice 0,00 . But i press f5 and it is repair... it happend in diferente computer and ips . Something strange.

Marek (marek)
Wednesday, 22 February 2017, 12:59 GMT+2
Support Team

Unfortunately I still didn't find any solution

Loading...