We offer professional Design CustomizationCreate a Ticket
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 23.07.17, 23:36
  • Reason: Closed
  • Comment: Glad to help!

FS#10528 - Image carousel in product page doesn't work in safari

Hi!
there is a bug in the product page with safari
with chrome it works but not with safari... check my picture..
i know that browsers are different but this thing should work in every browser.. or customers can’t look at all picture of an item!
Let me know
Best regards
Francesco Capodagli

   image carousel.jpeg (611.2 KiB)

Ticket dependencies (view graph):

Marek (marek)
Monday, 03 July 2017, 12:20 GMT+1
Support Team

I just tested the page http://www.new.gioielleriacapodagli.it/it/973-aurora-penna-stilografica-leonardo-da-vinci.html in my Safari, and it works just fine. Could you please check the issue once again?
media.promokit.euscreenshotsscreencloudscreenshot20170703_121857.jpg

Francesco Capodagli (capocopa)
Monday, 03 July 2017, 17:40 GMT+1

Hi! i don’t know why but in my safari doesn’t work..
i disabled cache and everything.. it’s really strange..
and i have 2 error 404 in the ispection
check my picture
the first and the last error seems that i’m missing some files..
can you check?
Thank you so much

   error.jpeg (161.8 KiB)
Francesco Capodagli (capocopa)
Monday, 03 July 2017, 23:54 GMT+1

Hi Marek!
about the carousel i found the problem! i disabled all extensions in my browser.. and now the carousel works like a charm!
there are only left those 2 error in the picture:

1- https://www.new.gioielleriacapodagli.it/modules/revsliderprestashop/views/css/rs-plugin/css/static-captions.css Failed to load resource: the server responded with a status of 404 (Not Found)

2- https://www.new.gioielleriacapodagli.it/themes/core.js.map Failed to load resource: the server responded with a status of 404 (Not Found)

do you know what they mean? i already set all permission to 755
let me know
thank you so much
Best regards
Francesco

Marek (marek)
Tuesday, 04 July 2017, 11:18 GMT+1
Support Team

Hi Francesco.
Issues has been fixed. Please check it out

Francesco Capodagli (capocopa)
Tuesday, 04 July 2017, 12:12 GMT+1

Thank you so much Marek!

now there are some items that are not loaded with https... can you change them? i think that they are some of your modules
Thank you!
Best regards
Francesco Capodagli

   https error.jpeg (431 KiB)
Marek (marek)
Tuesday, 04 July 2017, 12:18 GMT+1
Support Team

You can try to fix that yourself. Just go to “Promokit Text Block” and remove “http:” in images path. For example it should looks like this:

//www.new.gioielleriacapodagli.it/path/to/image/img.png
Francesco Capodagli (capocopa)
Tuesday, 04 July 2017, 12:28 GMT+1

Great! Fixed!
Thank you so much Marek for the tip!
Best regards
Francesco Capodagli

Francesco Capodagli (capocopa)
Tuesday, 04 July 2017, 19:24 GMT+1

Hi Marek!
Something wrong with featured items block
the carousel doesn’t work correctly..
i didn’t changed anything.. here is a picture
can you check?
thank you so much
Best regards
Francesco

   featured.jpeg (241.7 KiB)
Marek (marek)
Tuesday, 04 July 2017, 19:55 GMT+1
Support Team

I see the problem. You are using ps_featuredproducts module. Unfortunately it’s adapted for sidebar only. I recommend you to use pk_products module instead

Francesco Capodagli (capocopa)
Wednesday, 05 July 2017, 17:31 GMT+1

Hi Marek!
ok problem solved.. i disabled ps featured product module..
now i have another problem.. i don’t know why my website load very slowly.. it depend from your theme because with the classic theme it load fastly
are you able to see what cause this slowdown?
thank you so much
Francesco

Francesco Capodagli (capocopa)
Wednesday, 05 July 2017, 17:38 GMT+1

I think i found what slowdown the website.. now it load fastly.. there is a problem with pk_products module.. it hugely impact website speed.. i don’t know why.. and it also have graphics problem

Francesco Capodagli (capocopa)
Wednesday, 05 July 2017, 17:46 GMT+1

Now it doesn’t work anymore also the menu

Francesco Capodagli (capocopa)
Wednesday, 05 July 2017, 17:50 GMT+1

Here is the error that i get

   error.jpeg (81.6 KiB)
Francesco Capodagli (capocopa)
Wednesday, 05 July 2017, 19:27 GMT+1

The problem is not only with menu.. but with all dropdown menu.. i think it’s a java problem
Waiting for your check
Thank you so much until now for everything!

Marek (marek)
Wednesday, 05 July 2017, 20:21 GMT+1
Support Team

That was an issue with daily deal module. I just fixed that. Regarding the pk_products I’ll definitely check that out

Marek (marek)
Sunday, 23 July 2017, 23:36 GMT+1
Support Team

I have investigated issues in Products module and there is all follows Prestashop standards. I have only added missed cache system, and now it works really faster.
Updated module will be available with new Alysum theme release.

Loading...