We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 29.10.17, 15:45
  • Reason: Closed
  • Comment: Glad to help!

Ticket #10866 - Cannot install Alysum

Prestashop v 1.7.2 Alysum v 5.1.3 Apache 2.4 running on Win 10 laptop PHP 7.1.7 with all required modules installed. ============================================= When adding (from Prestashop) I get the message attached in the browser. However this problem does not happen on the production Linux based web server only my laptop. It is not good as I cannot develop off-line. This scenario also happens with Prestashop 1.6.15 and Alysum 4.3 Any ideas would be much appreciated. Best regards Richard

alysum_problem.PNG (10.6 KiB)

This ticket does not depend on any other tickets.

Marek (marek) 28 Sep 2017, 19:49

Hi, Richard. Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your back office, I need to see the issue

Marek (marek) 28 Sep 2017, 20:13

I suppose the problem is with PHP 7.1.7. Can you try 7.0.X version?

Richard Holland (bigdutch) 28 Sep 2017, 20:31

Hi Marek The production server is running PHP 7.1.5 and this has no problem with Alysum so I doubt it is the PHP version but it may be a PHP configuration problem or even an Apache setting. The weird thing is I have Wordpress and Prestashop v 1.6.1.15 and v 1.7.2 (but not with your theme). Is there any obvious thing I could start looking at to get this working?. I may build a Linux based PC with Apache but it cannot be that complicated - can it? Regards Richard

Marek (marek) 28 Sep 2017, 20:35

We can try to figure out what's wrong. Do you have any error logs to find there an errors related to the theme?

Richard Holland (bigdutch) 28 Sep 2017, 20:46

Hi Marek I have updated my details but you will also need a web password (same as in the details) and login (user: organics_login). I had to do this as the shop was constantly being hacked. We are not sure if it the shop or a theme module. I want to build the same site but using ps v1.7.2 and hopefully get rid of any weaknesses. I had to leave the old site up on the production server as I could not get it to work on my laptop for the reason being discussed. I am not sure how to enable useful logging (apache, php or prestashop) but if you come up with a plan I will do it! I have to leave to play squash now but I will have a look at anything you might have mentioned. Do you develop on Windows or Linux? I have a few things like Bitdefender etc. Do you think I should clean boot etc. Talk soon Regards Richard

Marek (marek) 28 Sep 2017, 20:51

I'm using server based on Ubuntu 14.04. Here is the path to error log in my system /var/log/apache2/error.log but I'm not sure you have the same

Richard Holland (bigdutch) 29 Sep 2017, 01:08

Hi Marek This is the only thing I get from the Apache logs: [php7:error] [pid 7744:tid 1260] [client ::1:2845] PHP Fatal error: Maximum execution time of 30 seconds exceeded in C:\\Apache24\\htdocs\\organics_new\\classes\\Tools.php on line 2822, referer: http://localhost/organics_new/admin862lgmcae/index.php?controller=AdminThemes&action=importtheme&token=dd2815d248579d1ed20ad934bbd1d745 Richard

Richard Holland (bigdutch) 29 Sep 2017, 01:12

The above message is obviously from my local PC. I am thinking I might install Win 10 on a fresh HDD and put nothing on it apart from mySQL, Apache and PHP 5.x and see f I can get it to work. If it does I might narrow the problem. Regards Richard ps in the meantime I will have a look at what is in tools.php!

Richard Holland (bigdutch) 29 Sep 2017, 01:34

Tools.php line 2822 is just the PHP unzip script. I think this may be part of the problem or something unrelated. Cheers

Marek (marek) 29 Sep 2017, 08:28

unzip script is not related to the theme, it's a part of Prestashop platform. Maybe you just have to install zip plugin to your apache?

Richard Holland (bigdutch) 29 Sep 2017, 13:28

Hi Marek I have had a look on manual install of the theme but it is not that clear how things get into the database. Do I just unzip the theme into the Prestashop theme folder and Prestashop will then offer it as an installable option? Regards Richard

Marek (marek) 29 Sep 2017, 16:43

You can find a video of installation process here https://alysum5.promokit.eu/documentation/#!/installation_via_wp

Richard Holland (bigdutch) 29 Sep 2017, 17:23

Hi Marek I shall install Ubuntu Server on a test PC with PHP7, Apache24 an MySQL ad see what happens with PS 1.7.2 and Alysum 5.3 I think my laptop has got too much on it and I will re-format that later as well! Hopefully Alysum 5.3 will install correctly on the Ubuntu Server machine. Thank you for pointing out the install videos but I am confused with the updating part. If I want to do a fresh manual installation rather than via PS the video does not cover that - does it? Regards Richard

Marek (marek) 29 Sep 2017, 17:51

The best way to install the theme is through PS. In case of manual installation, you have to install each module separately by hands

Loading...