We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 05.02.18, 16:09
  • Reason: Closed
  • Comment: Glad to help!

FS#11257 - Cart issue

Hi Marek,

There are some issue with the cart page,
i can´t see my cart to remove or add a product.
When i click to CART or CHECKOUT, direct me to the checkout page.

Could you check it?
Thanks
Pablo

This ticket does not depend on any other tickets.

Marek (marek) 12 Dec 2017, 12:47

I just checked theme templates and found out the link is generated automatically by prestashop platform. Looks like the cause of the issue is some setting in your back office. Unfortunately I don't know what option exactly you have to manage

Pablo (HiReset) 12 Dec 2017, 13:00

Hi Marek,
Maybe the issue is related to the last update of the module (Shopping Cart 2.0.1) and the theme lose the correct link??
Because cart page exist: https://test.resetpriority.com/en/cart ,

Marek (marek) 12 Dec 2017, 13:06

Yes, I also saw that link works fine, but for some reason, the link in theme goes with a suffix ?action=show

Pablo (HiReset) 12 Dec 2017, 14:02

Hope you can find the solution,
otherwise its not possible to remove products from the cart.
Looking forward your news.

Marek (marek) 13 Dec 2017, 13:18

Try now, it should work

Pablo (HiReset) 13 Dec 2017, 13:40

Its seems to work again,
Thanks.

Pablo (HiReset) 31 Dec 2017, 10:49

Hi Marek,
do you remeber of this issue you fix it, is still working but, when you are loged whit an account its not working the CART link.
Could you check it?
thanks,
Pablo

Marek (marek) 31 Dec 2017, 11:03

do you still working on domain https://test.resetpriority.com ?

Pablo (HiReset) 31 Dec 2017, 16:12

Yes still the same domain. change to: admin227

Pablo (HiReset) 31 Dec 2017, 17:26

Hi Marek,
one more issue, the Blog comments is not working.
Could you check it? thanks

Marek (marek) 02 Jan 2018, 11:43

Could you please show me at a screenshot which cart link is not working?

Pablo (HiReset) 02 Jan 2018, 17:27

Hi Marek,
Attached the image,
the CART link only works when you are not logged, as a registered user is not working.
Looking forwards your news thanks.

Marek (marek) 02 Jan 2018, 18:09

Try now

Pablo (HiReset) 02 Jan 2018, 18:19

Nothing change, i clean cache...
but its still not working

Marek (marek) 02 Jan 2018, 18:37

Try once again

Pablo (HiReset) 02 Jan 2018, 18:45

The target its not right, the link is: https://test.resetpriority.com/en/order?step=1 it should be: https://test.resetpriority.com/en/cart

But now its not working neither without log out, nad the page /cart not exist

Marek (marek) 02 Jan 2018, 18:57

if you take a look into source code, you will see the link is https://test.resetpriority.com/en/cart?action=show but when you click, prestashop redirect it to https://test.resetpriority.com/en/order and I don't know why.
It could be some back office settings

Pablo (HiReset) 02 Jan 2018, 19:05

But now its not working neither if you are log out,
you can´t access to the cart in anyway,
you have been fixed it that preoviusly, and then i´ve noticed that not been working for registered customers.

I don´t change any back office settings, its strange,
please i need to fix it to be able to used the site, thanks

Marek (marek) 03 Jan 2018, 00:11

I spent over 2 hours to solve the issue and I figured out the reason is in the module "Klarna".
Try to disable it and if I'm right, I would like to get compensation 20 Euro for my time. I suppose it will be fair

Pablo (HiReset) 03 Jan 2018, 08:26

Hi Marek,
i appreciate your time spent on the issue,
but i disable and delete de module "Klarna" and nothing happens, still same problem cart link not working

I´ve tried to change using classic theme and CART link its working well,
and the link root send me to this: https://test.resetpriority.com/en/cart?action=show

The thing its that this issue is related to Alysum and if this important thing its not working, i can be able to used your theme, hope you understand it.

Looking forward to your news.

Pablo

Marek (marek) 03 Jan 2018, 11:23

Ok, keep trying to find a solution

Marek (marek) 03 Jan 2018, 13:59

Must be fixed now

Pablo (HiReset) 03 Jan 2018, 16:26

Hi Marek,
The link seems to work, but its not working well as before i notice this errors:
- I don´t recive any feedback when i add a product, and the button remains blocked on hover
- The preview on the cart of the top its not working.

Please could you check it?

Thnaks.

Marek (marek) 04 Jan 2018, 21:12

I didn't change anything, but it works fine for me

Pablo (HiReset) 05 Jan 2018, 13:05

Hi Marek,
do you remeber of this issue you fix it, is still working but, when you are loged whit an account its not working the CART link.
Could you check it?
thanks,
Pablo

Marek (marek) 05 Jan 2018, 13:09

I don't understand. The links works fine for me when I logged in
http://awesomescreenshot.com/0cf6f1nvbc

Pablo (HiReset) 06 Jan 2018, 09:17

Hi Marek,

Since you made the last change, the cart is not working properly.
When you add some products to the cart:

- the cart icon doesn´t refresh, and the customer doesn´t see the updated icon of the purchased items as before. The icon on the cart only refreshes after changing to another page. This is not good.
- Also, the pop up with the added product disappeared, this is mandatory for us to have.

If you test with the classic theme everything works properly.
I´m not sure what you did to make the cart working again, but I need to fix this issues.

Thanks,
Pablo

Marek (marek) 06 Jan 2018, 11:43

I see js error in the console what comes with amazon module. Try to disable it and check if the issue is still there

Pablo (HiReset) 06 Jan 2018, 20:28

Hi Marek I disable Amazon module but nothing, same problem.

Marek (marek) 07 Jan 2018, 12:50

Your website has strange behaviour, I had never seen it before.
Try now, it must work

Pablo (HiReset) 07 Jan 2018, 13:21

Hi Marek,
Its seems its work nicely again,
As you can see i´ve been working with a clean new prestashop and add your theme and some modules, adding just few css changes.
Its strange this kind of errors, i just want the site work properly, testing all the steps.
I will try to add the Amazon module so i hope it will work.

Thanks for your support,
Regards
Pablo

Loading...