Support will be provided with delays until 3 June. We are sorry for the inconvenience.
We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 06.05.18, 21:21
  • Reason: Closed
  • Comment: Glad to help!

Ticket #11790 - Problems with update

Hi!

I have updated the template and there are several errors now:

1. In the general page of products, the texts of availability and product description no longer appear (before the update they looked good)

2. In the brands page the thumbnails of products do not see correctly, before they looked good. (before the update they looked good)

3. In the product file, each accessory product occupies 100% of the screen (http://www.capsulebcn.com/shop/14-14-karakum-shirt-jacket-stone-white.html#/1- size-s)

4. In the product file I do not know how to activate “in the same category”

5. In ipad all lists or menu are aligned to the left in a row (attached screenshots)

BrandsNow.jpg (44.6 KiB)
Ipad1.jpg (569.9 KiB)
Ipad2.jpg (571.9 KiB)

This ticket does not depend on any other tickets.

Marek (marek) 05 Mar 2018, 14:02

Hi, Maya.
I see you have a lot of layout customisation, and I don't recommend you to update your theme. For now the solution is only one, restore from a backup the version what you have before.

Maya del Barrio (maya77) 05 Mar 2018, 14:10

Except for points 1 and 2, the other problems already existed before.

My customization is only css level, fonts and sizes, it does not interfere with the operation of the template.

I do not have backup, can you help me to fix these bugs?

Marek (marek) 05 Mar 2018, 14:24

I see your brands like this? is it correct?

Maya del Barrio (maya77) 05 Mar 2018, 15:44

No, this is the list of brands. The brand page is BrandsNow.jpg attached before: The file inside one brand, for example "Cluse"

I am checking that the bugs of the ipad, in your demo exist as well. (point 5)

Marek (marek) 05 Mar 2018, 15:47

You ask me to fix your code. Try to remove float:right

Maya del Barrio (maya77) 05 Mar 2018, 16:22

Ups, sorry!! I was thinking that this is a mistake because before the last update this is working fine, sorry again.

About point 1, I think is not my customization, I attached you a screenshot before and after update. Can you check it please?

1. In the general page of products, the texts of availability and product description no longer appear (before the update they looked good)__

Shop.jpg (159.7 KiB)
Marek (marek) 05 Mar 2018, 17:58

What update do you mean? as I can see you have 5.1.4 version

Maya del Barrio (maya77) 05 Mar 2018, 18:01

Really?? No, yesterday I received an email for the update and today I updated to alysum-v.5.1.6

Marek (marek) 05 Mar 2018, 18:02

I'm updating your theme manually, please wait a moment

Marek (marek) 05 Mar 2018, 18:06

Done.
Please make a backup of the theme and modules

Maya del Barrio (maya77) 05 Mar 2018, 18:24

Oh no! I already had this problem before: The update does not respect the columns selected in the products, you told me to use this code but now it is not working ...

@media (min-width: 1320px) and (max-width: 1550px) {
body.product-grid-3 .view_grid .product_list .grid-container {grid-template-columns: repeat(auto-fill, minmax(300px, 1fr));}
}

@media (min-width: 1550px) {
body.product-grid-3 .view_grid .product_list .grid-container {grid-template-columns: repeat(auto-fill, minmax(400px, 1fr));}
}

@media (min-width: 2000px) {
body.product-grid-3 .view_grid .product_list .grid-container {grid-template-columns: repeat(auto-fill, minmax(450px, 1fr));}
}

@media (min-width: 2050px) {
body.product-grid-3 .view_grid .product_list .grid-container {grid-template-columns: repeat(auto-fill, minmax(550px, 1fr));}
}

Marek (marek) 05 Mar 2018, 18:26

Try to add "!important" in the end, like this

@media (min-width: 1320px) and (max-width: 1550px) {
body.product-grid-3 .view_grid .product_list .grid-container {grid-template-columns: repeat(auto-fill, minmax(300px, 1fr)) !important;}
}
Maya del Barrio (maya77) 05 Mar 2018, 19:33

I have added !important but it does not change anything

Marek (marek) 06 Mar 2018, 11:44

Now I see.
change "product-grid-3" to "product-grid-4"

Maya del Barrio (maya77) 06 Mar 2018, 12:24

Yes, now it works, thank you!

About products "Out of stock", you told me to add this line of code but now it does not work either, where do I have to put it?

/web/themes/alysum/templates/catalog/_partials/miniatures/product.tpl

{if ($ product.show_availability == 1)}
<li> {$ product.availability_message} </ li>
{/ if}

Marek (marek) 06 Mar 2018, 12:32

to any place you want to see it

Maya del Barrio (maya77) 06 Mar 2018, 12:54

I try to put it in the photo as before but I think the file is different, because I can not make it work

Shop.jpg (85.4 KiB)
Marek (marek) 06 Mar 2018, 13:07

I just add it here:http://media.promokit.eu/screenshots/monosnap/scr_20180306_130650.png

Please check out how it works now

Maya del Barrio (maya77) 06 Mar 2018, 13:59

It works, thank you!!

About accessory products ... why do they look one under the other occupying 100% of the screen? I do not remember changing that, is it a mistake? Should they be seen in rows of 4?

You can see an example here:

http://www.capsulebcn.com/shop/14-14-karakum-shirt-jacket-stone-white.html#/1-size-s

Accessories.jpg (116.2 KiB)
Marek (marek) 07 Mar 2018, 15:48

Here is the fix:

.product-accessories .products:not(.nbs-flexisel-ul) > article {width:20%}
Maya del Barrio (maya77) 09 Mar 2018, 11:04

Thank you very much!

About "in the same category" products, how do I activate it? In your demo they appear but on my website I do not see the module or how to activate it

Marek (marek) 09 Mar 2018, 11:33
Maya del Barrio (maya77) 09 Mar 2018, 11:44

Where is the module "products in the same category"? In your module folder is not included

Marek (marek) 09 Mar 2018, 11:44

it's in your back office

Maya del Barrio (maya77) 09 Mar 2018, 11:56

I'm sorry because it's possible that I'm asking very obvious things, but the module is not in my back office and I don't see how or where download it ...

Marek (marek) 09 Mar 2018, 11:58

Maya del Barrio (maya77) 09 Mar 2018, 12:10

It does not show any product...

Marek (marek) 09 Mar 2018, 12:11

Give name a link please

Marek (marek) 09 Mar 2018, 12:22

looks like it's a bug.
Here is the fix:

.nbs-flexisel-ul .product-miniature {float:left}
Maya del Barrio (maya77) 09 Mar 2018, 12:28

I think it still does not work

Marek (marek) 09 Mar 2018, 12:32

please don't forget about prestashop cache

Maya del Barrio (maya77) 09 Mar 2018, 13:03

Ops, you're right sorry, it works

Last question:

5. In ipad all lists or menu are aligned to the left in a row, I checked it and the demo also looks like this. I attached screenshots

Ipad1.jpg (569.9 KiB)
Ipad2.jpg (571.9 KiB)
Marek (marek) 09 Mar 2018, 20:15
Maya del Barrio (maya77) 12 Mar 2018, 09:41

My ipad has a old software version, but the rest of the websites look good. Is there any way to fix those bugs?

Marek (marek) 12 Mar 2018, 10:20

I don't have an idea how to reproduce the issue to fix it

Maya del Barrio (maya77) 13 Mar 2018, 10:07

Is there any way to "force" horizontal lists? The issue is that the lists appear vertical and floating to the left

Marek (marek) 13 Mar 2018, 19:42

What lists do you mean? Could you please take a screenshot?

Maya del Barrio (maya77) 22 Mar 2018, 10:43

Hello,

I attached screenshots of the issues I see on ipad:

1. Div "header-right-side" looks to the left and out of place.

2. Div "flexmenu" is to the left and vertical listing.

3. Div "Pagination" is to the left and vertical listing.

4. Newsletter form arrow is outside the form on the right.

5. "Cookies": all the content on the left.

Ipad1.jpg (448.6 KiB)
Ipad2.jpg (0.99 MiB)
Marek (marek) 22 Mar 2018, 14:37
Maya del Barrio (maya77) 22 Mar 2018, 16:13

I have seen that in the most current versions it looks good. The problem is that users with older software will see it with bugs. There is no way to fix it? The rest of websites look good with that ipad

Loading...