We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Status: Waiting on customer

Ticket #11808 - Alysum does not work together with Customer registration module

I use a customer registration module that allows you approve customers before they can see prices and make orders:

When a customer is not logged in everything works ok. However, when a customer is approved by this module and logs in he all Alysum related fields disappear and are replace by error messages. See the attached image.

What is happening here and how can I solve this?

regis2.jpg (157.9 KiB)

This ticket does not depend on any other tickets.

Wim Roffel (wimroffel) 07 Mar 2018, 23:15

I found out that it is related to the cookies. When I delete the cookies the problem disappears. I checked the files and database but there is nothing suspicious there.

Wim Roffel (wimroffel) 08 Mar 2018, 09:47

It is only the cookies. When the site is in this state I can uninstall and delete the registration module and the problem still remains.

The only conclusion can be that a defective cookie is enough to shut down my website forever for someone. This is not how things are supposed to work.

Marek (marek) 08 Mar 2018, 10:49

Hi, Wim.
Is the module installed and enabled now? can I test registration process?

Marek (marek) 08 Mar 2018, 12:23

Hi, Wim.
Is the module installed and enabled now? can I test registration process?

Wim Roffel (wimroffel) 08 Mar 2018, 12:33

Yes, it is.

Unfortunately things have worsened and I am now not even able to get back a normal situation by removing cookies.

Marek (marek) 08 Mar 2018, 12:45

How can I reproduce the issue?

Wim Roffel (wimroffel) 08 Mar 2018, 12:52

Make an account - you will be told that it needs to be approved.
Go to the backoffice. In Modules find deluxeregistrovalidado. Choose configure for that module. Inside it choose the tab for approval and approve your email address.
No go back to the front office and login with this account

Marek (marek) 08 Mar 2018, 13:01

I don't see such module in your back office

Wim Roffel (wimroffel) 08 Mar 2018, 13:22

Now it should work. You need to try a new email address.

You can also try this combination:
user: [email protected]
password: secret

Marek (marek) 08 Mar 2018, 13:34

Now I see the issue http://media.promokit.eu/screenshots/monosnap/scr_20180308_133214.png

1. The theme can't support all existing modules, I suppose you understand that.
2. I can try to make it work (despite I'm not obligated to do that and your 1 star rating) but I need access to your server via FTP

Wim Roffel (wimroffel) 08 Mar 2018, 15:01

For this I will need to give you access to the production server instead of the test server. So I have changed my profile accordingly. All information is now there.

Marek (marek) 09 Mar 2018, 10:41

Hi, Wim.
But I still don't see credentials in your profile

Wim Roffel (wimroffel) 09 Mar 2018, 10:51

Another try...

Marek (marek) 09 Mar 2018, 11:52

I'm not able to open "themes" folder

Status:      	Retrieving directory listing of "/public_html/themes"...
Command:	PASV
Response: 	227 Entering Passive Mode (145,131,10,250,253,33).
Command:	MLSD
Response: 	150 Opening ASCII mode data connection for MLSD
Response: 	425 Unable to build data connection: Operation not permitted
Error:        	Failed to retrieve directory listing
Wim Roffel (wimroffel) 09 Mar 2018, 12:06

This provider has a rather bad FTP connection. Sometimes it breaks down. It happens to me about once a week. The solution is to logout and try connecting again.

But this is not related to the problem. The other site (themadag.com) is with a different hosting provider where the FTP never gives problems.

Marek (marek) 09 Mar 2018, 12:06

ok, I'll try more

Wim Roffel (wimroffel) 13 Mar 2018, 14:43

preliminary result: an entry in the ps_customer_group table with the id_group value zero seems to be the problem. I have sent a message to the creator of the module with a question about this.

Marek (marek) 13 Mar 2018, 16:33

Sorry for the delay, I was out these days.
Ok, please let me know once you will have a reply