We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation

Promokit HelpdeskAlysum AMP theme

  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 11.04.18, 12:27
  • Reason: Closed
  • Comment: Glad to help!

Ticket #11809 - Can not add new products or edit and save them on prestashop 1.7.3

HI,
I can not add new products or edit and save them on prestashop 1.7.3.

After clicking on save button, it shows the message: Configuration updated but nothing is saved.

Regards.

This ticket does not depend on any other tickets.

Marek (marek) 07 Mar 2018, 13:51

Hi, Victor.
Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your back office

Victor iCreativa (icreativame) 07 Mar 2018, 14:33

Hi Marek, you got it!

Let me know if you need something else.

Regards.

Marek (marek) 07 Mar 2018, 15:15

I see the issue but I'm not sure it's related to the theme. I have tested our demo and all works fine. Could you please switch to the default theme and check out how it works? Please notice, you can lose some configuration if you will switch the theme

Victor iCreativa (icreativame) 09 Mar 2018, 07:56

Hi marek,
if you create a new product and set the title quickly saving it, then the product is saved. Afterthat if you try to update the product description, price, etc it doesn't work.

The format of the price is wrong: 1.2,1,00 €. It should be 12,10 €

Regards.

Victor iCreativa (icreativame) 09 Mar 2018, 09:02

Hi Marek, I appreciate that you can tell me how to fix these 2 points ASAP.
Regards.

Marek (marek) 09 Mar 2018, 09:55

But you described the issue with your back office, right? How it's related to the theme?

Victor iCreativa (icreativame) 09 Mar 2018, 09:57

I don't know. Do you think that the issue is related with the hosting / permissions?

Marek (marek) 09 Mar 2018, 10:10

I just tested the theme on prestashop 1.7.3 on our server and there is no such issue.

Victor iCreativa (icreativame) 09 Mar 2018, 10:25

The format of the price is wrong: 1.2,1,00 €. It should be 12,10 €
How can i fix this?

Marek (marek) 09 Mar 2018, 10:27

There is nothing to fix because it's not a bug. you have to configure it in your back office and it's not related to the theme as well

Marek (marek) 09 Mar 2018, 10:35

I have found similar ticket https://support.promokit.eu/index.php?do=details&task_id=11816 Could you please also switch back to default theme and check the issue with products?

Victor iCreativa (icreativame) 09 Mar 2018, 10:43

Please, before switching back to default, I need you to fix the format issue of the price: 1.2,1,00 €. It should be 12,10 €

Marek (marek) 09 Mar 2018, 11:29

There is no any option in the theme's code what changed price format. You have to find where it's changes in the back office

Marek (marek) 09 Mar 2018, 20:41

Do you have access to your server error logs. It would help me to figure out the reason of the issue

Victor iCreativa (icreativame) 09 Mar 2018, 21:30

Please, try to create one new product adding the name and the price WITH DECIMALS. Then try to update the price WITH DECIMALS of one product.

Marek (marek) 09 Mar 2018, 22:13

The issue is not with the price. There is impossible to save anything. Do you have access to your server error logs? It would help me to figure out the reason of the issue

Marek (marek) 09 Mar 2018, 22:33

I also noticed you are using php 7.1.x Is it possible for you to switch to php 7.0.x just for a test?

Marek (marek) 09 Mar 2018, 22:37

I just switched to php 7.1 on my localhost and there is no such issue as well. Keep working to find out what's wrong

Marek (marek) 09 Mar 2018, 22:48

I have found another customers who already installed prestashop 1.7.3 and tested product management there - all works fine with any issues

Victor iCreativa (icreativame) 12 Mar 2018, 15:14

Hi Marek, now you have access to the server error logs via ftp > error_log

Marek (marek) 12 Mar 2018, 21:53

The issue must be fixed now. Please check it out

Victor iCreativa (icreativame) 21 Mar 2018, 12:41

Thanks Marek. Could you explain how do you fix it?

Marek (marek) 21 Mar 2018, 15:47

The module simple blog has been disabled, that is the fix as I remember

Victor iCreativa (icreativame) 29 Mar 2018, 12:23

So, if the blog is the problem, how can i use the blog?

Marek (marek) 29 Mar 2018, 12:24

The issue has been fixed in the last update

Loading...