We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 15.03.18, 13:16
  • Reason: Closed
  • Comment: Glad to help!

Ticket #11835 - [PrestaShopDatabaseException]

I still can not work in the Turkish language. I do not know why. trying in different languages.
I repeat the way I watched.
I’m installing PrestaShop.
I am installing the theme.
I choose Turkish language.
I am using the default language type in settings.
and the system is crashing.

I added the language myself as a different way and got a different error message.
there are errors on the front page and the back page.
Would you investigate.

This ticket does not depend on any other tickets.

Marek (marek) 11 Mar 2018, 09:16

Have you tested Turkish Lang with default prestashop theme?

Süleyman Tarım (slymntrm) 11 Mar 2018, 09:26

I added the turkish language myself, without doing any translate by hand

Marek (marek) 11 Mar 2018, 09:39

We have to figure out is the issue exist before installing the theme or not

Süleyman Tarım (slymntrm) 11 Mar 2018, 09:44

Look
There is no problem when using the theme in other languages.
theme works nicely.
but.
turkish language system crashes.

Marek (marek) 11 Mar 2018, 09:54

Please test Turkish language with default "Classic" theme

Marek (marek) 11 Mar 2018, 10:06

I need to test it out myself. Could you please reinstall your prestashop, and I'll try to install Turkish language myself

Süleyman Tarım (slymntrm) 11 Mar 2018, 10:12

If you choose English from the front page, the speed of the page is fine.
but when you choose turkish you are slowing down and the page can not be loaded for a long time.

Marek (marek) 11 Mar 2018, 10:13

I need to test it out myself. Could you please reinstall your prestashop, and I'll try to install Turkish language myself.

Süleyman Tarım (slymntrm) 11 Mar 2018, 10:16

Reinstall prestashop

Marek (marek) 11 Mar 2018, 10:32

I can't login to your back office http://flaviano.lusemta.com/adminflavi

Süleyman Tarım (slymntrm) 11 Mar 2018, 10:34

current information is available on my profile

Marek (marek) 11 Mar 2018, 10:51

As I can see now, you have wrong permissions for /app/cache. Please set 777 for all folders ald files in the /app/cache

Süleyman Tarım (slymntrm) 11 Mar 2018, 11:02

I applied as you say

Marek (marek) 11 Mar 2018, 11:07

Yes, I see. Something wrong is going on your server. I'm not sure it's related to the theme, but I'll try to figure that out. For now would be great to get access to your server error logs.

Süleyman Tarım (slymntrm) 11 Mar 2018, 11:08

what should I do

Marek (marek) 11 Mar 2018, 11:09

If you don't know please ask your hosting provider to let you know where to get Server error logs. You can even ask then why it loads slow with Turkish language

Süleyman Tarım (slymntrm) 11 Mar 2018, 11:14

classic theme no problem?
there is alysum problem
example this page is still not working
http://flaviano.lusemta.com/index.php?controller=prices-drop

Marek (marek) 11 Mar 2018, 11:17

If you need a help please do what I asked you for

Süleyman Tarım (slymntrm) 11 Mar 2018, 11:20

this page probably does not work right

Ekran Resmi 2018-03-11 13.19.... (272.6 KiB)
Marek (marek) 11 Mar 2018, 11:21

please ask your hosting provider to help you

Süleyman Tarım (slymntrm) 11 Mar 2018, 14:43

flaviano.lusemta.com/classes/controller/AdminController.php

the following page is deleted from the self
you sent the original

Marek (marek) 11 Mar 2018, 16:58

I didn't delete any pages or files

Süleyman Tarım (slymntrm) 11 Mar 2018, 17:39

I noticed something.
The problem occurs when i is in the address bar.
  other executive pages are working.
for example,
- Advanced Parameters → Performance
http://flaviano.lusemta.com/adminflavi/index.php/configure/advanced/performance?_token=uq4drl7f3aerp26qloktw94oudıoavwqq3jg3dxgt4 to

sample corrupt page
Theme & Logo> See Theme (AdminThemes) There is the letter "i"
http://flaviano.lusemta.com/adminflavi/index.php?controller=adminthemes&token=783433708d5e349526889401d9041707

Marek (marek) 11 Mar 2018, 17:40

Do you have a possibility to install prestashop on your localhost and test it out there?

Süleyman Tarım (slymntrm) 11 Mar 2018, 17:53

what will change as long as it does not work in the living.
please find a solution to this error.

Marek (marek) 11 Mar 2018, 17:53

It's not the theme issue

Süleyman Tarım (slymntrm) 11 Mar 2018, 17:53

Exception in Access.php line 73:
The slug ROLE_MOD_TAB_ADM�NDASHBOARD_READ is invalid
in Access.php line 73
at AccessCore::isGranted(array('ROLE_MOD_TAB_ADM�NDASHBOARD_READ'), '1') in AdminController.php line 743
at AdminControllerCore→access('view', false) in AdminController.php line 757
at AdminControllerCore→viewAccess() in Controller.php line 204
at ControllerCore→run() in Dispatcher.php line 428
at DispatcherCore→dispatch() in index.php line 96

� that sign may be causing the error

Marek (marek) 11 Mar 2018, 18:25

Do you have a possibility to install prestashop on your localhost and test it out there?.

Süleyman Tarım (slymntrm) 12 Mar 2018, 14:15

I tried a lot of roads but it does not happen.
please install it in your own local language, please try to install a language package.
you can see the problem better.
I would like to use version 1.7.

Marek (marek) 12 Mar 2018, 23:13

I have make a test installation of fresh prestashop 1.7.3 with Turkish language and the theme. All works fine for me. So the issue is definitely with your server configuration.
Here is my video https://youtu.be/b7gpebSiJp0

Süleyman Tarım (slymntrm) 13 Mar 2018, 10:15

I tried it on my own local account.
worked successfully.
I loaded this system into the living thing and it was still broken.

Marek (marek) 13 Mar 2018, 10:19

Something wrong with your server. Here is another customer with Turkish language and all works fine there https://www.beautysecretshop.com

Süleyman Tarım (slymntrm) 13 Mar 2018, 11:12

prestashop 1.6 theme upluad
504 Gateway Time-out
The server didn't respond in time.

Marek (marek) 13 Mar 2018, 11:14

Do you have decided to switch to prestashop 1.6?

Süleyman Tarım (slymntrm) 13 Mar 2018, 11:17

I have system 1.6
after that I will continue from here.
I'm getting this error when loading a theme

504 Gateway Time-out
The server didn't respond in time.

Marek (marek) 13 Mar 2018, 11:20

Give me a link where could I see that?

Marek (marek) 13 Mar 2018, 12:07

There is no Alysum theme. I need to install it?

Süleyman Tarım (slymntrm) 13 Mar 2018, 12:22

theme folder exists in dos.zip

Marek (marek) 13 Mar 2018, 12:23

Do I need to install the theme?

Süleyman Tarım (slymntrm) 13 Mar 2018, 12:26

yes

Marek (marek) 13 Mar 2018, 12:47

I just installed the theme with no problems http://flavi.lusemta.com/index.php

Süleyman Tarım (slymntrm) 13 Mar 2018, 12:52

thank you
full screen slide not working right what to do

Marek (marek) 13 Mar 2018, 12:59

You had enabled cache. Now it's ok

Süleyman Tarım (slymntrm) 13 Mar 2018, 13:17

the logo on the main page remains below how can we pull up
http://flavi.lusemta.com/index.php

Marek (marek) 13 Mar 2018, 13:18

Because it's too large. Try to upload smaller image

Süleyman Tarım (slymntrm) 13 Mar 2018, 13:26

thank you.
I told the server company of the errors in version 1.7 that they could not find anything.

Marek (marek) 13 Mar 2018, 13:27

The best way for you to make sure that the issue with server is to test it on your local computer or another server

Süleyman Tarım (slymntrm) 13 Mar 2018, 17:25

homepage images in mobile version are getting smaller. why

Süleyman Tarım (slymntrm) 13 Mar 2018, 17:44

flavi.lusemta.com

Marek (marek) 13 Mar 2018, 17:50

But how do you think it should be?

Süleyman Tarım (slymntrm) 13 Mar 2018, 18:11

this

hhh.png (751 KiB)
Marek (marek) 13 Mar 2018, 18:19

Try to add following CSS to the Theme Settings > Custom CSS:

#fullpageslider .main_image {
max-width: 10000%;
width: auto;
height: 100%;
position: absolute;
}
Süleyman Tarım (slymntrm) 13 Mar 2018, 19:15

it broke more

Marek (marek) 13 Mar 2018, 19:17

I don't see that code in your website. Where did you add it?

Süleyman Tarım (slymntrm) 13 Mar 2018, 19:22

I've tried.
I was gone before.

Marek (marek) 13 Mar 2018, 19:27

I do not understand. I just tested it directly in your website and all worked fine

Süleyman Tarım (slymntrm) 13 Mar 2018, 19:51

I added again.
I have not added pictures and text on the full slide.
Consider.

Süleyman Tarım (slymntrm) 13 Mar 2018, 21:31

heyyy ??

Marek (marek) 14 Mar 2018, 10:52

I still don't see that code in your website

Süleyman Tarım (slymntrm) 14 Mar 2018, 10:59

See you uploaded.

Süleyman Tarım (slymntrm) 14 Mar 2018, 11:03

how can i make this pictorial menu

Ekran Resmi 2018-03-14 13.02.... (711.8 KiB)
Marek (marek) 14 Mar 2018, 11:12

Go to menu settings and add images there

Süleyman Tarım (slymntrm) 14 Mar 2018, 11:18

could you give me more detailed information.

Marek (marek) 14 Mar 2018, 11:37

I forgot you are using prestashop 1.6. And there is no exactly the same option like you showed on the screenshot.
Here is screenshot how to add an image in your menu

Süleyman Tarım (slymntrm) 14 Mar 2018, 15:05

custom css add
#fullpageslider .main_image {
max-width: 10000%;
width: auto;
height: 100%;
position: absolute;
}

Consider

Marek (marek) 14 Mar 2018, 17:46

There is no images in the slider now to see the effect

Süleyman Tarım (slymntrm) 15 Mar 2018, 07:08

look again

Marek (marek) 15 Mar 2018, 10:15

The image is ok

Süleyman Tarım (slymntrm) 15 Mar 2018, 10:21

mouse scrolls down
the pictures are shifting

Marek (marek) 15 Mar 2018, 11:00

But that is the view for mobile devices, nobody have a mouse to use a phone

Süleyman Tarım (slymntrm) 15 Mar 2018, 11:06

but it works right on your own page.
https://alysum5.promokit.eu/fullpage/en/

I look at my mobile phone again, it is becoming a slip.
it also does not display the picture on the desktop screen.

Untitled-2.jpg (380.9 KiB)
Marek (marek) 15 Mar 2018, 12:50

1. Do you mean you want to scroll down to the footer?
2. added a fix to your custom CSS

Süleyman Tarım (slymntrm) 15 Mar 2018, 13:05

thank you

Loading...