We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation

Promokit HelpdeskAlysum AMP theme

  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 08.07.18, 14:15
  • Reason: Closed
  • Comment: Please create a new ticket

Ticket #11852 - Preset change step by step

Hello.
I can’t change present (layout). Example: I need to use electronic or classic template but when I choose it and apply change nothing special happened. I see some changes in header but whole layout is different than in examples. Only ‘alysum’ vriant is fully available.

This ticket does not depend on any other tickets.

Marek (marek) 14 Mar 2018, 17:47

Hi, Sebastian.
Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your back office

Sebastian Szaraniec (szaran) 14 Mar 2018, 20:29

Back office - you mean access to my shop presta admin page?

Marek (marek) 14 Mar 2018, 20:53

Yes, right

Sebastian Szaraniec (szaran) 14 Mar 2018, 21:37

Done.

Marek (marek) 15 Mar 2018, 10:38

I have found syntax error in the electronics config file. Please upload attached file to the /modules/pk_themesettings/presets

electronics.json (10.8 KiB)
Sebastian Szaraniec (szaran) 15 Mar 2018, 10:58

File uploaded, but still doesn't works properly. When I choose for example classic variant I see something like that (attachment. I see two banner showcases and nothing happened special with rest ot layout, especially vertical navigation

Zrzut ekranu 2018-03-15 o 10.... (2.16 MiB)
Marek (marek) 15 Mar 2018, 11:03

I'll check your back office settings and try to make the view the same.

Sebastian Szaraniec (szaran) 15 Mar 2018, 11:05

Thanks, please focus on two variants of layout - classic and electronics.

Marek (marek) 15 Mar 2018, 12:34

Electronics preset has been configured http://weselnystolik.pl

Sebastian Szaraniec (szaran) 15 Mar 2018, 12:37

Something weird is happening - after choosing another one (like classic) and back to electronic the layout is damaged.

Marek (marek) 15 Mar 2018, 12:43

you have to enable page builder and Footer builder in the theme settings

Sebastian Szaraniec (szaran) 15 Mar 2018, 12:45

More details pls.. What should I do when I'd like to change preset to see layout variant to be consistent with your original template?

Marek (marek) 15 Mar 2018, 12:52

You can find "homepage_builder" option in the config I sent you and set it to "1" to make this option automatically enabled

Sebastian Szaraniec (szaran) 15 Mar 2018, 13:14

Let's resume. You sent me .json file with configuration which I putted into my ftp catalogue.

In presta admin when I want change template variant a need to choose proper one in "preset" menu and next in HomePage Builder mark "Yes". It will work or should I also make changes manually in .json file?

Marek (marek) 15 Mar 2018, 13:16

I sent you son config before and there are disabled content builders. so you just have set "1" for homepage_builder and footer_bulder parameters

Sebastian Szaraniec (szaran) 15 Mar 2018, 15:29

Config was for electronic. Understand it, but sill when I try to change layout from for example 'electronic' to 'classic' are differences between (banners, typography, header etc.) results and demo page –> https://alysum5.promokit.eu/classic/en/

Marek (marek) 15 Mar 2018, 15:49

Yes, because classic preset for Page builder is not ready yet, I'll let you know when I'll finish with that

Sebastian Szaraniec (szaran) 15 Mar 2018, 15:51

Clear. Let me know pls when will be finished. Thanks.

Marek (marek) 15 Mar 2018, 18:42

Done. Please check out Classic layout

Sebastian Szaraniec (szaran) 16 Mar 2018, 21:56

Thanks. It works fine.. but when I introduced SSL protocol on my website links (header, catalog, menu, cart etc.) doesn't works and product images disappeared. Any idea what happened?

Sebastian Szaraniec (szaran) 16 Mar 2018, 22:54

Ok, forget pls. Fixed.

Marek (marek) 16 Mar 2018, 23:17

Glad you solved the issue

Sebastian Szaraniec (szaran) 18 Mar 2018, 21:19

Marek, I have the problem with ps_categorytree widget. On home page there is no results –> the category container is empty. Help..

Marek (marek) 19 Mar 2018, 10:42

Hi, Sebastian.
That is a native prestashop module and there is a problem with it in any theme.
Try to change module settings

Sebastian Szaraniec (szaran) 19 Mar 2018, 12:11

Work fine with "home category" checked.

Ok, thank for your patient but I preparing launch if my shop so I will have many detailed questions. When I'm looking at demo template at https://alysum5.promokit.eu/classic/en/ I see differences between mine and yours template. Please, look at screens.

- Testimonials - how to reach effect like on your template (sidebar)
- sticky menu - doesn't work in my shop (Sticky Menu option checked 'yes')
- how to put for example 'bestsellers' module from sidebar to main column? When I try to do it in "layout builder" I see bestseller bud with products in vertical orientation.
- is it possible to replace logo file with SVG file?

differences.png (35.1 KiB)
Marek (marek) 19 Mar 2018, 12:40

1 and 2. I need access through FTP to check out what's wrong
3. use "product list" widget to display bestsellers
4. Yes, it's possible but require additional coding

Sebastian Szaraniec (szaran) 19 Mar 2018, 13:41

1 and 2 - access granted.

Marek (marek) 19 Mar 2018, 14:20

Fixed

Sebastian Szaraniec (szaran) 20 Mar 2018, 09:28

Thanks, but drop-down menu still looks different. Please, look at my file differences.png

Marek (marek) 20 Mar 2018, 10:36

Sorry, I missed that.
Here is CSS fix:

#top-menu {height: 100%}
Sebastian Szaraniec (szaran) 20 Mar 2018, 12:24

Where put it? In configuration of template in customer css/js?

Marek (marek) 20 Mar 2018, 12:29

Go to Theme Settings > Custom CSS tab

Sebastian Szaraniec (szaran) 20 Mar 2018, 12:39

Still doesn't work

Marek (marek) 20 Mar 2018, 12:44

it works for me. try another browser or clean browser's cache or incognito tab

Sebastian Szaraniec (szaran) 20 Mar 2018, 12:56

Will check it later, probably you're right.
Can you tell me how to put social icons to the left of the column? Please, check the attached file.

social.png (4.6 KiB)
Marek (marek) 20 Mar 2018, 13:07

Sebastian Szaraniec (szaran) 20 Mar 2018, 14:38

Yes, I did this, but I don't know how to force social icons to align left of the right column. Is there any class in widget settings to figure it out?

Marek (marek) 20 Mar 2018, 22:39

I just did it for you

Sebastian Szaraniec (szaran) 21 Mar 2018, 10:26

Thanks. Is it possible to change blog home page from 2 columns to 3 columns?

Marek (marek) 21 Mar 2018, 12:08

You can find necessary option to switch columns number in the BLOG → USTAWIENIA

Sebastian Szaraniec (szaran) 02 May 2018, 13:30

Hi Marek. I have trouble - somehow (it is of course my fault) I lost content from homepage (category tree, banners etc). I don't know how to restore it.

Marek (marek) 02 May 2018, 13:33

Hi, Sebastian.
Try to disable this option http://take.ms/Immp0

Sebastian Szaraniec (szaran) 02 May 2018, 13:52

Thanks Marek it helps.
I'm preparing set of question to you - I hope, that it will be enough for me before start my new shop. But right now I'm trying to find some translation which are incompatibile with polish language, so maybe you will know where I can find it? I mean words "aktyvni filtry". I've tried hundred times and can't find this..

And a second thing: when I click "yes" to Show Subcategories in Alysum setting there is someting wrong with displaying subcats. Please, take a look at attached file.

filters-name.png (32.8 KiB)
subcategories-view.png (126.5 KiB)
Marek (marek) 02 May 2018, 17:42

Strange, it should be available in back office. But there is also another way to translate it. Open the file /themes/alysum/translations/pl-PL/ShopTheme.pl-PL.xlf and find there necessary phrase

Sebastian Szaraniec (szaran) 02 May 2018, 23:39

I found that file, and locate improper translation. Fixed that and uploaded on server but on page I still see previous translations. Any idea?

And the second thing?

The problem with page builder is back. I can't restore it to classic view. I don't know how to do it (proper order)

Sebastian Szaraniec (szaran) 03 May 2018, 21:26

I have critical error connected with probably blog module. Right now I havent access to Alysum Menu - below te screen with error.

error.jpg (588.5 KiB)
Marek (marek) 03 May 2018, 22:15

I have fixed issue with blog, but there is another problem, what require theme update. Please make a backup and update the theme through Theme Settings

Sebastian Szaraniec (szaran) 04 May 2018, 07:50

Backup done, theme update also.

Marek (marek) 04 May 2018, 11:13

Is it ok now?

Sebastian Szaraniec (szaran) 04 May 2018, 14:18

There is no errors but due to theme update there some elements were changed and I lost css with my fixes.

At the first sight:
1. There is no sticky menu (top). I see te option but when is ON slider with foto has bad position
2. Below the topmenu appears different spacer the same below the photo slider.
3. On pages I've lost H1 titles (?)
4. Blog post on home page and blog pages have no photos.

General question: from time to time I had big problem with home page. Any attempt to change something on page builder resulted with big fuckup. After that I was finally able to get look which I wanted but.. another change damaged everything. I will be glad to help with set the mockup like this –> https://alysum5.promokit.eu/en/, with the exception of header and slider (only product content and footer should be changed).

Marek (marek) 05 May 2018, 11:08

Hi, Sebastian.
1. Fixed
2. Please take a screenshot
3. Where do you need to have H1 tag?
4. Maybe because you didn't add an image to your posts?
5. I just imported you "alysum" preset. Please test it out

Sebastian Szaraniec (szaran) 05 May 2018, 22:28

1. Thanks.
2. Right now it looks good - probably due to importing alysum preset by you.
3. Marked as (2) on image - in previous version of theme it was here. Really. On the same screen I marked Blog link (1) - how to remove black label "blog"?
4. Maybe, but when I'm trying to upload file appear another error screen (please, see screenshot)
5. Thanks, perfect.

I see the new option - login with Facebook. How turn it on?

blog.jpg (437.1 KiB)
screen.jpg (355 KiB)
Marek (marek) 06 May 2018, 14:22

3. You just have to remove "Sub Title" in the menu item settings
4. Try to set permissions to write (777) for the folder /modules/ph_simpleblog/covers/

Sebastian Szaraniec (szaran) 07 May 2018, 12:08

Marek, there is no folder such as /modules/ph_simpleblog/cover. I see only covers_cat. I should create it and set permission?

Remain two issues: Facebook login and headers on category pages. I marked it in previous massage.

Marek (marek) 07 May 2018, 12:23

Yes, try to create that folder.
As for Facebook login, please check is the module installed and enabled. You also have to put your API key there.
And what's wrong with header on category pages?

Sebastian Szaraniec (szaran) 07 May 2018, 12:27

Problem is that after template update the header with the name of category dissapeared :-) A propos FB module: which one do you prefer? Is that one ok?

https://www.prestashop.com/forums/topic/494491-free-module-facebook-login-registration/

Marek (marek) 07 May 2018, 12:40

1. Could you please take a screenshot, because I don't see the issue
2. Facebook login module is already in your back office, you don't have to add any other one

Sebastian Szaraniec (szaran) 07 May 2018, 12:50

Here you are (attached file).

By the way, please look at filters. I can't manage with proper translation of this. I change "aktyvni filtry" (active filters) na "wybrane filtry" in file you wrote earlier but there is no effect.

screenshot-header.jpg (441.7 KiB)
Marek (marek) 07 May 2018, 13:01

This option has to be enabled http://take.ms/45EnD

Sebastian Szaraniec (szaran) 09 May 2018, 11:46

Marek, could you take a look at the previous messages about filters? I can't change this translations.
In dropdown menu appears the problem - can't change width of it due to long category names –> screenshot.

menu.jpg (92.2 KiB)
Marek (marek) 09 May 2018, 15:14

The fix for menu:

.pk-menu-horizontal ul li.level-1 ul li a span {white-space:normal}

As for translation, it should work now under Shop.Theme.Global domain

Sebastian Szaraniec (szaran) 10 May 2018, 11:33

I've putted this to customer CSS and doesn't work.

Marek (marek) 10 May 2018, 18:53

The issue has been fixed. Please check it out

Sebastian Szaraniec (szaran) 10 May 2018, 22:20

Still the same :-(

Zrzut ekranu 2018-05-10 o 22.... (1.18 MiB)
Marek (marek) 10 May 2018, 22:30

Don't forget about your browser's cache. All is ok for me https://www.dropbox.com/s/vcfppvpmyfzwg3s/Screenshot%202018-05-10%2022.30.20.png?dl=0

Sebastian Szaraniec (szaran) 11 May 2018, 00:19

Works fine now, but it was strange because during my tests I'm using browser why "disable cache" mode on. Nevermind..

Marek, I'd like to change some elements on product page - for example some element remove or change some styles. Please, take a look on screenshot and tell me pls which file .tpl or .php is responsible for that? Next issue - I see, that some styles are built in code and can't change it editing css files..

product-page.jpg (262.3 KiB)
styles.png (737.2 KiB)
Marek (marek) 11 May 2018, 11:39

You have to edit the file /themes/alysum/templates/catalog/product.tpl
to override the inline styles, try to use "!important" after your styles, like this:

body {font-size:14px !important}
Sebastian Szaraniec (szaran) 11 May 2018, 21:03

Thanks. Works fine.
Where could I find translation for word "quality". I've searched hundred times translation files without positive effect (screenshot).

Technical question: I made a lot of changes in css styles and some in template files and noticed that appeared new version of Alysum. Is it critical patch? I'm afraid that update will disrupt whole my previous work.

quality.png (79.5 KiB)
Marek (marek) 11 May 2018, 21:34

1. Yes, it's translation bug. We will fix it as soon as possible. You can fix it directly in the file /modules/productcomments/views/templates/front/productcomments.tpl.
find the line

<label>{$criterion.name}</label>

and change to

<label>{l s='YOUR TEXT' mod='productcomments'}</label>

2. you can download latest version from themeforest and see which files was updated in the folder: /updates/5.2.X

Sebastian Szaraniec (szaran) 25 Jun 2018, 13:22

I need your help!

Sebastian Szaraniec (szaran) 25 Jun 2018, 13:22

I need your help!

Marek (marek) 25 Jun 2018, 13:22

Please describe your problem

Sebastian Szaraniec (szaran) 26 Jun 2018, 11:02

He Marek. Sometimes during adding new product appears error like this (attachement). How to manage with this problem?

Zrzut ekranu 2018-06-26 o 11.... (639.4 KiB)
Marek (marek) 26 Jun 2018, 11:16

As I can see, there is no permissions to write cache. Try to set CHMOD 777 for the folder /shop/app/cache

Sebastian Szaraniec (szaran) 26 Jun 2018, 11:18

BTW, your template looks better than good. Kudos for you, because the whole shope also looks great. Probably it will be the last portion of my questions, butt better ask the proffessional than make mistakes. So, the are my asks - please answer me:

1. How to add to product page slider modules with for example: "20 products with this category" or "Customers also bought.."
2. How to manage left side bar? I need to have only catalogue filters, I don't want colors, price filters.
3. How to add to left sidebar module "new products" below the filters?
4. How to get rid images from left sidebar?
5. I'd like to add stroke or shadow to expanded search bar (like cart)?

Sebastian Szaraniec (szaran) 26 Jun 2018, 11:23

CHMOD setted for subfolder 'cache'. Still doesn't work. Any idea?

Sebastian Szaraniec (szaran) 26 Jun 2018, 11:36

Ok, this problem solved - disk quota exceeded :(

Marek (marek) 26 Jun 2018, 11:39

1. You can find full "product page" description here https://alysum5.promokit.eu/promokit/documentation/#product-page See the name of necessary blocks
2. Go to the settings of the "Faceted Search" module
3. Go to "Design" → "Positions", click "Transplant a module", then select your module and necessary hook
4. Go to "Design" → "Positions", http://take.ms/JyuaI

5. add following CSS:

body .pk_search_result {box-shadow: 0px 5px 5px 0px rgba(0, 0, 0, 0.20), inset 0px 1px 1px 0px rgba(255, 255, 255, 0.95);}

6. Try to clear prestashop cache

Sebastian Szaraniec (szaran) 26 Jun 2018, 11:42

Thanks a lot. I will check it.

Sebastian Szaraniec (szaran) 26 Jun 2018, 11:52

Ad. point 5 - added to Customer CSS/JS and no effect. I see also that is something wrong with z-index, because on the search results layer appears "NEW" label.

Marek (marek) 26 Jun 2018, 12:22

5. maybe you have enabled CSS cache, please check it out
6.

body .pk_search_result {z-index:9999}
Sebastian Szaraniec (szaran) 26 Jun 2018, 12:33

No, a have cache disabled. Look at this pls.

Zrzut ekranu 2018-06-26 o 12.... (948.9 KiB)
Sebastian Szaraniec (szaran) 26 Jun 2018, 21:29

Another question. How to add to product page 2 blocks (I can't see this possibility in template):

1. Shipping info
2. Product type: new / used / personalized

Marek (marek) 27 Jun 2018, 09:01
Sebastian Szaraniec (szaran) 27 Jun 2018, 10:07

Yes, CSS works fine - it was my fault.

I thought about solutions (check image) –> point 2. I can set point 1 in backoffice (product catalog) and this information appears on product page (product details tab). But with shipping info (point 2) is problem.

In backoffice I can set general shipping info for products, and on each product in catalog I can set information about different method of shipping. And now I have the question - how to display this information on product page? It's really important due to EU law.

screen.jpg (90.6 KiB)
shipping.jpg (324 KiB)
stan.jpg (255.8 KiB)
Sebastian Szaraniec (szaran) 27 Jun 2018, 16:09

1. You can find full "product page" description here https://alysum5.promokit.eu/promokit/documentation/#product-page See the name of necessary blocks

Ad.1 I cant see posibillity to turn on module "in the same category". How to do it?

2. Go to the settings of the "Faceted Search" module
3. Go to "Design" → "Positions", click "Transplant a module", then select your module and necessary hook
4. Go to "Design" → "Positions", http://take.ms/JyuaI

Ad 2 / 3 / 4 I turned off the filters which I don't needed but I have no idea how to turn off the banners.

Zrzut ekranu 2018-06-27 o 15.... (355.3 KiB)
Marek (marek) 28 Jun 2018, 12:03

1. Please make sure the module is installed and enabled
2. I do not see banners on your page https://weselnystolik.pl/4-zielona-eco

Sebastian Szaraniec (szaran) 28 Jun 2018, 12:33

Images appears after few seconds. Weird..

Module "in the same caetgory" installed and works fine. Thanks.
How about my previous question related to displaying shipping info on product page?

And I still don't know how tu put "new products" below filters on category page

Zrzut ekranu 2018-06-27 o 15.... (355.3 KiB)
Marek (marek) 29 Jun 2018, 11:58

I wrote about shipping two days ago:
As for shipping info, I have found this: https://www.prestashop.com/forums/topic/623984-displaying-shipping-info-on-product-page-no-stock-management-ps17

Sebastian Szaraniec (szaran) 03 Jul 2018, 18:00

Marek, how about with images appears i left sidebar? This problem still exist.
Help me pls with "new products" below filters on category page. I still don't know how tu put it there properly.

Marek (marek) 03 Jul 2018, 22:18

1. I'm not sure it's a bug, please check out all slider setting, something wrong with that
2. There is a module "New Product" in your BO. Please make sure it's installed and enabled and hooked into Left Column

Sebastian Szaraniec (szaran) 03 Jul 2018, 22:55

1. Yes, it was slider. Thanks.
2. Probably I did something wrong - module installed and hooked. Any idea? (attachement)

Zrzut ekranu 2018-07-03 o 22.... (161.9 KiB)
Marek (marek) 04 Jul 2018, 11:23

That was your solution http://take.ms/Z4VDC

Sebastian Szaraniec (szaran) 04 Jul 2018, 13:32

Thanks - works fine.

Sebastian Szaraniec (szaran) 08 Jul 2018, 14:15

Marek, it’s not the end. I have a few following questions due to theme.

Loading...