We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation

Promokit HelpdeskAlysum AMP theme

  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 06.05.18, 22:56
  • Reason: Closed
  • Comment: Glad to help!

Ticket #11917 - Daily deal module / isotope module / google map on contact page

Hi Marek,

Back again about home page module issues.

1. I can’t get daily deal module on my home page. Tryed a lot of times, reseting module, refreshing both cash prestashop and firefox.
Please see attached file 1 and 2.

Is it due to preset choice??

2. Pk isotope module still doesn’ work, it only shows 3 products and manual selection doesn’t seem to work too...
I reseted module and firefox cash oftenly.

Could you fix it please?

I would like something like https://alysum5.promokit.eu/complex/en/ or https://alysum5.promokit.eu/dailydeal/en/ .
please see attached files 3 and 4.

3. Is the maximum number products shown of pk isotope is 12?

4. Google map key issue –> map doesn’t display.
Please see attached files 5,6, and 7.
Did i miss something or could you fix it please?

Thank you for your response.

Greetings

1.JPG (740.9 KiB)
2.JPG (532.7 KiB)
3.JPG (645.6 KiB)
4.JPG (575.1 KiB)
5.JPG (404.7 KiB)
6.JPG (493.8 KiB)
7.JPG (380.5 KiB)

This ticket does not depend on any other tickets.

Marek (marek) 23 Mar 2018, 22:49

1. The module was not active. Now it's ok
2. Isotope must be ok as well
3. There is no such limit in the module's code. You can set the limit in the module settings.
4. I see the message in the console "Your site URL to be authorized: http://30exemplaires.fr/nous-contacter" so you have to add your domain to the API Key settings

Rizak (vatna) 26 Mar 2018, 17:34

Hi Marek,

Thanks for fixes, however there are still somme issues :

1. Ok, nice but how can i hook it to "content_top" on home page as in alysum demo : https://alysum5.promokit.eu/dailydeal/en/ I can't find this hook in the list when selecting "daily deal" module.

Why the module crop my pictures? Please see picture in module and picture in page product.

Why there is no products when clicking "view all"?

Plus, there is an already seen issue, there is a little number "1" on cart icon.
We talked about this before, it is linked to "daily deal" module according to my past tests. Could you fix it ?

2. Nice it works now, i understand how the counter products works too. Thank you.

Automaticaly get products is fine.
In manualy products selected, how can i set filters type? Default type for now is "All", "Featured", "Recents".

3. Thanks got it now.

4. Please see attached file.
I think i added my domain "http://30exemplaires.fr/nous-contacter" to API settings.
Google says few minutes to apply, i'm still waiting.

1.JPG (451.4 KiB)
1.JPG (468.1 KiB)
Rizak (vatna) 26 Mar 2018, 17:48

...sorry forgot this

2. Why last picture is cut? Please see attached file "2"

2.jpg (796.4 KiB)
Marek (marek) 27 Mar 2018, 12:37

1. Done.
2. Why there is no products when clicking "view all"? - that is a link to Special products. You seems do not have special products
3. how the counter products works? - you have to add a discount limited by time for a product to get countdown
4. Please read google suggestions carefully. As I remember there should be "*" in the end or begin of line

Rizak (vatna) 27 Mar 2018, 14:45

1. Thank you for hooking module. Why wasn't i be abble to do it by the classic way??

Pictures are still cropped. Is there a way to fix this??
About little number "1" on cart icon? Please see attached file "3.jpg"

2. About isotope, again : In manualy products selected, how can i set filters type? Default type for now is "All", "Featured", "Recents".

Why last picture is cut? Please see attached file "2.jpg"

3. About googlemap, i'll try this. Thank you

2.jpg (796.4 KiB)
3.JPG (637.1 KiB)
Marek (marek) 28 Mar 2018, 16:17

1. I need access via FTP to fix that.
2. I don't see the issue, try to clean browser's cache

Rizak (vatna) 28 Mar 2018, 16:29

1. I'll prepare this
2. True it's ok now.
Where can is set filter type/name Marek please?
3. I tryed with * and different adress page, but still doesn't work.
Do i need to put name domain or contact adress page, I don't get it.

Marek (marek) 29 Mar 2018, 11:10

you have to use Automatic mode to select certain product types
I can't help you with that because I don't have access to your google account. try to see some video tutorial

Rizak (vatna) 26 Apr 2018, 10:22

Hi Marek,

I'm still stuck with google map.

The domain is not secured –> "https" , this could be linked to my google map issue??
Thank you

Marek (marek) 26 Apr 2018, 11:55

Ok, try following way. Go to your API Key settings and select IP there like this http://take.ms/z0oBl

Put IP of your server and save

Rizak (vatna) 26 Apr 2018, 12:23

Hi Marek,

Still doesn't work... I waited few minutes as google says.
Makes me mad :-((

GMAP.JPG (446.5 KiB)
Marek (marek) 26 Apr 2018, 12:44

Seems you put your local IP address. Please check your website IP for instance here http://get-site-ip.com

Rizak (vatna) 26 Apr 2018, 19:52

Unfortunatly no.

My Ip : 91.161.88.176.

30exemplaires.fr Ip : 192.162.70.244

What can i do?? I get mad really ...

Marek (marek) 27 Apr 2018, 11:31

I don't know how to help you with that.
There is an error in console: https://developers.google.com/maps/documentation/javascript/error-messages#referer-not-allowed-map-error

The current URL loading the Google Maps JavaScript API has not been added to the list of allowed referrers

So the issue is definitely with your API configuration
My configuration looks like this http://take.ms/SNvtO

Rizak (vatna) 27 Apr 2018, 13:45

Ok thanks, i'm still testing differents adresses/referes
I'll tell if something changes.

Greetings!

Marek (marek) 27 Apr 2018, 13:47

Ok, let me know the result

Loading...