We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation

Promokit HelpdeskAlysum AMP theme

  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 19.04.18, 22:29
  • Reason: Closed
  • Comment: Glad to help!

Ticket #12015 - Error 500 after installation

Hello,
I have problem with Alysum theme (last version). I have installed brand new Prestashop (1.7.3.). Then I have tried install theme. After succesful upload I have a problem. When I try to activate theme or show modules page in BO I got “500 Internal Server Error”.
According to log, there is problem at “PHP Fatal error: Can’t use function return value in write context in demo-eshop/modules/pk_compare/pk_compare.php on line 243”

Next (nested) exception in log is:
Stack trace: #0 [internal function]: Symfony\Component\HttpKernel\HttpKernel→terminateWithException(Object(Symfony\Component\Debug\Exception\FatalErrorException)) #1 demo-eshop/vendor/symfony/symfony/src/Symfony/Component/Debug/ErrorHandler.php(606): call_user_func(Array, Object(Symfony\Component\Debug\Exception\FatalErrorException)) #2 demo-eshop/vendor/symfony/symfony/src/Symfony/Component/Debug/ErrorHandler.php(668): Symfony\Component\Debug\ErrorHandler→handleException(Ob in demo-eshop/app/bootstrap.php.cache on line 3231

I have tried the previous version of theme and it worked so its probably related to the latest version.

Thank you for your help.

This ticket does not depend on any other tickets.

Marek (marek) 08 Apr 2018, 21:12

Hi, Ales.
Try to install now. I just make a fix

Ales (ales_005) 09 Apr 2018, 21:01

There is another error when I try to open Module page.

PHP Fatal error: Can't use function return value in write context in demo-eshop/modules/pk_compare/pk_compare.php on line 241 - another line

Please fix it. Thank you.

Marek (marek) 09 Apr 2018, 21:03

Try now

Ales (ales_005) 09 Apr 2018, 21:04

No change. The same.

Marek (marek) 09 Apr 2018, 21:05

Ok, I have disabled Compare module. Try once again

Ales (ales_005) 09 Apr 2018, 21:05

demo-eshop/modules/pk_compare/pk_compare.php on line 318

Ales (ales_005) 09 Apr 2018, 21:06

Now, module page is working.

Marek (marek) 09 Apr 2018, 21:08

Great. Are you going to use Compare module?

Ales (ales_005) 09 Apr 2018, 21:13

Not now, it is demo version, but I think my client will want to use it. Where is the problem?

Marek (marek) 09 Apr 2018, 21:14

I don't know yet, but I'll figure it out and let you know as soon as possible

Ales (ales_005) 09 Apr 2018, 21:19

Activation of theme is still not sucessful.

[09-Apr-2018 21:15:17 Europe/Prague] PHP Fatal error: Uncaught exception 'Exception' with message 'Zapnutí tohoto modulu nemáte povoleno. (translation: activation is not allowed)' in demo-eshop/src/Core/Addon/Module/ModuleManager.php:385
Stack trace:
#0 demo-eshop/src/Core/Addon/Theme/ThemeManager.php(291): PrestaShop\PrestaShop\Core\Addon\Module\ModuleManager→enable('pk_compare')
#1 demo-eshop/src/Core/Addon/Theme/ThemeManager.php(176): PrestaShop\PrestaShop\Core\Addon\Theme\ThemeManager→doEnableModules(Array)
#2 demo-eshop/controllers/admin/AdminThemesController.php(306): PrestaShop\PrestaShop\Core\Addon\Theme\ThemeManager→enable('alysum')
#3 demo-eshop/classes/controller/Controller.php(194): AdminThemesControllerCore→postProcess()
#4 demo-eshop/classes/Dispatcher.php(428): ControllerCore→run()
#5 demo-eshop/app/bootstrap.php.cache on line 3231

Marek (marek) 09 Apr 2018, 21:20

What is your PHP version?

Ales (ales_005) 09 Apr 2018, 21:30

PHP Version 5.4.45-0+deb7u12
I can send you phpinfo (privately), if you would like.

Marek (marek) 09 Apr 2018, 21:55

I would highly recommend you to update it at least to 5.6.x, but would be much better to have 7.x version which is much faster

Ales (ales_005) 09 Apr 2018, 22:00

Ok, but I need to keep working current version of PS (at root URL). Its PS 1.5.6.2 with Alysum 2.9. Will it work?

Marek (marek) 09 Apr 2018, 22:15

with 5.6 yes, but I'm not sure about 7.x

Loading...