We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 06.05.18, 22:18
  • Reason: No answer from a customer

Ticket #12021 - Check out not working

Hi,

I can not use the checkout page there are several problems.

1. the footer is not like the rest of the site built using the footer builder. I had to add this manually
2. The login button on the check out page just brings me to down the page and not to the register page
3. I can not see any payment option I have 2 installed.
4. There are missing objects for the editing the address and shipping all is shown is a red box that dose not work and overlays some text

Anthony

This ticket does not depend on any other tickets.

Anthony Carroll (Dataharp) 09 Apr 2018, 18:17

Please see image for issue no 4.

Capture.PNG (67.3 KiB)
Marek (marek) 09 Apr 2018, 19:37

Hi, Anthony.
Please give me a link to your store

Marek (marek) 10 Apr 2018, 10:52

I'm not able to add a product to the cart to test it. I see the message "You cannot place a new order from your country (Poland)."

Anthony Carroll (Dataharp) 10 Apr 2018, 11:46

Hi Marek,

My apologies can you retry

Marek (marek) 10 Apr 2018, 11:54

I see visual issues on check out page. Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your server through FTP and Back office

Anthony Carroll (Dataharp) 10 Apr 2018, 12:02

Ok I have done this

Anthony Carroll (Dataharp) 10 Apr 2018, 19:52

Hello Marek,

Have you ant ideas on what the problem is I need to sort out this issue.

My apologies for being hasty.

Marek (marek) 10 Apr 2018, 19:59

No problem, I'll take a look right now

Marek (marek) 10 Apr 2018, 20:10

I just wiped out prestashop cache and now I see following message on checkout page

Please make sure you've chosen a payment method and accepted the terms and conditions.

Could you please check that out?

Anthony Carroll (Dataharp) 10 Apr 2018, 20:26

Hi,

This is one of problems it is not giving an option to select a payment option

Marek (marek) 10 Apr 2018, 20:49

I didn't see such issue before. I suppose the problem is related to the language, and I have to test installation on localhost. I back to you as soon as I'll have any news

Anthony Carroll (Dataharp) 10 Apr 2018, 20:57

Cool I appreciate this thanks Marek

Marek (marek) 10 Apr 2018, 20:59

Sorry, comment to another ticket

Anthony Carroll (Dataharp) 10 Apr 2018, 21:05

ah ok cool

Anthony Carroll (Dataharp) 10 Apr 2018, 21:42

Hi I have put the shop into catalog mode while the problem is being sorted

Marek (marek) 11 Apr 2018, 13:58

Hi, Anthony.
Your server is very slow and unstable, I'm trying to work but it takes too much time to wait while pages are loading. Could you please check out what's wrong?

Anthony Carroll (Dataharp) 11 Apr 2018, 14:25

Hi Marek,

I am currently checking this out. I am also seeing this error 500

Anthony Carroll (Dataharp) 11 Apr 2018, 14:27

Backend seems to be working fine,
I have not made any changes that would cause this error on the front end

Marek (marek) 11 Apr 2018, 14:28

ok, I see, I'll back to you soon

Anthony Carroll (Dataharp) 11 Apr 2018, 14:31

what was the last thing you have changed?

Marek (marek) 11 Apr 2018, 14:32

I didn't change anything. Do you need a help with that?

Anthony Carroll (Dataharp) 11 Apr 2018, 14:37

No I am just trying to find the issue I think it may be an issue with the VPS I am getting error

PHP Warning: Error while sending QUERY packet. PID=11462 in ....classes/db/DbPDO.php on line 147

Marek (marek) 11 Apr 2018, 14:38

ok, let me know in case you will need a help

Anthony Carroll (Dataharp) 11 Apr 2018, 17:26

Hi Marek,

I have contacted the hosting people and they have confirmed everything is ok on the server.

When I change back tot eh standard theme the site works but now is not working with the installed theme.

I need help on this issue

Anthony Carroll (Dataharp) 11 Apr 2018, 22:09

Hi,

I can not resolve this issue, after I change from the venedior theme I can then see the site but hen the theme is activated I am getting error 500

Marek (marek) 12 Apr 2018, 00:38

I'll back to you tomorrow in the morning, don't worry.

Marek (marek) 12 Apr 2018, 10:00

Something wrong with your server configuration. I always see the message

SessionHandler::gc(): ps_files_cleanup_dir: opendir(/var/cpanel/php/sessions/ea-php70) failed: Permission denied (13)

Keep working to find out what's wrong

Anthony Carroll (Dataharp) 12 Apr 2018, 10:08

I have found a problem the PHP ini was set to ea-php70 and not ea-php56

This has been changed

Anthony Carroll (Dataharp) 12 Apr 2018, 10:10

I have now seen the error this has been fixed

Marek (marek) 12 Apr 2018, 10:11

Wait a moment, I'm trying to do something with that

Anthony Carroll (Dataharp) 12 Apr 2018, 10:15

no problem

Marek (marek) 12 Apr 2018, 10:32

Could you please give me a link to product what I found purchase to test checkout?

Marek (marek) 12 Apr 2018, 10:49

ok, so I'll disable it for a moment

Anthony Carroll (Dataharp) 12 Apr 2018, 10:53

ok

Anthony Carroll (Dataharp) 12 Apr 2018, 10:59

ok now we have made a little progress :) the red boxes are gone but still no options to pay.

Login from this page is not working
and the menus in the top bar do not work

Marek (marek) 12 Apr 2018, 11:00

Yes, I see. Working on that

Marek (marek) 12 Apr 2018, 11:02

I have switched your store back to default theme and there is the same problem, you can check that yourself

Anthony Carroll (Dataharp) 12 Apr 2018, 11:06

is the shop still in debug mode?

Marek (marek) 12 Apr 2018, 11:07

yes, it is.
I keep trying to find out a solution

Anthony Carroll (Dataharp) 12 Apr 2018, 11:25

Ok I have solved the payments missing issue.

No payments were made available for the shipping carriers

Marek (marek) 12 Apr 2018, 11:33

So all is fine now?

Anthony Carroll (Dataharp) 12 Apr 2018, 11:42

No now the payments do not work when I change back to the theme see here in the image.

Capture.PNG (69.7 KiB)
Marek (marek) 12 Apr 2018, 13:07

I have found out your modification in the file checkout.tpl. I spent about one hour to fix the issue you did. please be more careful in future

Anthony Carroll (Dataharp) 12 Apr 2018, 13:14

My apologies I added a footer as the footer is not working on this page.

Marek (marek) 12 Apr 2018, 13:14

no problem

Anthony Carroll (Dataharp) 12 Apr 2018, 14:03

So whats is our next step

Marek (marek) 12 Apr 2018, 14:12

Sorry, it seems I missed that, but what is the problem now?

Anthony Carroll (Dataharp) 12 Apr 2018, 14:42

The top bar is not functional.
There is no login from this page working
The footer when you remove my modification is not the footer as seen on the fest of the site.
and please see the image attached to the last comment this is how the payments are when using the theme and are still not functional

Anthony Carroll (Dataharp) 12 Apr 2018, 15:58

Hello Marek,

Should I put the site into maintenance mode?

Marek (marek) 13 Apr 2018, 11:00

1. The top bar is not functional. - I don't see any issue, could you please take a screenshot?
2. Maybe it a cache issue, because I see payments works fine http://take.ms/nRoif 3. Login works fine as well.
The footer looks like you did it http://take.ms/TY0NW, or you want to have the same footer like on the home page?

Please clean the cache of your browser and check out these issues once again

Anthony Carroll (Dataharp) 13 Apr 2018, 11:02

Hi Marek,

I have updated the theme using the button and while it did remove my logo and my menu module, it has fixed the issue with the payment.

Marek (marek) 13 Apr 2018, 11:10

But I see your logo and menu

Anthony Carroll (Dataharp) 13 Apr 2018, 11:53

Here is how the site looks now after the update and clearing the cache.
This is not the menu I was using I am using mega menu pro.

Capture.PNG (16.9 KiB)
Marek (marek) 13 Apr 2018, 12:02

mega menu pro is not a part of the theme. you have to check out if it's enabled or not?

Loading...