Support will be provided with delays until 3 June. We are sorry for the inconvenience.
We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 06.05.18, 22:56
  • Reason: Closed
  • Comment: Glad to help!

Ticket #12118 - How to translate the "Top Bar Short Message".

Hi, how can i translate the “Top Bar Short Message”, in this moment the his value is “Now Shipping to Canada”, and i nedd to translate the value “Now Shipping to Canada”.

The “Top Bar Short Message” is located in:
PROMOKIT → Alysum Settings → Header → Top Bar Short Message

Tanks
Fulcro

This ticket does not depend on any other tickets.

Marek (marek) 23 Apr 2018, 13:15

Hi, Fulcro Development Department.
Unfortunately there is no way to translate it in BO. but I can make it translatable.
Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your server through FTP

Fulcro Development Department (Fulcro_Development_Department) 23 Apr 2018, 13:57

Hi Marek, i fill the fields in my profile as you ask.

When i update the theme i will lost the changes that you are doing?

Marek (marek) 23 Apr 2018, 14:09

Now it should be available for translation in your back office, see Shop → Theme → Catalog

Fulcro Development Department (Fulcro_Development_Department) 23 Apr 2018, 15:39

Hi Marek,
After the change now i'm seeing a problem with the search field, the search field disapear, is not possible to make a search, but the search icon apear below the text "Now shipping to Canada".

front_page.jpg (158.4 KiB)
Marek (marek) 23 Apr 2018, 22:32

I see you changed header a little bit. Do you still need a help with that?

Fulcro Development Department (Fulcro_Development_Department) 24 Apr 2018, 12:26

Hi Marek yes i change the header to another to resolve the search issue.
But i stiil need your help, for the translation, the translation of “Now Shipping to Canada” is not working, i clear the cache and is not translating.

I'm also with dificult to find the Contacts Page to change the Google Maps defenitions can you please tell me where i can change google Maps defenitions in google maps.

Capture.JPG (138.8 KiB)
Marek (marek) 24 Apr 2018, 12:33

Yes, it's because you changed header type.
Open the file /themes/alysum/templates/_partials/headers/header-2.tpl
find the line

{$pkts.top_bar_short_message nofilter}

and replace it with

{l s='Now shipping to Canada' d='Shop.Theme.Catalog'}

Read here how to edit contact details http://alysum5.promokit.eu/promokit/documentation/#faq3

Fulcro Development Department (Fulcro_Development_Department) 24 Apr 2018, 13:19

Hi Marek, i folowed your instrutions and the "Now shipping to Canada" translation is working thanks.

But i have 2 issues in my contacts page, the Google Maps is not working and the email form is not sending emails where i can see the email form configuration?

contacts.jpg (75.8 KiB)
Marek (marek) 24 Apr 2018, 15:34

1. You have to put Google API Key to the Theme Settings to show Google maps
2. I'm not sure it's a theme issue. Here is possible solution https://www.prestashop.com/forums/topic/627675-an-error-occurred-while-sending-the-message-on-contact-form/

Fulcro Development Department (Fulcro_Development_Department) 24 Apr 2018, 17:51

Hi Marek the Api Key is workinh ok now, but i can't send email. When i press in "Test your email configuration" i receive the email, but when i send the email by a form in contacts apear a error can you please help me thanks.

Marek (marek) 25 Apr 2018, 16:36

Yes, I know about the issue and working to find a solution

Marek (marek) 25 Apr 2018, 16:48
Fulcro Development Department (Fulcro_Development_Department) 26 Apr 2018, 14:02

I have done more invistigation about this issue:

		

In line 418 in the file "modules/contactform/contactform.php"
$this→context→controller→errors[] = $this→trans('An error occurred while sending the message, please try again.', array(), 'Modules.Contactform.Shop');

I replace by this code:
$this→context→controller→errors[] = $errorMessage = error_get_last()['message'];

Them i send a email in my Contacts page, an them i get the error "Undefined property: stdClass::$id_shop"
How can i resolve this?

Capture.JPG (101.4 KiB)
Marek (marek) 26 Apr 2018, 14:20

The problem is not with our theme or module. That is a native prestashop module. So we can try to help you with that but for some price

Fulcro Development Department (Fulcro_Development_Department) 26 Apr 2018, 15:32

So my objective is to have a email form working, so how can i edit the contact page? or what i shoul do to use your module insted of the native prestashop module?

I'm used to work with WordPress, and it's my first experience bulding a online store in PrestaShop.

In the Improve → Design → Pages i only have 6 pages that are associated with the category Home, i try to search the contact page where but i don´t find the page, I only have one category that is home is this right?

Capture.JPG (88.7 KiB)
Marek (marek) 27 Apr 2018, 12:49

Please try now, it should work

Fulcro Development Department (Fulcro_Development_Department) 27 Apr 2018, 13:44

Hi Marek, It's Working Thank You. I'm go to Give you a very very Good review, thanks for your excellent job.

Marek (marek) 27 Apr 2018, 13:46

:) That's my work, no problem,
But review is always appreciated
You can write it here http://themeforest.net/downloads

Loading...