We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 16.11.18, 19:17
  • Reason: Closed
  • Comment: Glad to help!

Ticket #12213 - Pagination buttons missing

Hello again!
I have another problem that I think is to do with my theme or Hoki options plugin - I don’t have any pagination buttons on the shop. There are a few pages of products now and the site only shows one with no ‘next’ button or any pagination.
Thankyou,
Gabby

This ticket does not depend on any other tickets.

Marek (marek) 11 May 2018, 12:58

I see the issue. I'll try to fix it as soon as possible

Marek (marek) 12 May 2018, 15:39

Hi, Gabrielle.
Could you please tell me the path to the theme.
I have tried to edit files in the folder /clickandbuilds/SewbytheSea/wp-content/themes/hoki and I don't see my changes at the from page http://sewbythesea.co.uk/shop/

Gabrielle Young (gabsong2012) 18 May 2018, 15:56

Hello Marek,
I'm sorry I don't know what the path to the theme means! ;)

Also how do I change the left sidebar on the shop pages? None of the options work and I'd prefer to be able to add my own sidebar but can't find a way to change it!

Thankyou,
Gabby

Marek (marek) 22 May 2018, 08:45

Hi, Gabby.
I'm sorry for the delay. I have really slow Internet connection right now.
I'll figure out what's wrong with the issue I have described you before. As for the problem with sidebar I need to check it out. I'll back to you as soon as possible

Marek (marek) 03 Jun 2018, 12:37

Hi, Gabby.
I'm sorry for the delay.
Do you use some cache services or plugins? When I edit theme files I don't see my changes through browser

Gabrielle Young (gabsong2012) 07 Jun 2018, 09:28

Hello Marek,
Sorry I was away.
I don't know if I do but I am happy for you to look around the wordpress backsite to check what may be conflicting.

I have screengrabbed and attached all the plugins activated.

Thankyou,
Gabby

Screen Shot 2018-06-07 at 08.... (126 KiB)
Screen Shot 2018-06-07 at 08.... (142.2 KiB)
Screen Shot 2018-06-07 at 08.... (168.5 KiB)
Screen Shot 2018-06-07 at 08.... (123 KiB)
Marek (marek) 07 Jun 2018, 14:28

I have found out the plugin and disabled the cache. As for the issue with pagination it looks like a conflict, I'll try to figure out why it happens

Marek (marek) 12 Jun 2018, 14:02

Hi, Gabby.
I spent much time to figure out what's wrong but still have no solution. Do you have possibility to install new wordpress installation just for a test?

Gabrielle Young (gabsong2012) 13 Jun 2018, 09:09

Hello!
Sorry that this is taking so long. What would I need to do for a new wordpress installation?
I'm also OK with you disabling the plugins to find the conflict is that helps?
I'm happy to whatever as long as I don't lose anything!
:)

Marek (marek) 13 Jun 2018, 20:17

I just want to test out fresh theme installation on a new wordpress, because I didn't see such problem before

Gabrielle Young (gabsong2012) 20 Jun 2018, 14:06

OK I have just set up a fresh new wordpress elsewhere - can you test it there?!

Marek (marek) 22 Jun 2018, 15:54

Hi, Gabrielle.
Sorry for the delay.
Yes, you can set up a fresh new wordpress elsewhere

Gabrielle Young (gabsong2012) 25 Jun 2018, 17:10

Hello.
I have set up a new wordpress with nothing on it yet here:
http://www.gabberdasherypatterns.com

I have attached all the info you should need and feel free to experiment here to find the problem.

Gabberdashery Patterns FTP.pdf (20.3 KiB)
Marek (marek) 26 Jun 2018, 12:25

Great! How to login to admin panel? I need login and password

Gabrielle Young (gabsong2012) 26 Jun 2018, 12:39

It's all in the attached note. Hope that's OK?

Marek (marek) 26 Jun 2018, 13:49

Yes, I see now.
The theme has been installed http://www.gabberdasherypatterns.com/product-category/gifts/ and I still see the same problem, it seems latest WooCommerce version has some changes. I'll try to find out a fix as soon as possible

Gabrielle Young (gabsong2012) 26 Jun 2018, 18:06

Ok thankyou!
You can leave the theme on the new site as I was going to use it here too anyway.
Thankyou,
Gabby

Marek (marek) 26 Jun 2018, 19:50

Ok, I'll back to you as soon as possible

Marek (marek) 28 Jun 2018, 12:16

I have found out a solution.
Open the file /wp-content/themes/hoki/woocommerce/config.php and add "//" before the line 19 – http://take.ms/h9syC

Gabrielle Young (gabsong2012) 28 Jun 2018, 14:18

YAAAY! That has the pagination buttons back!! Thankyou!
Now it's just this menu on the left hand side? It doesn't work and I can't see where to change it to a custom menu.
SO NEARLY THERE!!

Thankyou so much Marek! :)

Marek (marek) 29 Jun 2018, 12:33

I just finished to configure the filter widget. Please check it out

Gabrielle Young (gabsong2012) 02 Jul 2018, 09:37

Oh Marek thankyou SO much this is fantastic!!

Now, of course, we have a new problem! But hopefully this will be it!!

The front page says this "Your theme (Hoki) contains outdated copies of some WooCommerce template files. These files may need updating to ensure they are compatible with the current version of WooCommerce. You can see which files are affected from the system status page. If in doubt, check with the author of the theme."

And when I try to add or edit a product it says
"Fatal error: Uncaught Error: [] operator not supported for strings in /homepages/15/d731227237/htdocs/clickandbuilds/SewbytheSea/wp-content/themes/hoki/woocommerce/plugins/woocommerce-video-tab.php:190 Stack trace: #0 /homepages/15/d731227237/htdocs/clickandbuilds/SewbytheSea/wp-includes/class-wp-hook.php(286): WooCommerce_Video_Product_Tab→product_write_panel() #1 /homepages/15/d731227237/htdocs/clickandbuilds/SewbytheSea/wp-includes/class-wp-hook.php(310): WP_Hook→apply_filters('', Array) #2 /homepages/15/d731227237/htdocs/clickandbuilds/SewbytheSea/wp-includes/plugin.php(515): WP_Hook→do_action(Array) #3 /homepages/15/d731227237/htdocs/clickandbuilds/SewbytheSea/wp-content/plugins/woocommerce/includes/wc-deprecated-functions.php(33): do_action_ref_array('woocommerce_pro...', Array) #4 /homepages/15/d731227237/htdocs/clickandbuilds/SewbytheSea/wp-content/plugins/woocommerce/includes/admin/meta-boxes/views/html-product-data-panel.php(47): wc_do_deprecated_action('woocommerce_pro...', Array, '2.6', 'Use woocommerce...' in /homepages/15/d731227237/htdocs/clickandbuilds/SewbytheSea/wp-content/themes/hoki/woocommerce/plugins/woocommerce-video-tab.php on line 190"

Sorry but do you mind looking at this and then I will leave you alone!!

Thankyou,
Gabby

Marek (marek) 02 Jul 2018, 10:25

Try now, all should be ok

Gabrielle Young (gabsong2012) 02 Jul 2018, 14:37

Thankyou!! Now I have this in the description box of the product!!

Fatal error: Uncaught Error: [] operator not supported for strings in /homepages/15/d731227237/htdocs/clickandbuilds/SewbytheSea/wp-content/themes/hoki/woocommerce/plugins/woocommerce-custom-product-tabs-lite.php:184 Stack trace: #0 /homepages/15/d731227237/htdocs/clickandbuilds/SewbytheSea/wp-includes/class-wp-hook.php(286): WooCommerceCustomProductTabsLite→product_write_panel() #1 /homepages/15/d731227237/htdocs/clickandbuilds/SewbytheSea/wp-includes/class-wp-hook.php(310): WP_Hook→apply_filters('', Array) #2 /homepages/15/d731227237/htdocs/clickandbuilds/SewbytheSea/wp-includes/plugin.php(515): WP_Hook→do_action(Array) #3 /homepages/15/d731227237/htdocs/clickandbuilds/SewbytheSea/wp-content/plugins/woocommerce/includes/wc-deprecated-functions.php(33): do_action_ref_array('woocommerce_pro...', Array) #4 /homepages/15/d731227237/htdocs/clickandbuilds/SewbytheSea/wp-content/plugins/woocommerce/includes/admin/meta-boxes/views/html-product-data-panel.php(47): wc_do_deprecated_action('woocommerce_pro...', Array, '2.6', 'U in /homepages/15/d731227237/htdocs/clickandbuilds/SewbytheSea/wp-content/themes/hoki/woocommerce/plugins/woocommerce-custom-product-tabs-lite.php on line 184

Marek (marek) 03 Jul 2018, 11:32

Could you please give me a link to the product with such errors

Gabrielle Young (gabsong2012) 04 Jul 2018, 10:45

Hello Marek,
It's all of them and when I try to 'add new product' too.
http://sewbythesea.co.uk/wp-admin/post-new.php?post_type=product

Thankyou,
Gabby

Marek (marek) 04 Jul 2018, 11:40

I have disabled Custom Tabs plugin and now the problem is solved. If you are going to use it, just let me know, and I'll try to figure out what's wrong with that

Gabrielle Young (gabsong2012) 04 Jul 2018, 18:24

Thankyou so much Marek!!
I will try not to have anymore issues now!! :)

Marek (marek) 04 Jul 2018, 23:52

No problem, I'll try to help you :)

Loading...