We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 13.07.18, 20:41
  • Reason: Closed
  • Comment: Glad to help!

Ticket #12331 - alysum settings / theme settings missing in menu - additional: blanc homepage

Hi - we installed this theme on prestashop 1.7 but the backoffice menu does not show the menuitem “theme settings” or “alysum settings” which should be there for the basic settings.
Additionally, the homepage is 90% blanc after selecting this theme.

Thank you in advance for your help.

Rgrds, Michel

This ticket does not depend on any other tickets.

Marek (marek) 04 Jun 2018, 20:56

Hi, mvk69.
Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your back office

michel (mvk69) 05 Jun 2018, 09:59

Done.

Marek (marek) 05 Jun 2018, 14:24

It's still empty, please check it out

Marek (marek) 05 Jun 2018, 15:16

Yes, I really need access. I have to see your configuration to understand what's wrong. Please write all messages in your ticket, it will be easily for me to find it

michel (mvk69) 05 Jun 2018, 16:24

done

Marek (marek) 05 Jun 2018, 17:19

1. What store I have to use?
2. Do I need to enable Alysum theme?

michel (mvk69) 05 Jun 2018, 17:53

We want alysum at all shops, so please activate for all, tnx.

Marek (marek) 06 Jun 2018, 11:34

The theme has been enabled and works fine

michel (mvk69) 06 Jun 2018, 14:06

Thank you. What was de reason for this problem? Was there something wrong with our configuration?
Can we update in the future without any problems? Just asking, beceause maybe some manual modifications are done.

Marek (marek) 06 Jun 2018, 14:13

I don't know what was wrong, I just enabled the theme, and that's all.
Yes, you can update it with no problem

michel (mvk69) 06 Jun 2018, 15:09

Yes, then the front is working from time to time, but if I make a change somewhere, most of the homepage is blank. So I disabled the theme. But still the Alysum Settings or theme settings are not in the menu, pls see attached file

menu.jpg (7.8 KiB)
Marek (marek) 06 Jun 2018, 15:17

Try to reset the module to get it in the menu. And please make sure the module is active for each of your stores

michel (mvk69) 06 Jun 2018, 15:41

And please make sure the module is active for each of your stores
- I did.

Try to reset the module to get it in the menu.
- found it and reset.
- but it did not show up in the menu bar
- as a suprise, I found the "Theme settings" under the "installed modules" and this worked (for a second)
- i clicked "reset" on this one and received a no permission message
- now, the "Theme settings" is no longer under "installed modules" and no where to find
addional, our websites .de and .fr sites gives a http 500 error
the .fr gives a blanc page

Marek (marek) 06 Jun 2018, 17:20

When the module is uninstalled it appears under the first tab http://take.ms/elsDE May I ask you why you have created two additional sub stores? I suppose not only for different languages? because it's not correct approach

michel (mvk69) 06 Jun 2018, 18:00

Found the module again. .nl page is almost empty. The .de and fr pages same and are missing css

I created one shop group. This group contains 3 domain names with different extentions (.nl .fr and .de) so each domain has it's own language.

Hope you have a solution, spend already many many hours on this...

Marek (marek) 06 Jun 2018, 18:06

https://www.biomoda.nl works fine.
Working on other domains

Marek (marek) 06 Jun 2018, 18:14

Please make sure the module Theme Settings and Page Builder enabled for each your store. For Page builder module please make sure necessary layout is selected as default.
All these options are not theme configuration, but prestashop platform

michel (mvk69) 07 Jun 2018, 12:51

I am pretty close to giving up. It seems to be impossible to get this working on multistore. If I activate on one, it dissapears on the other. Can you pls activate Alysum theme on all 3 shops for me?

Marek (marek) 07 Jun 2018, 12:55

Ok, give me a moment

Marek (marek) 07 Jun 2018, 13:10

You have really strange back office behaviour.
For now all stores are configured https://www.biomoda.de https://www.biomoda.nl and https://www.biomoda.fr

michel (mvk69) 07 Jun 2018, 15:13

I noticed this behaviour on Alysum only. I just found out that the backoffice works only fine with alysum if:

you login with the extention in the admin url fi. biomoda.fr/admin and modify the corresponding sub shop, FR, then it works.
Complicated, I noticed it will not use the main menu structure, I need to define each subshop menu. While normally, 1 menu can be used for all shops. Or am I doing something wrong?

Questions, the footer only shows on the .FR page, not on the .NL and .DE

Marek (marek) 07 Jun 2018, 15:16

That is a prestashop system and I can't change it. You have to understand how it works. It's not related to the theme and nor to the modules

michel (mvk69) 13 Jun 2018, 10:19

Ok, thank you very much for your support!

michel (mvk69) 13 Jun 2018, 12:52

If I switch from preset in theme settings, sometimes I see an almost blanc page, and sometimes with nice layout. It depends on the preset I choose. How can I solve this?

michel (mvk69) 13 Jun 2018, 14:19

Additional info: i use multishop. It works well on one shop (.fr domain). But for the others, there is blanc homepage.

Marek (marek) 13 Jun 2018, 16:59

Hi, Michel.
Please make sure the module Theme Settings and Page Builder are installed and enabled for both stores. Then you have to create new layout special for your second store

michel (mvk69) 14 Jun 2018, 16:12

OK I understand the way of working. Modules are installed. But, the layout builder, footer builder etc hangs. See screenshot. It all keeps greyed out, I can not use the tools (although it succeeded a single time). Pls help. I'm getting frustrated, spend already soo much time on this.

hangs.jpg (227 KiB)
Marek (marek) 14 Jun 2018, 16:25

I asked you to be sure the modules are installed and enabled. As I can see it's Page builder is disabled for one of your store http://take.ms/TuAL0

michel (mvk69) 14 Jun 2018, 17:09

OK, but still does'nt work. If a profile is loaded, then unable to modify (keeps greyed out). Counts for all shops. Please help.

michel (mvk69) 14 Jun 2018, 17:46

One more; if I select a product page layout on the NL page, the result on the product page is really a mess.
If I go the select product page layout for FR, there is nothing to choose, only default.
Please help. We need this shop to go live soon but the last weeks all our time is spend on the theme configuration.

Marek (marek) 14 Jun 2018, 21:22

1. I'll check that right now.
2. You have to create new layout separately for each shop

michel (mvk69) 14 Jun 2018, 21:25

1. Ok thank you
2. Understood, but the dropbox should show al available layouts but is shows only default

Marek (marek) 14 Jun 2018, 21:26

2. it means there are no layouts for certain shop

Marek (marek) 14 Jun 2018, 21:38

Here is important thing you have to consider http://take.ms/vaGdhe

Domain name must be the same as selected store. I want to emphasise, that is a prestashop characteristic, not the theme or module problem

Marek (marek) 14 Jun 2018, 21:39

I have imported new layout in your FR store, please try to do the same for "DE". Just export existing layout, and import to necessary store

michel (mvk69) 14 Jun 2018, 21:47

"Here is important thing you have to consider http://take.ms/vaGdhe"
- ok, I noticed and wrote this earlier to you, above on 07 Jun 2018, 13:13

for the presets, the basic should at least be available, like attached

michel (mvk69) 14 Jun 2018, 21:58

To show you the mess of the product page:
https://www.biomoda.nl/legging-merinowol-engel-natur

Marek (marek) 14 Jun 2018, 22:01

In the theme settings you can select only layout for certain store, there is no any problem with that
As for product page try to create a new layout special for product page, because you are using homepage layout

michel (mvk69) 14 Jun 2018, 22:14

I see, thank you. But still don't understand why the available options vary per store. Continue tommorow. Hope you can fix the pagebuilder issue (hangs on loading). Have a nice evening.

Marek (marek) 14 Jun 2018, 22:15

It works fine if you open back office with the same domain as selected store.

michel (mvk69) 14 Jun 2018, 22:25

sorry but still dont work. Try to do this already the whole afternoon. See screenshot

A question/remark: why can I select homepage layouts on the tab "product page layout"? That gives problems and questions...

theme2.jpg (117.4 KiB)
Marek (marek) 15 Jun 2018, 11:56

I'll add an option to fix possible issues with Page Builder by one click, give me a time, I hope to do that today

michel (mvk69) 15 Jun 2018, 12:20

That is much appreciated, thank you. If it works all next monday is also ok, so no need to hurry today.

Marek (marek) 15 Jun 2018, 12:21

Ok, thank you

Marek (marek) 15 Jun 2018, 12:26

Can I reset Page Builder? Existing layouts will be erased

michel (mvk69) 15 Jun 2018, 12:49

Sure, no problem.

Marek (marek) 15 Jun 2018, 13:30

Can I get access to your database through phpMyAdmin, I need to remove duplicated menu items http://take.ms/1yXCW

michel (mvk69) 15 Jun 2018, 14:40

Yes, I can sent you a link to access without any password. But this link is only valid for about 5 minutes. I sent you this one now, if it is expired, let me know then I sent a new one.

michel (mvk69) 15 Jun 2018, 17:11

Pls tell me when you need the link then I sent it to you by email.

Marek (marek) 15 Jun 2018, 17:16

I'm ready

michel (mvk69) 15 Jun 2018, 17:44

OK, sent to you by email. It's 1 time valid and expires in 5 a 10 minutes.

Marek (marek) 15 Jun 2018, 18:10

So, here is what I have done:
1. Duplicated linka are removed.
2. Page Builder module is enabled for each store
3. Layout has been imported for each store
4. Page Builder back office loads fine in each store
5. Each store Front-page loads fine

michel (mvk69) 18 Jun 2018, 14:15

Thank you for your help, I really appreciate it. Just started to work on it but many problems occur again.

I exported the footer from .DE for import at .NL

That works now, but after I changed the main theme for DE to classic:
https://www.biomoda.de/ -
https://www.biomoda.de/startseite Besides they show different content, they show no homepage layout.

https://www.biomoda.fr/ is empty after selecting another layout
https://www.biomoda.fr/accueil this contains product layout

If I change something here, somewere else problems occur.

I checked the admin url is corresponding with the shop.

We spent both a lot of time on this. At which moment can we conclude that this is not working? Pls advice.

Meanwhile I tried some things... I exported the working NL homepage layout and imported it at DE but that gives no good result.

Marek (marek) 18 Jun 2018, 15:54

But I see your home page layout in the DE version https://www.biomoda.de

michel (mvk69) 18 Jun 2018, 16:06

Yes but many widgets/items are missing.
Besides that, https://www.biomoda.de/startseite shows a differnt view

https://www.biomoda.fr/ is empty
https://www.biomoda.fr/accueil this contains product layout same as https://www.biomoda.de/startseite

How do we continue?

Marek (marek) 18 Jun 2018, 16:10

You must have at least of layout by default: http://take.ms/oAEmf

Besides that, https://www.biomoda.de/startseite shows a differnt view - I don't see any difference, could you please clarify?

michel (mvk69) 18 Jun 2018, 16:17

https://www.biomoda.de/ and
https://www.biomoda.de/startseite pointing to the same (homepage) but different content

Marek (marek) 18 Jun 2018, 16:18

As I can see that is a category page

michel (mvk69) 18 Jun 2018, 16:24

https://www.biomoda.fr/ did add imported profile from .NL
shows nothing on home

"As I can see that is a category page"
yes indeed, but should show "home"

Marek (marek) 18 Jun 2018, 16:29

1. I suppose it's because there is no content in French language http://take.ms/By6Rt

2. How did you make that page as "home"?

michel (mvk69) 18 Jun 2018, 17:08

1. I did add some and now something is comming up indeed. I expected non-text related items to come up anyway on a copied profile. But
I try to understand the way of working and that is difficult: if I change from preset, it shows a blanc page again. The preset should load content on the homepage, right?

2. How did you make that page as "home"?
Solved, sorry my fault.

Marek (marek) 18 Jun 2018, 17:45

Could you please show me what preset you have changed?

michel (mvk69) 19 Jun 2018, 09:16

See www.biomoda.fr I did change it to theme Lingery at the presets in Alysum setting.
Result: no footer, no homepage content.

Setting al pages/header/footer etc manually in layoutbuilder is not the right way of working with this I guess? It should apply the basic layout. How to fix this?

michel (mvk69) 19 Jun 2018, 09:27

Other question: I need to change the header of the NL page. The header builder shows no editable profile, but the .NL website shows a header. How can I edit the existing header?

Marek (marek) 19 Jun 2018, 12:23

1. It works correct. When you change the preset in the theme Settings, it loads configuration of that preset and layout with the same name as preset has.
2. I just created header layout and enable it in the Theme settings http://take.ms/yXl63

michel (mvk69) 19 Jun 2018, 13:13

Pls see on our admin, feel free to choose some presets and look at the result on the NL page.
f.i. complex, oldstyle or lingerie does not work, pls try yourself

Fullpage theme shows much (mixes styles sometimes depending on the sequence of change)

So assuming we choose fullpage as theme, we should see "fullpage" as loaded and adjustable configuration in header/footer/pagebuilder. But that is not the case.

I am trying to understand what the point is.... it feels like it is caused by duplicate profile settings caused by multishop insertions/updates.

Marek (marek) 19 Jun 2018, 13:55

Yes, it doesn't work because you have no layouts "complex", "oldstyle" or "lingerie" in the page builder.
After switching the preset you have to select some layout manually.

michel (mvk69) 19 Jun 2018, 16:12

OK. But when I select f.i. "classic" in Theme setting presets, the result should be a complete page with header/homepage/footer right? Or am I missing the point?

Marek (marek) 19 Jun 2018, 17:14

Yes, you are right, but it works for main page layout only now. We will try to improve it in the next versions.

michel (mvk69) 19 Jun 2018, 17:51

Ok, Then, within our store setup, which one is the adjustable mainpage for theme presets?

michel (mvk69) 20 Jun 2018, 10:17

I found out the DE shop works as mainpage.

You created header layout and enable it in the Theme settings for NL. I saw it and modified it. No changes appear on the homepage.
For NL, I did add a footer layout according your working method. After a modification, it's gone.
We are comming close to a month now to get this working, but I feel this is not gonna happen...
I really appreciate your help but at a certain stage, we need to decide if we go on or not.
So if you could show me today how to get this working on our multistore, then we proceed. Otherwise we need to stop this implementation. Pls advice.

Marek (marek) 20 Jun 2018, 11:02

Yes, I understand you.
I see such strange behaviour first time, but I'm able to configure it. Let's take NL version
1. Theme Settings → Header → Header Builder enabled
2. Theme Settings → HomePage → HomePage Builder enabled
3. Theme Settings → Footer → Footer Builder enabled
4. Page Builder → Header Layout exist as default
5. Page Builder → HomePage Layout exist as default
6. Page Builder → Footer Layout exist as default

michel (mvk69) 20 Jun 2018, 12:03

Ok thank you. Getting more up now.

Ok, so assume the DE page can generate a layout.
1. How can I copy/export DE header/page/footer layout for import in NL/FR?

2. Btw the preset of classic theme is damaged. Can I update this?

michel (mvk69) 20 Jun 2018, 12:52

3. If i buy the venedor theme, would that help? Maybe I want that anyway, the menu looks better.

michel (mvk69) 20 Jun 2018, 13:05

4. You made so much manual modifictions, will this all stil work if we update the theme and/or prestashop version?

Sorry for all my questoins but we need to decide if we go on.

Marek (marek) 20 Jun 2018, 14:16

1. Go to NL version and export your layout. Then go to DE version and import it.
2. You can take it here https://alysum5.promokit.eu/modules/pspagebuilder/exports/classic.txt

3. Vendor has the same modules just different design
4. There was no any code modifications, it was just configuration of Page Builder and Theme Settings module

michel (mvk69) 20 Jun 2018, 16:37

1.NL has no presets, only DE loads presets, so from there, I can export
But there is nothing to export beceause the header builder shows no profile.
I don't want to make everything from zero, just use and modify a preset
Pls try yourself

2. gives an error when I use it on "import new preset".

3 and 4: I'm thinking about deleting the whole store and DB and start all over again with Venedor. But, if it works the same as alysum, I need to have a working method on 1: using the presets. Pls advice.

Marek (marek) 20 Jun 2018, 19:19

If you want, I can provide you Venedor Theme for testing.
As for header layouts, this option is really fresh and there are no predefined layouts yet

michel (mvk69) 21 Jun 2018, 15:06

Thank you for your offer. We deleted the whole shop and DB today and start all over again. Tnks for all your support, I appreciated it.

Marek (marek) 21 Jun 2018, 15:52

Ok, Let me know if you will need a help

Loading...