We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Status: Waiting on customer

Ticket #12551 - Alysum 5.2.3 theme doesn't work on prestashop 1.7.4

Hi,
I have downloaded last update of Alysum theme for Prestashop 1.7.4

I have installed prestashop 1.7.4 in my hosting and after I have uploaded Alysum theme ver 5.2.3 but it doesn’t work! My homepage is complete white and if I active “Debug Mode” I receive error 500 with some problems (perhaps modeules missing or old version...)

In attached files you can find all my configurations like PHP ver 7.2 and more...

Please tell me all what needs to fix problem because this is only mockup and test and I will install Alysum on other domain and hosting so I would like to know for myself resolution in future.

(I have send to support email new personal data to access my BO)

Thank you for your job

This ticket does not depend on any other tickets.

Marek (marek) 14 Jul 2018, 11:31

I'll check that out, give me a moment

Marek (marek) 14 Jul 2018, 11:50

I have found an incompatibility with php 7.2.x http://php.net/manual/en/function.mcrypt-get-iv-size.php

We are working to provide a fix as soon as possible

Alessandro Borsani (AleBTstudio) 14 Jul 2018, 12:16

thank you, I hope that you can fix this problem. I use php 7.2.x because I saw that this ver improve performance and speed, but if necessary,you can tell me the best and stable version of PHP (for your experience) and I can change this in next installation. The problem is when in same hosting we have more subdomain with more CMS installed and some of this required php 7.2.x
I hope that my case can help you for improvements

Thank you for your great work

Marek (marek) 14 Jul 2018, 12:18

In any case we must make it compatible with latest php version. For now you can work on 7.1. I write you back once the solution will be found out

Alessandro Borsani (AleBTstudio) 14 Jul 2018, 12:20

thank you, for now I go to switch on PHP 7.1
Thank you

Alessandro Borsani (AleBTstudio) 14 Jul 2018, 12:21

Can I switch PHP ver without makes anything? (without re installation?)

Marek (marek) 14 Jul 2018, 12:21

Yes, you can

Alessandro Borsani (AleBTstudio) 14 Jul 2018, 12:43

Ok now in PHP 7.1 it works!

OT: But revolution slider module is it included with promokit? because in slider revolution i see that i have to activate that module (thank you)

Marek (marek) 14 Jul 2018, 12:44

You don't have to activate it. Activation requires only to get updates directly from developer

Alessandro Borsani (AleBTstudio) 14 Jul 2018, 12:47

thank you

Alessandro Borsani (AleBTstudio) 15 Jul 2018, 10:58

thank you

Marek (marek) 18 Jul 2018, 10:49

Hi, Alessandro.
I still working to make layouts compatible with both php 7.1 and 7.2 but it's not so easy. Right now it works separately for 7.1 or 7.2. So if it's not critical for you, you can keep using 7.1. I hope to provide a fix in the next update.

Loading...