We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 09.10.18, 13:22
  • Reason: Closed
  • Comment: Glad to help!

Ticket #12675 - Wrong traslation

Hello, im trying to change some of the translation integrated on the theme.

There is a button inside the product page to add it to the cart. The traslation of the button is wrong, and i would like to change it, I have inspected the item using the browser it looks is just the name of the button in the code.
I tried to change it using the native translation module from Prestashop, but when i choose theme traslation, and my own language has a loading error code.
You can see attached the printscreen for more information.

I use Prestashop 1.7.2.2, PHP version 7.0, 5.2 alysum version.

website: https://fourwindsproject.com/ Wrong translation page page: https://fourwindsproject.com/four-winds-basic/10-53-four-winds-basic-negra.html#/2-size-m

The button is called “Matricúlate”(this is word is used in spanish to join a course or something similar, not used to add a product to the cart or buy it. The correct word should be Add to the cart (Spanish: Añadir)
Take into consideration the button appears too in the direct access from the homepage, if you click in the picture of the product it will open a new layer without leaving the home page, and the button appears again.
In added, if you add the product to the cart, and want to finish the procedures, appears another button called “Revise” the meaning is Check, and should appears Continue (Spanish: Continuar) or validate (Spanish: Validar)

Which is the way to change it in this case? Shall I modify it from his own file inside the theme using TPL? Where can i find the button code file?

This ticket does not depend on any other tickets.

Marek (marek) 09 Aug 2018, 11:08

Hi, Sergio Rubiales.
Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your back office

Sergio Rubiales (Sergio-Fourwinds) 09 Aug 2018, 11:37

Hello, al the information has been updated, waiting your feedback, Many thanks for you support
Best regards

Marek (marek) 09 Aug 2018, 12:10

I have found out an error message

Failed to copy "/webspace/siteapps/Prestashop-248197/htdocs/app/cache/prod/themes/alysum/translations/es-ES/ModulesCustomeraccountlinksShop.es-ES.xlf" to "
/webspace/siteapps/Prestashop-248197/htdocs/app/cache/prod/themes/alysum/translations/es-ES/ModulesCustomeraccountlinksShop.es-ES.xlf" because target file could not be opened for writing. 

So, it's not related to the theme, it's permissions question.
Try to set chmod 777 for the folder /webspace/siteapps/Prestashop-248197/htdocs/app/cache

Sergio Rubiales (Sergio-Fourwinds) 12 Aug 2018, 21:27

Good Afternoon,

I have set the permission to 777 for cache directory, the same message error appears, I tried to set 777 for the whole prestashop directory with the same result.
There is another way to modify it?

Best regards

Marek (marek) 13 Aug 2018, 11:31

Something wrong with files permissions http://take.ms/9b59k
Try to ask your hosting provider support how to fix that

Sergio Rubiales (Sergio-Fourwinds) 13 Aug 2018, 17:06

Hello Marek,
I have check the permissions, The permissions still 666 because everytime I connect with back office the files are updated and change into 666 permissions again, If I set them to 777 now, when I check traslation module in the back office, them automaticaly changes into 666 at the same moment. this issue just happens with Cache files. My host's technical services assure this is a usual operation with prestashop, and the changes are generated from prestashop because the files are updated with different permissions.

I have check similar questions in Prestashop forum and it looks normal, majority files from the cache folder are updated everytime we try to modify something, so wich is the next step?
i have tried to deactivate cache with the same result.

You can check what i mean using ftp and trying to acces to the traslation module, and is not a problem with the host or the permissions, many webs editors ask for similar errors in the prestashop forum and the answer is the same, cache is updated continuosly and then files are generated with the permission 666.

Best regards

Marek (marek) 14 Aug 2018, 13:54

I would like to help you but I really have no idea what's wrong with that. And the issue is not related to the theme. Try to ask prestashop community to help

Sergio Rubiales (Sergio-Fourwinds) 19 Aug 2018, 21:50

Hello Marek, I´ve been searching a lot, and PS forum recomended me to update PS version.

I have update PS to the latest version the theme can run, I have update php version and I have update the theme.

Thinking about the error, PS tries to open a cache file with permission 666, the error happens because the file cant be written, but 666 allows to write.

So could be a configuration mistake with backoffice? maybe i have to activate something there in order to modify the translation?

As a final solution, could be possible to modify the code for just the word i want to change?

I understad could be harder for me but Im sure you could find easily wich file should I modify, take into consideration just i want to change the word, not anymore.

Im sure you are having a lot of tickets to solve and this could take more than you can, but really it would be great if you lend a hand.

Have a nice day.

Marek (marek) 06 Sep 2018, 13:04

Hi, Sergio.
I'm sorry for the delay. Do you still need a help?

Sergio Rubiales (Sergio-Fourwinds) 06 Sep 2018, 16:48

Hello Marek, I already need the help, I tried everything ppl suggested me in Prestashop Forum, I updated the theme and the version of prestashop, but We still having the error with the traslation module.
Maybe there is any solution just modifing the files? Correct me if I´m wrong, bur every traslation must be included in the files, could I modify the word inside the file? I desist to use the module because there is any kind of error that doesnt allow me to use it. And we cant delete the whore web to start again because we are working at this moment, the problem is We know we are lossing some sales due this problem, the traslation as I told you is really bad, and this generates distrust in our customers. This is really important for us.

Best regards

Marek (marek) 07 Sep 2018, 12:53

I have found out the solution on prestashop bug tracker http://forge.prestashop.com/browse/BOOM-4443

Sergio Rubiales (Sergio-Fourwinds) 09 Oct 2018, 13:07

It´s solved Marek, Many thanks, in added for anyone who needs the same help, If you update de traslations to your own language it should be solved too. You can close the ticket.

Best regards,

Loading...