We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Status: Waiting on customer

Ticket #12697 - Layout Bulider: export doesn't work

Hi Marek,
at first thank you for your last release!
I installed Alysum last ver 5.2.4 for php 7.2 (like you know i need to work with prestashop 1.7.4.2 and php 7.2.x) and when i try to export in page builder function i received an 500 error. In my previusly ver all works fine.
Thank you

This ticket does not depend on any other tickets.

Marek (marek) 11 Aug 2018, 11:25

Hi, Alessandro.
I'm not able to connect to your server to make a fix

Alessandro Borsani (AleBTstudio) 11 Aug 2018, 12:15

Hi marek, I upload now new corect data of my server access. Here is my official site and not where i test (in test i have alysum 5.2.3 and php 7.1)
Please note that also when i try to upload an image with a widget and i click on choose button i receive error 500, in server test all work fine)
thank you

Alessandro Borsani (AleBTstudio) 12 Aug 2018, 10:45

Hi Marek, I have to downgrade PHP ver to 7.1 because too many features don't work properly in Alysum 5.2.4 with PHP 7.2 like:
- in all widget can't upload image
- in all row can't upload images
- all export button (template, style..) doesn't work
- posts in blog section can't be visible also from backend
- upload image in blog...

I think that all problems have same origin. I have switch in PHP ver 7.1 so we can continue with my webdesign work and you can solve it with more time. But I want inform you because last release doesn't work like it might be. (my opinion)
Thank you for your devolopment, when all will be ready please tell me the news.

Marek (marek) 12 Aug 2018, 10:58

Hi, Alessandro.
Thank you for your report, I'll check out all described issues, and make a fix in the next update

Marek (marek) 12 Aug 2018, 11:03

Let me please know how did you get 5.2.4 version, installed from scratch or updated from 5.2.3?

Alessandro Borsani (AleBTstudio) 12 Aug 2018, 11:14

I made a new installation of 5.2.4 ver
I just see that in swithing down php ver from 7.2 to 7.1 some css work and some widget don't show like before...a lot of hours go away...:(

Marek (marek) 12 Aug 2018, 11:58

Ok, I see, I'll make more tests

Marek (marek) 12 Aug 2018, 14:18

Here is the fix for images upload, if you need it now
http://take.ms/GwrOW

Marek (marek) 12 Aug 2018, 14:48

Export feature is fixed and will be available in the next update. if you need a fix please let me know

Alessandro Borsani (AleBTstudio) 12 Aug 2018, 15:20

Hi, Marek, I have to switch another time to php ver 7.2 because when i made downgrade to 7.1 all problems (i shopke up) were fixed but some css changing and some widget (like featured products and social links doesn't appeare anymore)
So I can make two things:
1 continue with php ver 7.1 and you help me to fix problem cuase downgrade
2 i switch to php 7.2 and you help me with fixes

Pls let me know your suggest way to continue

thank you

Marek (marek) 12 Aug 2018, 15:22

You can switch to php 7.2 and I'll make fixed then

Alessandro Borsani (AleBTstudio) 12 Aug 2018, 15:30

ok, i switch now. For fix image, where I have to add? (pls tell me the three because I know prestashop 1.6.x and is different

Other fix I need are:
1- blog post
2- export

thank you so much

Marek (marek) 12 Aug 2018, 15:33

1.
File: /modules/ph_simpleblog/controllers/admin/AdminSimpleBlogPostsController.php http://take.ms/JtUHy

2.
Files:
/modules/pspagebuilder/controllers/admin/AdminPspagebuilderFooter.php
/modules/pspagebuilder/controllers/admin/AdminPspagebuilderHeader.php
/modules/pspagebuilder/controllers/admin/AdminPspagebuilderMenu.php
/modules/pspagebuilder/controllers/admin/AdminPspagebuilderProfile.php

http://take.ms/7ENWo

Marek (marek) 12 Aug 2018, 15:36

The file for the first fix is /modules/pspagebuilder/controllers/admin/AdminPspagebuilderImage.php

Alessandro Borsani (AleBTstudio) 12 Aug 2018, 15:38

thank you a lot for your work

Marek (marek) 12 Aug 2018, 15:39

No problem. Please check out how stable it works now, especially Page Builder

Alessandro Borsani (AleBTstudio) 12 Aug 2018, 16:29

Marek i have just made all your fix and now all works properly. If I find some error or problem I will tell you soon. IN these days I'm made my new shop so It will be my preoccupation show you the result
thank you

Marek (marek) 12 Aug 2018, 16:34

Great! no problem!

Alessandro Borsani (AleBTstudio) 12 Aug 2018, 17:30

hi Marek,
in one refresh, without any changes, my footer shows like image in attached file. I have set row in footer builder "no" full width but now it is not more in according with site width.
What could be it?

Marek (marek) 12 Aug 2018, 17:43

I'm not able to login to your back office

Alessandro Borsani (AleBTstudio) 12 Aug 2018, 17:56

I just send you an email with data changing, but I'm making a new site in same domain where I have old site online. I have modify my host file in local machine to fix correct dns
Let me know how can make access you to my BO.
thank you

Marek (marek) 13 Aug 2018, 10:09

Hi, Alessandro.
I need details to add to my hosts file

Alessandro Borsani (AleBTstudio) 13 Aug 2018, 10:14

Hi Marek, sure!

DNS: 185.2.5.1
name domain: agpiu.com

Alessandro Borsani (AleBTstudio) 13 Aug 2018, 10:18

If you need other info I'm at your disposal. Account for BO is ready!

Marek (marek) 13 Aug 2018, 12:08

Now I see the website, but I'm not able to login to back office.
I also inspected module code and the issue with export should not be there.

Alessandro Borsani (AleBTstudio) 13 Aug 2018, 12:34

Why Can't you login?
user: [email protected] (not [email protected])

Alessandro Borsani (AleBTstudio) 13 Aug 2018, 12:35

the problem was footer width that is not according with site width

Marek (marek) 13 Aug 2018, 13:22

try with following settings http://take.ms/gMtiY

Alessandro Borsani (AleBTstudio) 13 Aug 2018, 15:06

It doesn't work, but i see that now you can log in in BO. If you try to view site you will see that doesn't change.

Alessandro Borsani (AleBTstudio) 13 Aug 2018, 15:38

I just see now that the problem about footer width is only for home page, if you click on a product the footer appeare right!!!
I want inform you about this css difference.
Pls let me know

thank you

Marek (marek) 13 Aug 2018, 16:00

Yes, I see now.
Find following code in your custom CSS code:

#pattern .page-width {

and replace with

body .page-width {
Alessandro Borsani (AleBTstudio) 13 Aug 2018, 16:22

I haven't this code in my custom css
I find the code only in file "generatedcss" and replace but now you can see in browser like it appeare!

Marek (marek) 13 Aug 2018, 16:29

Sorry, my fault.
Ok, just keep it in your custom code

body .page-width, body#index .page-width {max-width:1530px}
Alessandro Borsani (AleBTstudio) 13 Aug 2018, 17:24

I put it but doesn't work, you can check in website...
Now I can't see also my rev slider that just few minute ago I saw...a lot of instability with page builder...

Marek (marek) 13 Aug 2018, 17:27

Fixed

Alessandro Borsani (AleBTstudio) 13 Aug 2018, 17:30

thank you, I checked. I don't know what you do but now fixed :)

Marek (marek) 13 Aug 2018, 17:32

Glad to help

Loading...