We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 09.10.18, 13:33
  • Reason: Closed
  • Comment: Glad to help!

Ticket #12908 - Error on checkout (ContextErrorException in smarty_internal_templatebase.php(157) : eval()'d code li

Hello,

I am getting this error when a client tries to place an order. The error appears in the /order page, after filling out all the details.

(the error is attached)

Thanks

This ticket does not depend on any other tickets.

Guillermo Martínez (salesdeplata) 13 Sep 2018, 18:35

I have tried to delete the dev and prod folders from app/cache.
Nothing happens the error keeps going

Guillermo Martínez (salesdeplata) 13 Sep 2018, 18:59

I migrated the site, the new url is https://salesdeplata.com

Marek (marek) 13 Sep 2018, 22:10

Hi, Guillermo.
try following fix:
- open the file /themes/alysum/templates/checkout/_partials/steps/addresses.tpl
- find the line

<input type="hidden" id="not-valid-addresses" value="{$not_valid_addresses}">

- replace it with:

{if isset($not_valid_addresses)}<input type="hidden" id="not-valid-addresses" value="{$not_valid_addresses}">{/if}
Guillermo Martínez (salesdeplata) 14 Sep 2018, 16:34

Hi Marek.
It worked but now im gettinng another error in the order confirmation page. (attached screenshoot)
It happens once you have paid, at the confirmation page. In the backoffice the order is received and all the needed emails are sent.
I have tried with different users and adresses, on differente browsers and os but Im getting the very same error.

Thanks !

Marek (marek) 15 Sep 2018, 11:21

As I can see the problem is with the module psgdpr. Try to disable it and test an order once again

Guillermo Martínez (salesdeplata) 15 Sep 2018, 13:54

Okey, once i have uninstalled the module. The confirmation page is show with no erros.

How can I make it compatible with the psgdpr module ? I think this module is very important with the new law.

Thanksss !

Marek (marek) 15 Sep 2018, 13:54

I'll take a look and back to you with some news as soon as possible

Marek (marek) 15 Sep 2018, 14:29

Try to upload attached files to your server
/themes/alysum/modules/ps_emailsubscription/views/templates/hook/ps_emailsubscription.tpl
/themes/alysum/modules/contactform/views/templates/widget/contactform.tpl

Guillermo Martínez (salesdeplata) 15 Sep 2018, 14:34

I have to add them, install the gdpr module and try to reproduce the error, right ?

Marek (marek) 16 Sep 2018, 11:06

yes, right

Loading...