We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation

Promokit HelpdeskAlysum AMP theme

  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 04.12.18, 12:13
  • Reason: Closed
  • Comment: Glad to help!

Ticket #13218 - "product-actions"

Hello Marek!
I wrote to the developer of the Advanced pack 5 module the following message and then I copy your answer to see if you can help me with this:

Hello again!
The “add to cart” button on the product page of the packs no longer works. and also behaves strange color and size selector... I put you next the link to a product page (of a pack)
https://elsximplets.cat/samarretes-dona/212-715-samarreta-eco-dona-torracollons.html#/72-ap5_pack-212_defaultcombination

On the other hand, in this same page you can see that the related products of the packs copy the attributes of the Pack.
The related article that you can see in this page, is a simple article without combinations, but it shows the size and colors selector with the same values of the pack.

Best regards,
Cristina

Hi,

Theses two errors are related to the /themes/alysum/templates/catalog/_partials/miniatures/product.tpl template of your theme.

There is an implement of a div with “product-actions” class ; this element is not present on the default theme there, it’s inside the product.tpl main file.

Once it’s renamed to be compliant with the standard behavior, it’s work great about the two issues.

Regards,

__

I also want to tell you that the “add to cart” button on the product pages doesn’t work well for me either... I put you a link to product page. If you click on add to cart is left thinking, you must update the page so that the product is loaded into the cart and the icon leaves the state of “loading”.
https://elsximplets.cat/tasses/46-tassa-sucar-el-melindro.html

The same thing happens from the home with the thumbnails of the “isotope”. If you click on the icon of the cart, it remains rotating until you update.
I copy you the direct link to the Home.
https://elsximplets.cat/

Best regards!
Cristina

This ticket does not depend on any other tickets.

Marek (marek) 10 Nov 2018, 11:27

I just renamed that class, please check it out

ximplets catalans (ximplets) 10 Nov 2018, 12:20

Hello!
* Related articles are OK - no longer take the attributes of the pack (issue solved)

Unresolved issues:
* The "add to cart" button on the product page (when the product is a pack) does not work.
link product page pack: https://elsximplets.cat/samarretes-dona/212-715-samarreta-eco-dona-torracollons.html#/72-ap5_pack-212_defaultcombination

* The "add to cart" button on the product page (when it is a simple product) remains loading. You need to refresh the page to load into the cart and stop spinning.
product page link: https://elsximplets.cat/tasses/46-tassa-sucar-el-melindro.html

* Add to cart" icon on the Home isotope behaves in the same way as the "add to cart" button on the product page. It remains loading until you refresh the page.
Link to home: https://elsximplets.cat/

Best Regards!
Crsitina

Marek (marek) 11 Nov 2018, 10:32

Please try the solution given in the ticket https://support.promokit.eu/index.php?do=details&task_id=13221

ximplets catalans (ximplets) 12 Nov 2018, 12:12

Good morning, Mareck,
I deleted the code as you indicated and the problem persists:
When I click Add to cart, as well as when I remove an item from the cart, the action is performed but not refreshed automatically, so from the point of view of the customer, neither added to the cart nor removed.

Link to article page: https://elsximplets.cat/tasses/45-tassa-quins-pebrots.html

In the product pages of packs, the action, directly, is not carried out. Three blue rounds appear and nothing happens.

Link to article page "Pack": https://elsximplets.cat/samarretes-dona/212-715-samarreta-eco-dona-torracollons.html#/72-ap5_pack-212_defaultcombination

Marek (marek) 12 Nov 2018, 23:48

Have you tested your module out with default prestashop theme? Please do it to make sure the module works correctly there

ximplets catalans (ximplets) 14 Nov 2018, 11:15

Good morning, Marek,
As you indicated, I set the classic theme to check the problem without Alysum and the same thing was still happening.
I also uninstalled the Advanced Pack 5 module and it kept happening... I've been seeing it with the developers of the Pack and we've already located it, but I need a part of you.
I'll update you:

ADVANCED PACK DEVELOPER: After I enabled the debug mode of PrestaShop (for my IP address only), I could see that your Mailchimp Integration module is causing errors on all the pages of your shop (home, categories, products, etc..).

You should contact its developer in order to fix this, as this might be a cause of why you cannot see these buttons on the pack page. You can find attached a screenshot of the error to give to its developer.
Link to screenshot pict: http://addons.prestashop.com/attachment/community/627/5bea8a5449d86.png

ME: I uninstalled the mailchimp module.
I reinstalled the Advanced Pack 5 module. I tested my website with the classic template.

I still have problems with the Add to cart button with both packs and items, but with differences in behavior between them:
*Icon to add to cart above the thumbnails of the home:
-Simple articles: Add the product to the cart but the page is not updated, so it is not visible to the user.
-Pack: Works correctly

*Add to cart button on the product page:
-Simple articles: Add the product to the cart but the page is not updated, so it is not visible to the user.
Pack: Does not add the item to the cart but links to the page of the cart.

Items / packs added to the cart, viewed from the page of the cart: if you want to remove them by the cross, are removed, but not updated page the user does not see.

Link product page (pack) https://elsximplets.cat/samarretes-home/227-1023-samarreta-home-pixar-fora-de-test-blau-mari.html#/84-ap5_pack-227_defaultcombination Link product page (article) https://elsximplets.cat/tasses/45-tassa-quins-pebrots.html Link home: https://elsximplets.cat/

ADVANCED PACK DEVELOPER: There is a JavaScript error on all the links you sent, which seems to be related to "Chimpstatic".

Do you have any module that adds scripts related to this service? If so, contact their developer to fix this JavaScript error, as it will block all other scripts on the page from executing, including the one which handle the add to cart.

ME: I had the mailchimp module and consequently to your message that said it caused me problems, I uninstalled it.
As far as I know, I don't have anything else...
The only modules installed are Advanced Pack 5 and Redsys. And on the other hand the Alysum theme.

ADVANCED PACK DEVELOPER: The uninstall of the Mailchimp module made the JavaScript error disappear, which is a good point.

Regarding the issues you are reporting us, I can see that none of your products can be added to the cart while using the "Add to cart" button, the animation keeps spinning indefinitely, which is not a normal behavior.

Before investigating the issue on the pack page, you should contact your theme developer to find out why the add to cart is not working on classic products (there is the following error in the return of the AJAX call made to your shop when trying to add to the cart : "Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /usr/home/elsximplets.cat/web/controllers/front/CartController.php on line 128". Give this information to your developer for a fix).

Excuse me for the extension of the message, I need to solve this problem to open my online store and I think that sharing all the information, the path will be more direct.

Best Regards!
Cristina

ximplets catalans (ximplets) 15 Nov 2018, 10:14

Hello Marek!
Sorry to insist, but the developers of the module and I are waiting for your answer to fix the bug that prevents me from opening my e-commerce. I know that there is a time difference, but 24H have passed since my last comment and as you can imagine, it is very urgent to solve it for me and I've been with this for many days (although it is not alysum problem directly but I can only get to the solution with you).
Thank you for understanding the situation.
I look forward to hearing from you ;)

Best Regards!
Cristina

Marek (marek) 15 Nov 2018, 10:17

Sorry for the delay, I'll give you a reply within a couple of minutes

Marek (marek) 15 Nov 2018, 10:34

So, yes, I see the issue what Ajax "Add to cart" function returns

Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /usr/home/elsximplets.cat/web/controllers/front/CartController.php on line 128

But the problem is that file is a core prestashop file and I can't make a fix inside prestashop. There is another way to get it fixed, you can disable showing "deprecated" errors in the server configuration.
Please try and let me know the result.

ximplets catalans (ximplets) 15 Nov 2018, 10:38

Thank you for your reply!
I don't know how to do what you're telling me to do... Where is the server configuration?

ximplets catalans (ximplets) 15 Nov 2018, 11:01

Hello Marek!
I've done it and everything is working except for the product pack page that I'll continue to work with the Advanced Pack guys.

Icons from Home, add to cart on product page and remove items from cart already works!

THANK YOU!

Marek (marek) 15 Nov 2018, 11:08

great! Let me know in case some issues, I'll try to help you as soon as possible

Loading...