We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation

Promokit HelpdeskAlysum AMP theme

  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 12.12.18, 11:14
  • Reason: Closed
  • Comment: Glad to help!

Ticket #13326 - Update the theme as brand new

Hi there,

I’ve made some changes at the theme today and I just feel I want to start over. I uninstalled the theme and uploaded it again from the .zip but it keep showing the changes I did before (as erasing the header layout at the Page Builder or some custom css I added). Is it possible to actually upload the theme as it was brand new?

Another question is, I’ve add some custome css but then I realize that once I applied the setting I couldn’t take them back? Is that right?

Anyway, I hope you can help me.

Sorry if my English is not that good :)

Best regards,
Xiana

This ticket does not depend on any other tickets.

Marek (marek) 05 Dec 2018, 21:59

Hi, Xiana.
No problem with English, I also not a native speaker :) As for your issue, you can just reset Theme Settings or Page Builder modules and that's all.
I didn't understand your problem with css, can't you just remove those styles you have added before?

Xiana Diaz (betterwithco) 07 Dec 2018, 09:51

Hi Marek!

Thank you for your quick answer. Reseting Page Builder module was easy, thanks! But when I tried to do the same with the Theme Settings it shows me an Error: I am not allowed to rest it. Anyway, I just find out that the module has gone, uploaded it again and voilà, everything is right now :P. On the other hand, I added some customized CSS at the Alysum Settings > Customer CSS tab, and when I tried to remove it I just couldn't; it was no longer at the tab but when it leaded me to the CSS file it was there, sticky without any chance to remove it. Is this normal? or just a bug?

Thank you! Have a nice day!
Best regards,
Xiana

Marek (marek) 07 Dec 2018, 16:27

Hi, Xiana.
Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your back office I need to check out the issue

Xiana Diaz (betterwithco) 07 Dec 2018, 16:55

Hi Marek,

I've already filled the fields for you to access my backoffice. Now you can see there is an "h" at the Custom CSS you can not erase (the previous changes I made are now gone as the Theme Settings module is the new one).

Thank you!
Xiana

Marek (marek) 07 Dec 2018, 17:04

Yes, I see it works now. So You didn't save your custom code before module reset?

Xiana Diaz (betterwithco) 07 Dec 2018, 17:58

Oh! Don't worry, I was just playing around with the CSS, not big deal ;). The issue is that I can not erase the custom CSS once I applied it and it shouldn't be that way, right? Can you erase the "h" appearing now at the CSS?

Marek (marek) 08 Dec 2018, 10:26

I just changes custom CSS with no problems http://take.ms/WFbCg

Xiana Diaz (betterwithco) 08 Dec 2018, 10:40

Ok... so nos I am trying to erase your "class{}" and I can not do it. I delete the words, "Apply settings" and they are still there... So sorry, I can not find the way to make changes if I want to take back some custom CSS. Is there anything I am missing here?

Xiana Diaz (betterwithco) 08 Dec 2018, 13:33

Hi Marek,

Another issue I am having (so sorry!) is that the margins go crazy when I chose the Preset I want for my shop "Lingerie". See images attached: on both sides I barely have margins and the top Header is cut by half :/

Thanks!

Marek (marek) 08 Dec 2018, 15:28

1. If you want to remove custom CSS completely, you have to delete css file. See the path in the Theme Settings → Custom CSS 2. Try following CSS:

.header-bottom > * {padding:0 20px}
Xiana Diaz (betterwithco) 08 Dec 2018, 16:13

Hi Marek,

I am not talking about erasing all the custom CSS but just want to know how to make changes on my custom CSS. Now I've added the CSS you sent me and I can not delete it, furthermore, it didn't change anything but the color of the menu, which is very weird... (now is black and I can not set it transparent again). I wonder if I did a wrong installation because it seems to be a lot of problems that are driving me crazy and I haven't even started with the shop. Anyway, the problem is not only with the header margin but with all margins on the preset.

Besides, when I try to reset the "Theme Settings module" it takes me to an error (attached) and then, the module just dissapeared (and I have to upload it again).

Any clue about why nothing is working as supposed? :(

Thanks,

Xiana Diaz (betterwithco) 08 Dec 2018, 16:32

This is going crazy...

Marek (marek) 08 Dec 2018, 17:13

As I can see you have succesfully added custom CSS and it works. Why do you need to reset the module?

Xiana Diaz (betterwithco) 08 Dec 2018, 17:28

Hi Marek,

I am just telling you what issues I have on my webpage; don't seem normal to me these errors I am finding on the way of customizing my site; and I barely started... Anyway, can you tell me something about the wrong margins on my site? It doesn't look at all as it shows on the "Presets tab".

Marek (marek) 08 Dec 2018, 17:30

Could you please take a screenshot? because it's not clear for me what exactly wrong

Xiana Diaz (betterwithco) 08 Dec 2018, 18:37

Maybe it has something to do with my 13' laptop?

Marek (marek) 08 Dec 2018, 18:47

I see now the issue with custom code. It seems has no permissions to write .css file - modules/pk_themesettings/assets/css/dynamic/customercss1.css

Please check out permissions (chmod) should be 777

Xiana Diaz (betterwithco) 10 Dec 2018, 09:50

Hi Marek, I changed the permissions but nothing changed. Anyway, I'll do it directly on the CSS file instead on the Alysum Settings > CSS Tab.
Do you have any clue about why I have no margins on my site?

Thanks!

Marek (marek) 10 Dec 2018, 09:51

Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your server through FTP I need to check module files

Xiana Diaz (betterwithco) 10 Dec 2018, 09:55

Ready!

Marek (marek) 10 Dec 2018, 10:12

I can not find there where to see folders/files permissions. Could you please give me details to direct access through FTP, not to your SiteGround account

Marek (marek) 10 Dec 2018, 11:16

Ok, so, I just added custom CSS: .class{color:red} and it works http://betterwithco.es/modules/pk_themesettings/assets/css/dynamic/customercss1.css

I have no idea what was wrong, but now it works. And that is definitely not theme's issue

Xiana Diaz (betterwithco) 10 Dec 2018, 11:18

Ok, thanks. Anything about the margins?

Marek (marek) 10 Dec 2018, 11:27

You can use the code I sent you before. Or set margins in your header builder http://take.ms/MVX5k

Xiana Diaz (betterwithco) 10 Dec 2018, 17:25

Hi Marek,

Is it possible to edit the widgets CSS?

Marek (marek) 10 Dec 2018, 18:15

yes, of course. you can override current styles with your own in the Custom CSS

Xiana Diaz (betterwithco) 11 Dec 2018, 12:22

Hi Marek,

I need to translate all captions. Can you show me the path where I can do it? Also, I want to change the thumbnails size (on Product Page)but it is not with all the imagen_default settings at the Presta Shop menu, can you show me where to find it?

thanks!

Marek (marek) 11 Dec 2018, 12:49

Hi, Xiana.
You can read about translation in our documentation http://alysum5.promokit.eu/promokit/documentation/#translation

Xiana Diaz (betterwithco) 11 Dec 2018, 13:09

Thanks! Can you tell me something about where to change the ratio of thumbnails images?

Marek (marek) 11 Dec 2018, 13:10

You can read about that in our documentation http://alysum5.promokit.eu/promokit/documentation/#images

Xiana Diaz (betterwithco) 11 Dec 2018, 19:08

Hi Marek, how can I add my custom tabs to my product page?

Marek (marek) 11 Dec 2018, 23:08

Please make sure the module Custom Tabs is installed and enabled. Then add custom tab in the module

Xiana Diaz (betterwithco) 12 Dec 2018, 09:23

Custom Tabs is installed, enable and I've already added two custom tabs, but how I include them on the Product Page with the Widget Tab? The final step is what I am missing here.

Marek (marek) 12 Dec 2018, 10:29

You missed these options http://take.ms/KNOGn now it works

Xiana Diaz (betterwithco) 12 Dec 2018, 11:06

Sorry... thanks!

Loading...