Promokit HelpdeskCustomisations

  • Priority: Medium
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 30.03.19, 19:29
  • Reason: Closed
  • Comment: Glad to help!

Ticket #13438 - Menu widget edit

Hi, is it possible to change the menu widget for Categories in Parent to not show the Parent item?
On my website testps.thestitchersmuse.com - under menu item Shop - mega menu show image, then Category Widget - shows Books & Patterns, and then shows Books & Patterns again - first one is the widget title (which I like the design of), the second is the Parent Category - which I would rather not show - and just show Patterns by Designer, Books, and Patterns by Technique.

This ticket does not depend on any other tickets.

Dione (CrystalPhoenix) 30 Dec 2018, 08:59

Also wondering - to set the page so there is some room around it (white space) - is that set under the page width (default setting 1830)? or is there another place I can set so there is some empty space around the page - possibly with a background image? For CMS page the text is set right next to the edge of the screen (About page) - makes it hard to read.
Thanks!

Marek (marek) 30 Dec 2018, 12:19

Try following CSS to hide parent category:

.widget-subcategories ul > li:first-child {display:none}

Could you please add some screenshots, because I can't understand where exactly the issue with spaces

Dione (CrystalPhoenix) 30 Dec 2018, 18:35

Screenshots attached - About Us cms page goes right to the edge of the screen. I'd also like more room on other pages so page is not side-to-side and images are not quite so large(screenshots are taken on my laptop).

Screenshot (32).png (147.4 KiB)
Screenshot (33).png (959 KiB)
Dione (CrystalPhoenix) 30 Dec 2018, 18:39

sorry - where is the css file for changing the widget?
Tried the themes>alysum>assets>css>theme.css & added it at the end but it didn't seem to make a difference. Not important, though - so no rush.

Dione (CrystalPhoenix) 30 Dec 2018, 19:29

Newsletter signup form in the footer - where does that go? I use Mailerlite, which does not currently have a Prestashop integration. How can I add the link for signing up? Add html code instead of the default email signup? I should add that I have several different lists for different activities/interests so would like to send the customer to the email landing page in Mailerlite.
Thanks so much for all your help from an almost-luddite...

Dione (CrystalPhoenix) 30 Dec 2018, 21:17
Dione (CrystalPhoenix) 30 Dec 2018, 22:05

Contact information in the footer - where do I find the icon list to customize this area?

Marek (marek) 31 Dec 2018, 11:07

Hi, Dione.
You can find the Lin in our documentation http://alysum5.promokit.eu/promokit/documentation/#svg

Dione (CrystalPhoenix) 01 Jan 2019, 23:33

There is a newsletter signup form in the footer by default - I would like to configure it to automatically go to my Mailerlite landing page - how can I do that?
Also would like to scale down the font in the Contact widget which I've installed beside my logo in the header.
Thanks for all your help.

Marek (marek) 02 Jan 2019, 12:30

Where is you Mailerlite landing page?
to find what class to edit in your contact widget you have to use Chrome Developer Tools. see the video here https://www.youtube.com/watch?v=wcFnnxfA70g

Dione (CrystalPhoenix) 02 Jan 2019, 19:56

Back to the question about space around the page - cms pages, checkout page, etc. go right to the edge of the screen on both my laptop and my old desktop (old, square monitor). Makes it hard to read and does not look well-designed. On my laptop it looks much better if I reduce the zoom on the screen to 75% or 67% - I'll attach a screenshot as soon as I get back to my laptop, but I'd like it to look like that by default and have the font size the same as without the zoom-out - screenshots 32 & 33 above show the current configuration.

Marek (marek) 03 Jan 2019, 11:49

So, you want to go to that landing page by click to the button "Subscribe"?
As for page view, you can adjust the width as you like in the Theme Settings → General → Page Width

Dione (CrystalPhoenix) 04 Jan 2019, 00:25

Newsletter subscription - yes, I would like the button to go to the landing page.
I've tried changing the page width but it doesn't seem to make much difference - when it does, the text and logo in the header are the same size and overwrite each other. Is there a way to reduce the font size for the Contact widget I have in the centre? I can reduce the size of the logo in a third-party program.

Alex Support (Admin) 05 Jan 2019, 10:55

Hi. I can help you with the modifications for a small price. It will cost about 10-20 euro.
If it's ok for you just write me back and I will help you.
What the info I need:
1) Subscribe button.
Do you mean this block? https://c2n.me/3YZlyYa

Hide field email and just leave button?

2)

I've tried changing the page width

CMS page. It seems fine for me https://c2n.me/3YZlC6o
How do you want to see it? Show me please with the screenshot.

3)

Is there a way to reduce the font size for the Contact widget I have in the centre? 

In the header?

.block-contactinfo .nav-item {font-size: 12px}

and if you need to reduce the margin between contact lines https://c2n.me/3YZm332
change to this

.block-contactinfo .nav-item {
  font-size: 12px;
  margin-bottom: 0;
}
Dione (CrystalPhoenix) 06 Jan 2019, 18:42

Hi Alex,
Answered in the order they appear above:
Email subscription box - yes that is the one I was referring to. I will consider hiring you for the modification - but will first contact my email list support to see if I can do it myself - mainly because if I need to change it in the future I will then know how.
The page width is working for me at the moment. I will survey my customers to see if they like the page as-is or if they'd like it to be narrower - now I know where to change that. It seems fine on android and will test on a tablet later today.
Changing the contact widget - brings up a general question - where do I change the css - IE, which module? Or is it better practice to add the new css in a separate file, so that the changes will continue through upgrades/updates to the theme and to PS? I think I added some previous css to the main css file, but I'm now rethinking that since it would be overwritten with an update - correct? I think I saw a place where custom css or custom js or custom html could be added?
Thank you for your help and support on these questions.

Alex Support (Admin) 10 Jan 2019, 23:41

Hi. Sorry for waiting. I was very busy these days.

Email subscription box

How do you want to see this block?
Just button SUBSCRIBE and redirect to your mail landing page or leave it by default and just send customers email to the landing page?

where do I change the css - IE, which module?

You can add the css in the BO > Theme Settings > CustomCSS ;) This file won't be overwriten since update :) Anyway. Always do backups before any update Ps or theme

Dione (CrystalPhoenix) 01 Feb 2019, 23:25

Email subscription - first option - Subscribe button which sends to landing page.

Alex Support (Admin) 03 Feb 2019, 19:16

Hi.
file location \modules\pspagebuilder\views\templates\front\widgets\widget_newsletter.tpl
remove whole tag

<form> .. </form>

with the code

<button class="btn btn-primary"><a target="_blank" rel="nofollow" href="https://www.subscribepage.com/Email_Subscription">{l s='Subscribe' mod='pspagebuilder'}</a></button>
Dione (CrystalPhoenix) 03 Feb 2019, 23:34

Thank you - that works perfectly.
More questions:
Font is quite large on my older monitor - is there a way to make it dynamic to accommodate different screen sizes? See attached screenshots.
Site still shows too close to left side of old monitor - see screenshot.
Subscribe button for the newsletter is not centered on the page - see screenshot.
Does Alysum control back office view? I have a problem with the categories widget on the product edit page being too narrow.
Where can I edit the text for the newsletter subscription "stay up to date"?
Is it possible to slow down the menu so it isn't as "jumpy"?
How to make the blog images on the front page smaller? Load a smaller picture or is there a way to set default size somewhere? Is there any documentation on the Simple Blog?
Please refresh my memory on where I can edit the email templates.
Sorry for so many questions!
Thank you!
Dione

Dione (CrystalPhoenix) 04 Feb 2019, 20:38

Next issue:
Category page - when scrolling down, "Load More" shows - when clicked on, more products appear but their images & info do not load - just the "loading" symbol. Products never load even if the page is left alone for hours. Please tell me how to fix this as the site is now live and I don't want to give customers a bad impression.

Alex Support (Admin) 05 Feb 2019, 22:01

Hi. Please look no your site look much better.

Font is quite large on my older monitor - is there a way to make it dynamic to accommodate different screen sizes? See attached screenshots.
Site still shows too close to left side of old monitor - see screenshot.

Fixed. Please check. Added fix to the CustomCSS

Does Alysum control back office view? I have a problem with the categories widget on the product edit page being too narrow.

Show me please the screenshot.

Where can I edit the text for the newsletter subscription "stay up to date"?

https://c2n.me/3ZCYvYt :)

Is it possible to slow down the menu so it isn't as "jumpy"?

Is this menu open/close effect you mean? Make it slower? http://www.youtube.com/watch?v=eF-2p6Xmeu0

How to make the blog images on the front page smaller? Load a smaller picture or is there a way to set default size somewhere? Is there any documentation on the Simple Blog?

Better way upload smaller image. I've fixed the issue with the image size for mobiles. Documentation https://alysum5.promokit.eu/promokit/documentation/blog/

Please refresh my memory on where I can edit the email templates.

Here is location themes\alysum\mails\en\

Subscribe button for the newsletter is not centered on the page - see screenshot.

Fixed with the PageBuilder settings - widget Newsletter, content centered

Also:
Fixed header. Readjusted it a little for better responsiveness. Is it ok the look now for your opinion?

- reduced the size of these images https://c2n.me/3ZCQTQc from about 700kb to 50kb. It's important for page performance

menu readjusted the images size https://c2n.me/3ZCRHNY to this https://c2n.me/3ZCVbt6 –reduced the img size
–on mobile your menu looked like here https://c2n.me/3ZCX4rt because of this pagebuilder image seting https://c2n.me/3ZCXctu now it's ok https://c2n.me/3ZCXul3
—-if you want I can hide images for mobile devices

- Fixed a lot of small bugs for site performance https://c2n.me/3ZCVoXx
and now it looks better https://c2n.me/3ZCYbey
I can try more improve performance for additional small payment. Write me back if you need my help with that

- fixed footer layout issues
- fixed mobile and tablet layouts issues.

Spend a few hours for that. So the payment will be 35 euro. Sorry that I didn't wrote the estimate price before work. But I thought there will be a few small issues.
But there was a lot of small wrong settings in the page builder blocks. Now your site looks nice. If you need to change something or I did something wrong just write me back and i will fix it.

Marek (marek) 06 Feb 2019, 11:07

As for the issue with Lazy load, something wrong with files permissions in your server, I'm not able to open js file through browser http://thestitchersmuse.com/modules/pk_infinitescroll/views/js/front.js

Please ask your hosting provider to fix it out

Alex Support (Admin) 12 Feb 2019, 10:09

Hi. Dione. Is everything ok? I didn't get any feedback from you :)

Alex Support (Admin) 02 Mar 2019, 17:15

Hi. Dione. I didn't gent any answer from you. I would ask you to make a payment for my work. I've send you the invoice to the admin email

Alex Support (Admin) 11 Mar 2019, 23:43

Hi. I've got payment from you. Thank you.
Write me back if you need some help

Loading...