• Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 20.02.19, 10:47
  • Reason: Closed
  • Comment: Glad to help!

Ticket #13721 - Newsletter Error Message

Hi,
I have a problem with ps_emailsubscription. If I enter any email, I always receive an error message: “indirizzo email giĆ  registrato”... in english should be “already registered email address”(img01). However, the e-mails are sent.

If i use newsletter form widget instead i have no error.

But i have to use ps_emailsubscription because it is also present in other pages.

Do you know how to solve this problem?

img-2.jpg (104.7 KiB)

This ticket does not depend on any other tickets.

Marek (marek) 11 Feb 2019, 14:29

Hi, Walter.
I need access to module files to figure out what's wrong. Current credentials doesn't let me to connect

Walter Fontana (cmgroup-web) 12 Feb 2019, 09:18

Hi, Marek
credentials are right.
But FTP PORT: 31210

Walter Fontana (cmgroup-web) 13 Feb 2019, 09:46

Hi, Marek
is it possible to solve this problem?

Marek (marek) 13 Feb 2019, 11:00

Sorry for the delay.
I have tested out a module and a widget and a widget works fine http://take.ms/cqICL The problem with module is that is native prestashop module and I can't fix it so just use the widget, there is no difference

Walter Fontana (cmgroup-web) 13 Feb 2019, 11:55

Yes, but can i use the widget in other pages? I have newsletter box also in contact page.
How can i do?

Marek (marek) 13 Feb 2019, 12:20

Yes, that is a problem. I'll try to figure out why it doesn't works

Walter Fontana (cmgroup-web) 14 Feb 2019, 12:15

But can you do that in these days?

Marek (marek) 14 Feb 2019, 12:16

Yes, of course

Marek (marek) 15 Feb 2019, 13:15

it should work now, please check it out

Walter Fontana (cmgroup-web) 15 Feb 2019, 14:59

Yes, thank you very much.
just a question: where i translate "Email already registered" and "Subscription successful"?

Marek (marek) 16 Feb 2019, 10:12

It should be available here http://take.ms/a0qaa

Walter Fontana (cmgroup-web) 18 Feb 2019, 10:32

I tried but it does not work because I'm using the module, not the pagebuilder widget.(img01)

Can i change it from code? Where?

img01.jpg (139.9 KiB)
Marek (marek) 18 Feb 2019, 11:08

There was an error in syntax, now it's fixed and you can translate it http://take.ms/fQ0xK

Walter Fontana (cmgroup-web) 18 Feb 2019, 14:38

i translate them but i have the same problem (img02)

img02.jpg (150.6 KiB)
Marek (marek) 18 Feb 2019, 18:16

Something strange is going on. Prestashop generates wrong translation ID. I have opened the file it.php and changed "newsletter" to "pspagebuilder", see screenshot http://take.ms/PJCsv

Walter Fontana (cmgroup-web) 20 Feb 2019, 10:46

ok thanks!

Loading...