Support will be provided with delays until 20 August. We are sorry for the inconvenience.
We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Priority: Medium
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 01.08.19, 12:23
  • Reason: Closed
  • Comment: Glad to help!

Ticket #14235 - Acceptance privacy on all contact form and newsletter box

Hello, i need add for european law in every registration form, contact form, newsletter form, popup newsletter box for privacy acceptance.
Why your theme not have it?

Thanks

This ticket does not depend on any other tickets.

Marek (marek) 10 Apr 2019, 14:58

Hi, Gabriele.
Because there is special module exists for that, just search GDPR in your back office

Gabriele Oldrati (creativonato) 10 Apr 2019, 15:27

Thanks... i do that, but there are some problems with layout... check attachments.
Thanks

Marek (marek) 10 Apr 2019, 22:51

Please give me a link to that page, I need to see the issue

Marek (marek) 13 Apr 2019, 15:09

I see only this http://take.ms/9a26a ? Did you modify something in the contact page settings?

Gabriele Oldrati (creativonato) 13 Apr 2019, 16:15

Not yet... i need chance that Page with right data

Marek (marek) 13 Apr 2019, 18:20

The issue has been fixed. Please check it out

Marek (marek) 13 Apr 2019, 19:41

But I see it looks correctly http://take.ms/7B77u

Gabriele Oldrati (creativonato) 17 Apr 2019, 11:45

Yes...thanks, how can i manage that page? I need hide left sidebar, and manage all other fields.

Marek (marek) 17 Apr 2019, 11:57
Gabriele Oldrati (creativonato) 17 Apr 2019, 15:20

I need change layout mean:
_ i’d like maps fullwidth
_ center contact form and add text
_ manage icons and design of page.

All of my changes need to be saved also after theme update.

Marek (marek) 18 Apr 2019, 12:37

Our support doesn’t cover theme customisation.
Try to add following CSS to the Theme Settings:

.row.contact-page {display:flex;flex-direction:column}
.contact-form-map {width:100%}
.contact-page .login-form {margin: 0 auto}

Read about icons here: https://alysum5.promokit.eu/promokit/documentation/#svg

The content of that page is in the file /modules/contactform/views/templates/widget/contactform.tpl

Gabriele Oldrati (creativonato) 18 Apr 2019, 12:48

How can I customise that tpl file and save it for future theme update?

Marek (marek) 18 Apr 2019, 13:17
Gabriele Oldrati (creativonato) 18 Apr 2019, 15:51

Can you help to me to install and activate child?

Marek (marek) 19 Apr 2019, 13:42
Gabriele Oldrati (creativonato) 29 May 2019, 15:35

Miss checkbox for European law of privacy cookie policy…

Marek (marek) 31 May 2019, 13:26

Make sure you have enabled psgdpr module

Gabriele Oldrati (creativonato) 31 May 2019, 13:31

Yes is activated but not appear

Marek (marek) 03 Jun 2019, 10:04

Yes, I see now. We will try to fix that for the next update. You can use newsletter module instead for a while

Gabriele Oldrati (creativonato) 03 Jun 2019, 11:04

No, i can’t for european GDPR law

Marek (marek) 03 Jun 2019, 11:16

You seems didn’t understand my message. You can use Newsletter module instead of Newsletter widget

Gabriele Oldrati (creativonato) 03 Jun 2019, 12:15

I need pay module also for some days

Marek (marek) 03 Jun 2019, 12:41

no, that module is free and available in your back office

Gabriele Oldrati (creativonato) 04 Jun 2019, 14:25

Newsletter module have not right layout. I try it but it’s not have right CSS!
I need also translate all messages...

Gabriele Oldrati (creativonato) 04 Jun 2019, 18:44

and i see that not send subscriber to mailchimp also if i have connected mailchimp with prestashop and activate mailchimp and mailchimp modules.

Marek (marek) 05 Jun 2019, 16:55

1. What’s the problem with layout? it looks fine for me.
2. You can make translation in the file /modules/pspagebuilder/views/js/pagebuilder.js for a while. We will add translation options in further releases
3. I have no ideas about mailchimp but I’ll try to figure out what’s wrong

Gabriele Oldrati (creativonato) 05 Jun 2019, 16:58

the problem is that i try to register myself to newsletter. receive confirmation of registration with green message “Subscription successful” but i never receive email from mailchimp to confirm that. And in mailchimp there isn’t my email.

Gabriele Oldrati (creativonato) 05 Jun 2019, 18:50

there aren’t sentences to translate in that file.
Not found “Invalid email address” not found “email already registered” not found “Successfully”

Marek (marek) 09 Jun 2019, 15:15

1. We are tying to figure out what’s wrong with registration
2. You can make translation in the file /modules/pspagebuilder/views/js/pagebuilder.js for a while. We will add translation options in further releases

Gabriele Oldrati (creativonato) 09 Jun 2019, 16:56
Warning: preg_match(): Compilation failed: regular expression is too large at offset 43779 in /var/www/support/public_html/plugins/dokuwiki/inc/parser/lexer.php on line 117

i don't find in that file right sentences to translate

Marek (marek) 09 Jun 2019, 17:37
Warning: preg_match(): Compilation failed: regular expression is too large at offset 45100 in /var/www/support/public_html/plugins/dokuwiki/inc/parser/lexer.php on line 117

Here is it https://take.ms/Fgrgq

Gabriele Oldrati (creativonato) 09 Jun 2019, 17:46
Warning: preg_match(): Compilation failed: regular expression is too large at offset 46421 in /var/www/support/public_html/plugins/dokuwiki/inc/parser/lexer.php on line 117

But all others messages?

Marek (marek) 09 Jun 2019, 17:51
Warning: preg_match(): Compilation failed: regular expression is too large at offset 47742 in /var/www/support/public_html/plugins/dokuwiki/inc/parser/lexer.php on line 117

Have you tried to translate Page Builder module? https://take.ms/iGhQZ

Loading...