• Priority: High
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 14.06.19, 17:33
  • Reason: Closed
  • Comment: Glad to help!

Ticket #14748 - Alysum - problem with AMP product page "id_product" not found

Hi there,
I have a problem with your Alysum theme. I configured AMP version, and when I try to access a product page from there, I get the following symphony error:

(1/1) ContextErrorException
Notice: Undefined index: id_category

in product.php line 113
at Pk_AmpProductModuleFrontController→initContent()
in Controller.php line 255
at ControllerCore→run()
in Dispatcher.php line 428
at DispatcherCore→dispatch()
in index.php line 28

Could you please help me?
Thanks

This ticket does not depend on any other tickets.

Marek (marek) 03 Jun 2019, 15:43

Hi, Andrés García Castilla.


Latest version of Faceted Search module has been released several days ago, and has been completely redesigned. Alysum theme is not compatible with this new version for a while. We are recommend to use previous module version https://www.dropbox.com/s/5e8v6el1s1ccutk/ps_facetedsearch.zip?dl=0 We will release an update as soon as possible

Andrés García Castilla (Garcicasti) 03 Jun 2019, 15:54

Hi there Marek,
Thanks for the reply. I just substituted one module with the one you provided (version 2.2.0) and the same exact problem persists.
Any other ideas?
Thanks again

Marek (marek) 04 Jun 2019, 09:17

Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your server through FTP I'll try to help you

Andrés García Castilla (Garcicasti) 04 Jun 2019, 09:24

Sure, I just did! Let me know your progress on it. Thanks!

Marek (marek) 05 Jun 2019, 11:36

I'm not able to connect to your server

Status:      	Resolving address of theamaranta.com
Status:      	Connecting to 45.55.98.207:21...
Error:        	Could not connect to server
Andrés García Castilla (Garcicasti) 10 Jun 2019, 19:16

Hi there again, sorry for the delay.

Please check the issue in the URL http://staging.altamirabrand.com (I couldn't change it in my account panel). This is a staging version I created since the other one is currently being used.
The passwords and users are there. Now they are correct.

Thanks in advance,
Andrés.

Marek (marek) 10 Jun 2019, 22:50

I need the path to the website https://staging.altamirabrand.com I just make an update in the folder /var/www/html/prestashop/themes/alysum/templates but not changes in the front page

Andrés García Castilla (Garcicasti) 11 Jun 2019, 13:01

Hi there Marek,

The path is correct. Probably we need to erase cache in administrator and also in prestashop/var/cache.
I just did that now. Check again please.

Marek (marek) 12 Jun 2019, 12:04

The issue has been fixed. Please check it out

Andrés García Castilla (Garcicasti) 14 Jun 2019, 17:26

I can confirm also that this issue was solved. Thanks again ;)

Loading...