• Priority: Medium
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 01.08.19, 12:45
  • Reason: Closed
  • Comment: Glad to help!

Ticket #14758 - AMP not working

Hi Marek,

I am encountering problems with the AMP version of the page, I can not see it and it seems it is not running at all. To the best of my beliefe the HomePage Configuration is set in the AMP Builder editor properly and Force loading AMP on mobile devices is allowed.

I get only the classic version of the Homepage, never AMP.

Could you please help?

Thanks, Jakub

IMG_0757.jpg (86.9 KiB)

This ticket does not depend on any other tickets.

Marek (marek) 04 Jun 2019, 12:20

Latest version of Faceted Search module has been released several days ago, and has been completely redesigned. Alysum theme is not compatible with this new version for a while. We are recommend to use previous module version https://www.dropbox.com/s/5e8v6el1s1ccutk/ps_facetedsearch.zip?dl=0 We will release an update as soon as possible

Jakub Baca (JakubB) 04 Jun 2019, 20:19

Unfortunately, installing and using this has no effect to AMP.

Jakub

Marek (marek) 04 Jun 2019, 20:31

Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your server through FTP

Jakub Baca (JakubB) 04 Jun 2019, 20:46

Done.

Marek (marek) 04 Jun 2019, 21:05

Unable to login

Command:	USER kvalitnapodlaha.sk
Response: 	331 Password required for kvalitnapodlaha.sk
Command:	PASS **********
Response: 	530 Login incorrect.
Error:        	Critical error: Could not connect to server
Jakub Baca (JakubB) 04 Jun 2019, 21:17

Sorry, it should be working now.

Marek (marek) 05 Jun 2019, 09:10

Please disable OPcache in your server while it’s in development stage

Jakub Baca (JakubB) 05 Jun 2019, 09:18

Hello Marek, done. The change should reflect in about 15 minutes. Jakub

Marek (marek) 05 Jun 2019, 10:31

AMP module has been updated and should works fine, but still not work. Make sure you have disabled all possible cache. Prestashop cache is disabled, I just checked that out

Jakub Baca (JakubB) 05 Jun 2019, 10:44

Thanks Marek, I´ll look at it and try. Jakub

Jakub Baca (JakubB) 05 Jun 2019, 10:49

All possible caches are disabled, but AMP is still not working. :(

Marek (marek) 05 Jun 2019, 12:47

I do not understand whats going on. See the issue first time, so I suppose something wrong with your installation. Do you have possibility to install fresh prestashop to subfolder/subdomain just for a test AMP module?

Jakub Baca (JakubB) 05 Jun 2019, 13:02

We will try and will let you know. This is frustrating. :( Jakub

Marek (marek) 05 Jun 2019, 13:30

I want to emphasise you are the first one who has this problem

Jakub Baca (JakubB) 05 Jun 2019, 13:56

Marek, I am just thinking how it will help if I try to install a fresh theme. AMP was working a week ago for more then a month, so it will also work with a fresh theme. Last week we installed a url module to get clean url addresses, could be possible that this module brought down AMP? Could you look at it and check it from this perspective?

Thanks, Jakub

Marek (marek) 05 Jun 2019, 14:11

Yes, it could be a reason. Try to disable that module

Jakub Baca (JakubB) 12 Jun 2019, 13:13

Hello Marek,

I have the url module and AMP finally working together, but a new issue occured. The links to my categories in my AMP menu go to a 404 page. I got this message from the url module developer:

“You have incorrect URL for categories and products like the AMP module requires ID-Rewrite but you only have ID no rewrite. Please contact the developer.”

Can we fix this somehow please?

Thanks, Jakub

Marek (marek) 12 Jun 2019, 14:00

Hi, Jakub.
Could you please let me know the solution with URL module? maybe it will help to find a solution

Jakub Baca (JakubB) 17 Jun 2019, 18:52

Hello Marek,

this is what I got from the module developer:

“The ID and hash was removed by editing getProductLink function in override/classes/Link.php. The AMP module is working fine on our local server with Pretty URLs installed.”

Thanks, Jakub

Marek (marek) 17 Jun 2019, 19:29

Great!

Jakub Baca (JakubB) 17 Jun 2019, 20:10

Marek, not sure what your “Great!” means. :) AMP works (not sure what they meant by it exactly), but the menu links in AMP I am writing about in my previous comments still do not work. Jakub

Marek (marek) 17 Jun 2019, 20:11

I read that “The AMP module is working fine on our local server with Pretty URLs installed” and replied “Great!”. Ok I’ll check out menu as well

Jakub Baca (JakubB) 17 Jun 2019, 20:12

Oh, ok. :) No problem, please check the menu links then, hope that will be all regarding AMP. Thank you, Jakub

Jakub Baca (JakubB) 17 Jun 2019, 20:15

Actually, the same thing is with the products on my homepage, once I click on a product, I get a 404.

Jakub Baca (JakubB) 18 Jun 2019, 10:22

Hello Marek,

any news please? I need the shop to be running by the end of the week.

Thanks, Jakub

Marek (marek) 18 Jun 2019, 11:31

That is definitely not a theme’s issue the issue is in your prestashop configuration. I suppose the problems comes from Pretty URL, I have disabled it but nothing changed. Try to uninstall it. Then disable “Priateľská URL” and enable it back

Jakub Baca (JakubB) 18 Jun 2019, 11:43

Ok, I tried to contact the module developer once more. Not sure if you or him was working on something at the moment, but all of my pages now have a 404 including non AMP.

Marek (marek) 18 Jun 2019, 11:51

Try to uninstall the module first to make sure all is fine, but as I can see something wrong with all your links. Try to disable “Priateľská URL” and enable it back

Loading...