• Priority: High
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 01.08.19, 12:43
  • Reason: Closed
  • Comment: Glad to help!

Ticket #14762 - AMP Stripe

Hi there,

The Stripe payment form doesn’t work in the AMP version of Alysum theme. Please see attachment. Any idea how to fix this? Thanks

Stripe.png (53.9 KiB)

This ticket does not depend on any other tickets.

Marek (marek) 04 Jun 2019, 20:32

Hi, Andrés García Castilla.
I’m not able to connect to your server through FTP, please update credentials in your profile

Andrés García Castilla (Garcicasti) 10 Jun 2019, 19:20

Hi there Marek,
Credentials are now corected, BUT please use the URL staging.altamirabrand.com

You can see that in the checkout process there is the problem.

Thanks,
Andrés.

Andrés García Castilla (Garcicasti) 10 Jun 2019, 19:21

Also, to be able to reach the checkout process, the problem appearing on product page opening must be fixed too. There is another ticket that I created for that matter. You can bypass that by disabling the debug mode for the moment.

Marek (marek) 10 Jun 2019, 22:47

I need the path to the website https://staging.altamirabrand.com

I just make an update in the folder /var/www/html/prestashop/themes/alysum/templates but not changes in the front page

Andrés García Castilla (Garcicasti) 11 Jun 2019, 13:02

Hi,
Like I commented in the other ticket, check again since maybe we needed to erase /var/cache in order for you to be able to see changes. It was a new staging version of the site.

Marek (marek) 12 Jun 2019, 12:02

Please check it out now. It should be ok

Andrés García Castilla (Garcicasti) 12 Jun 2019, 23:03

Hi there,
The form to pay with card looks good, but the Google Pay option doesn’t work. And I believe its because of the theme, for the tests I’ve made. Can you confirm this? Could this be fixed too? Thanks

Marek (marek) 13 Jun 2019, 11:32

I just added stripejs module for AMP checkout, please check out how it works now

Andrés García Castilla (Garcicasti) 14 Jun 2019, 17:25

Still doesn’t really work. If you have an Android device over there you can go to checkout with that and you’ll see that it says that your device does not meet the requirements...but I believe that’s not true. I payed with Google Pay on other places.... Can you recheck it please? Thank you

Marek (marek) 15 Jun 2019, 12:05

What I have to see there? For now, I see the following - https://take.ms/RP3i6 on both iOS and Android devices. Maybe you have some example?

Andrés García Castilla (Garcicasti) 15 Jun 2019, 18:46

Should be something like the attached image in iOS devices. In Android is pretty similar. It should be the OS prompting to pay with your saved card directly. But right now it just says that it is not a compatible device, while it’s not true.

The module I’m trying to use is this one: https://addons.prestashop.com/es/pago-tarjeta-carteras-digitales/17856-stripe-payment-pro.html

Marek (marek) 16 Jun 2019, 12:00

I suppose something wrong with module configuration. I have disabled AMP, load desktop version on mobile and see the same message like in AMP https://take.ms/WyIfc

Andrés García Castilla (Garcicasti) 16 Jun 2019, 21:54

Okey I’m gonna check with module dev

Thanks

Marek (marek) 17 Jun 2019, 11:05

Ok, let me know

Loading...