• Priority: Critical
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 14.06.19, 17:23
  • Reason: Closed
  • Comment: Glad to help!

Ticket #14803 - Error on checkout AMP

Hi there,

Some of my users are experimenting 500 server error during the checkout time. Just after clicking continue after imputting their delivery address. I can’t figure out why it happens only sometimes, but the PHP error that generates is the one attached.

Please I need help with this asap.

The login details are in my profile BUT please use new URL staging.altamirabrand.com

Thanks,
Andrés.

This ticket does not depend on any other tickets.

Andrés García Castilla (Garcicasti) 10 Jun 2019, 19:26

Sorry, here is my attachment

capture.jpeg (38.4 KiB)
Marek (marek) 10 Jun 2019, 21:24

How to reproduce the issue? it works fine for me https://take.ms/S21Nh

Andrés García Castilla (Garcicasti) 11 Jun 2019, 13:12

In the following link you can see how I make the error appear.

https://www.dropbox.com/s/9rcexecnf8z78ig/VID-20190610-WA0014.mp4?dl=0

Also in the attached file there is a capture of the error.

Marek (marek) 11 Jun 2019, 14:43

Ok, I see. I’ll try to figure our what’s wrong

Marek (marek) 11 Jun 2019, 15:54

I just make a fix, but don’t see any changes. Do you have some cache enabled?

Andrés García Castilla (Garcicasti) 11 Jun 2019, 17:53

Hi,

No, I have cache disabled. Remember it’s in staging.altamirabrand.com !! You can change that in my profile for future reference too.

I have a child theme setup though. Could that be the issue?

Marek (marek) 12 Jun 2019, 10:14

The issue should be fixed now, but there is some problem with back office. I just cleaned cache and that issue happened.

Andrés García Castilla (Garcicasti) 12 Jun 2019, 22:55

I’m checking if the issue has been indeed resolved.

But in the meantime, could you tell me what was the problem, or what changes did you make? because i need to put this in the production webpage

Andrés García Castilla (Garcicasti) 12 Jun 2019, 22:55

Was it something about me, or was it a but on the theme that will be corrected on a future update?

Marek (marek) 12 Jun 2019, 22:57

It’s hard to explain what was the issue, but of course, the fix will be available in the next update

Andrés García Castilla (Garcicasti) 12 Jun 2019, 23:05

Sure but, if the update is not really really soon, what would I need to do to put it in my other web, which is a clone? Can I just, copy the theme folder onto it?

Marek (marek) 13 Jun 2019, 10:06

Yes, right. Just copy the theme and modules

Andrés García Castilla (Garcicasti) 13 Jun 2019, 15:03

Ok, I did it and it is fine for the errors now. Just one thing. You kind of deactivated the child theme I believe, no? What did you change to do that in the files? I would need to see my changes in css back

Marek (marek) 14 Jun 2019, 11:44

I don’t remember all the changes. Just keep whole “mobile” folder /themes/alysum/templates/mobile

Andrés García Castilla (Garcicasti) 14 Jun 2019, 17:22

yeah, now I solved it. Now it works fine. Thank you very much.

Marek (marek) 14 Jun 2019, 17:23

You are welcome

Loading...