• Priority: Medium
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 01.08.19, 12:47
  • Reason: Closed
  • Comment: Glad to help!

Ticket #14837 - Out of stock label on mobile amp

Hi, some products on my store have the label “out of stock” on amp view.
The products are available and from desktop the label is not visible.
Can you please help me?
Here you can see the error in some products:
https://writesketchand.com/fr/mobile/category/43-summer-sales The label is the same in all languages.

Screenshot_20190613-223250.jpg (357 KiB)

This ticket does not depend on any other tickets.

Marek (marek) 14 Jun 2019, 11:06

Now it should be ok

Sergio Nuzzo (Sergionwp) 14 Jun 2019, 14:05

Hi Marek.
Now the label OUT OF STOCK is not visible from mobile, but it’s the same in products that are really out of stock! ;) I want the label visible only on products out of stock.
For example, if you search from mobile RIGHELLO SPOT (0 available in the warehouse) you see the label NEW but not OUT OF STOCK and you’ve to enter in the product page to undestand that is OUT OF STOCK. From desktop it’s correct: I see two labers: NEW and OUT OF STOCK.

Marek (marek) 16 Jun 2019, 14:43

Seems I miss something in your product settings. I just make a fix for these products https://writesketchand.com/it/mobile/category/13-righelli https://take.ms/EvcKE but now the issue with SUPER SPLASH NOTEBOOK is back https://writesketchand.com/fr/mobile/category/43-summer-sales so. Prestashop always return that product is not available for order, maybe you have some option enables for that product?

Sergio Nuzzo (Sergionwp) 16 Jun 2019, 14:54

I’ve checked and I think the problem is that these products had combinations in the past... so I think your AMP layout verify the “out of stock” status from a different table respect the desktop layout.
In fact, from desktop the layout it’s correct: only products with “0” in the warehouse have the label OUT OF STOCK.
Can you please verify in your AMP layout in wich way you check if the product have to show “OUT OF STOCK” label or not?
Thank you.

Marek (marek) 18 Jun 2019, 19:07

Loading...