Support will be provided with delays until 20 August. We are sorry for the inconvenience.
We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Priority: High
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 01.08.19, 13:03
  • Reason: Closed
  • Comment: Glad to help!

Ticket #14983 - Contact Page

Dear Marek,

I would like to ask You how can I change “contact page” layout. Can I add some items, modules to that page? How can I change text as shown on attached picture?

Best Regards,
Grzegorz

screen.png (129.5 KiB)

This ticket does not depend on any other tickets.

Marek (marek) 03 Jul 2019, 10:27

You can read how to edit contact details here http://alysum5.promokit.eu/promokit/documentation/#faq3

You can also edit this file /themes/alysum/modules/contactform/views/templates/widget/contactform.tpl

Grzegorz Janiszewski (Grzegorz1970) 03 Jul 2019, 10:38

Thank You very much.
One more question. Is it possible to create contact page using Page Builder. I’m trying to do that but when I configure button in Menu Editor I can’t see a layout which I’ve created.

Marek (marek) 03 Jul 2019, 11:24

Unfortunately, there is no such option

Grzegorz Janiszewski (Grzegorz1970) 03 Jul 2019, 13:43

And one more thing. Contact form in page footer not sending any mails. Please look at my webpage: ozonosept.pl

Marek (marek) 03 Jul 2019, 20:07

What is the path to the theme in your server?

Grzegorz Janiszewski (Grzegorz1970) 04 Jul 2019, 08:31

on my ftp server this path is /domains/ozonosept.pl/public_html/themes/alysum

Marek (marek) 04 Jul 2019, 10:12

Now I’m not able to connect to your server

Grzegorz Janiszewski (Grzegorz1970) 04 Jul 2019, 10:56

Did you try with new login and pass?

Marek (marek) 04 Jul 2019, 13:02

I just added a fix, but seems a cache is enabled in your back office, and I don’t have access to clear it

Grzegorz Janiszewski (Grzegorz1970) 04 Jul 2019, 15:33

I’ve disabled cache in back office but problem still exist.
I’ve corrected all required information in my profile: login, password and link (https://ozonosept.pl/ipye7svurhupjelq )

Marek (marek) 05 Jul 2019, 10:51

I’m not able to login with new password and login

Jest jeden błąd.
Pracownik nie istnieje lub hasło jest nieprawidłowe.
Marek (marek) 05 Jul 2019, 12:11

is that correct path to your prestashop? /domains/ozonosept.pl/public_html/

Grzegorz Janiszewski (Grzegorz1970) 05 Jul 2019, 12:25

yes

Marek (marek) 05 Jul 2019, 12:56

The module works fine in our demo server. I have copied it to your server and it don’t want to work. I suppose your server blocks requests to the file /domains/ozonosept.pl/public_html/modules/pk_contact/controllers/front/ajax.php
Please take a look at your error logs maybe you will find some errors releated to that file

Grzegorz Janiszewski (Grzegorz1970) 05 Jul 2019, 14:44

I do not know if you can read in polish but my hosting service sent me reply:

konsola w przeglądarce zgłasza błąd:
TypeError: data.errors is undefined

zapytania ajax nie są blokowane, ale w przypadku tych zapytań do formularza strona zwraca 302 i możliwe że to powoduje błąd:
87.239.222.109 - - [05/Jul/2019:12:50:09 +0200] “POST /module/pk_contact/ajax HTTP/2” 302 - “https://ozonosept.pl/index.php” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_5) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.1.1 Safari/605.1.15” “ozonosept.pl”

Przy “zwykłych” działaniach w zapleczu podobne zapytanie ma status 200:
213.17.240.178 - - [05/Jul/2019:11:59:02 +0200] “POST /ipye7svurhupjelq/ajax.php?rand=1562320741125 HTTP/2” 200 345 “https://ozonosept.pl/ipye7svurhupjelq/index.php?controller=AdminDashboard&token=4bfdae00e18e73a598cb7c57916a80eb” “Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0” “ozonosept.pl”

Raczej jest to kwestia ustawionych przekierowań np w .htaccess, lub są np osobne ustawienia dla zapytań ajax w zapleczu.

Which means that Console in browser found undefined.error. Requests from ajax are not blocked but in case of this form requests send back 302 and this can bi the cause of problem. In other request in the shop it has status 200. They said that it is not correct link forward in .htacces or there are different requests for ajax in backoffice....

Marek (marek) 07 Jul 2019, 10:11

I have enabled “Przyjazny adres URL” and all works fine now

Grzegorz Janiszewski (Grzegorz1970) 08 Jul 2019, 14:04

SUPER!!! Thank You very much.
Las question. Where can I find this mail text to translate?

screen.jpg (151.7 KiB)
Marek (marek) 08 Jul 2019, 20:13

It should be in the folder /themes/alysum/mails/ but I don’t know which file is that

Loading...