Support will be provided with delays until 15 December. We are sorry for the inconvenience.
We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Priority: Medium
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 30.08.19, 12:17
  • Reason: No answer from a customer
  • Comment: Glad to help!

Ticket #15275 - Header builder problem

Hi,

when I try to use the “Header builder” option (Venedor settings / Header / Header Builder) I get an exception when using the front office.

Exception details from the console:

bottom-e05e449.js:formatted:33903 Uncaught TypeError: Failed to execute ‘observe’ on ‘MutationObserver’: parameter 1 is not of type ‘Node’.

  at HTMLDocument.<anonymous> (bottom-e05e449.js:formatted:33903)
  at u (bottom-e05e449.js:formatted:1364)
  at Object.fireWith [as resolveWith] (bottom-e05e449.js:formatted:1415)
  at Function.ready (bottom-e05e449.js:formatted:1508)
  at HTMLDocument.H (bottom-e05e449.js:formatted:1350)

Attached is the formated code, the exception is thrown on line 33903 (observer.observe(target, config);)

Values of target and config evaluated from the console:
image.png

Please help :)

Regards, Žiga

This ticket does not depend on any other tickets.

Ziga Polajnar (PolenarTactical) 04 Aug 2019, 15:31

Forgot the code part :)

bottom-e05e449.txt (1.48 MiB)
Marek (marek) 05 Aug 2019, 10:56

Hi, Ziga.
Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your server through FTP and BO

Ziga Polajnar (PolenarTactical) 07 Aug 2019, 08:37

Done. I found an old ticket where you said that the HeaderPageBuilder hook was not setup OK, so I fixed that problem.

Open issues with the theme:

  • I’m still getting the console error which was described in my original post.
  • Whenever I create a new post / update testimonials / etc. it does not update widgets on my homepage. I have to manually remove the widget via page builder and than add it again to update it’s contents.
  • If I’m logged in with a BO user I can’t add products into the cart.
Marek (marek) 07 Aug 2019, 11:01

1. console log error fixed
2. Try to clear prestashop cache. We will check out how to optimize that
3. How to reproduce that? all works fine for me

Loading...