• Priority: High
  • Status: Closed
  • Closed by: Marek (marek)
  • Closed on: 30.08.19, 12:36
  • Reason: Closed
  • Comment: Glad to help!

Ticket #15321 - Missing translation in pk_compare

Hello Marek,
When we add or remove products in the compare list some phrases and words do not translate.
For example:
“The product has been successfully added to compare list” “The product has been successfully removed from”

We found the phrases in the pk_compare.php file, but there is no corresponding call in the language file /modules/pk_compare/translations/it.php

Also in the comparison page this words do not translate:
“PRODUCT”, “AVAILABILITY”, “PRICE”.

And in the same way I can not found where I can translate the link in My Account menu: “MY COMPARE LIST”

thanks for your help

This ticket does not depend on any other tickets.

Marek (marek) 13 Aug 2019, 12:02

you have to make translation through back office. All wordings are available there https://take.ms/zmusV

Sergio Nuzzo (Sergionwp) 14 Aug 2019, 12:14

When I go to back office International→Translation and set Module Translation, Compare Products, Italian the system give me back "500 Internal Server Error".
what is this error due to? how can i solve?
We have another prestashop in the same server and with the same configurations and the error there isn't there so I guess it's not a server problem.

Thanks again for your help

Marek (marek) 14 Aug 2019, 12:16

That's definitely not a theme's problem. You can try to select any native module to translate to make sure the issue is appearing as well

Sergio Nuzzo (Sergionwp) 17 Aug 2019, 10:39

I thought it was a problem of the theme because it was also created in another prestashop when I saved the translations of the module pk_compare from backend as you said.
It may be related to accented characters, but after it goes into error 500 I can't go back.

Anyway I can not found where I can translate the link in My Account menu: “MY COMPARE LIST” because is not in the pk_compare module translation

Marek (marek) 17 Aug 2019, 11:17

That is pk_customlinks (Custom Links) module where you have to make a translation for "MY COMPARE LIST"

Loading...