• Priority: High
  • Status: Waiting on customer

Ticket #15358 - "stores" link not working on mobile

I get the error attached when trying to reach the “stores” link and in spanish I get a “this page doesnt exist”. Also, I cannot find the “stores” module in the backoffice anymore...
Can you help please?
Thank you,
Virginia

This ticket does not depend on any other tickets.

Marek (marek) 17 Aug 2019, 11:45

Do you have enabled some cache service or a module? if so, please disable it

Virginia (Psophia) 17 Aug 2019, 17:40

No :( all of them are set to "no" (images attached)

Marek (marek) 17 Aug 2019, 21:01

what is the path to the theme?

Virginia (Psophia) 17 Aug 2019, 21:59

do you mean this path?
https://psophia.com/es/module/pk_amp/stores Now I do not get that error, but the content is gone (attached screenshot)both in the desktop and the mobile version... (it was there on the desktop version before)

Virginia (Psophia) 17 Aug 2019, 22:05

the module with the store locator is called "localizador tienda"
Where did the stores content on the backoffice go?

Marek (marek) 17 Aug 2019, 22:48

I need the path to the theme's folder in your server

Virginia (Psophia) 18 Aug 2019, 11:59

It is /httpdocs/themes/alysum

Virginia (Psophia) 18 Aug 2019, 22:16

other strange things are happening.... as what you can see in the image attached and that I cannot update stocks....

Marek (marek) 20 Aug 2019, 07:47

Second issue has been fixed. I keep working on first one

Marek (marek) 20 Aug 2019, 20:39

The issue has been fixed. Please test to confirm the change

Virginia (Psophia) 21 Aug 2019, 15:56

Now content appears, but the icon on the map is not the one I setted on the theme but prestashop default.
Also, on mobile, I can see the pictures missing and the opening hours missing, which should not appear when left in blank...
Screenshoots attached

Marek (marek) 22 Aug 2019, 12:41

There is no option to display map in the AMP mobile version.

There is no opening hours in the desktop as well https://take.ms/FjIyQ you can define that in the store option in your back office

Virginia (Psophia) 22 Aug 2019, 12:45

Ok, no Map for the AMP version. BUT, I dont have store pictures nor opening hours. It is not filled and it does not show in the desktop vs which is ok, but it SHOWS in the AMP vs without any content, and I dont want it to appear, just like it does in desktop version....
How do I do it?

Marek (marek) 22 Aug 2019, 19:35

The issue has been fixed. Please test to confirm the change

Virginia (Psophia) 22 Aug 2019, 21:20

I still see the "image not available" message :(

Marek (marek) 23 Aug 2019, 18:46

Try now

Virginia (Psophia) 23 Aug 2019, 19:39

Now it works on mobile perfectly, but it is empty on desktop :(

Marek (marek) 23 Aug 2019, 19:40

it's because you have to add an image there

Virginia (Psophia) 23 Aug 2019, 19:43

No, the content was there on desktop before, with the map and the adress. Now the page is empty
this is how it looked like until now (see image attached)

Virginia (Psophia) 23 Aug 2019, 19:44

image

Marek (marek) 23 Aug 2019, 20:13

I didn't touch anything there.
I also want to say that was a strange issue from the beginning because it appears in your case only, and I make special customization for you to display information correctly

Virginia (Psophia) 24 Aug 2019, 11:35

Then why has this content dissapeared? :( We have not touch anything either.... how do we make it appear?

Marek (marek) 30 Aug 2019, 18:36

I see you have modified theme templates. Try to upload original theme

Virginia (Psophia) 02 Sep 2019, 23:05

I have not modified the theme.... dont even know how to do it! If I upload it again, wont we loose information or content?

Marek (marek) 03 Sep 2019, 16:31

Here are modified files https://take.ms/zZVDY, not by me (except stores-customer what I have renamed)

Try to upload all original theme files

Virginia (Psophia) 08 Sep 2019, 22:34

I have not modified the theme.... dont even know how to do it! If I upload it again, wont we loose information or content?

Marek (marek) 09 Sep 2019, 11:58

I spent a lot of time on the issue what doesn't related to our theme, because you are the first who has it. Do you use some module what manage stores? I see a file what overrides default Prestashop controllers https://take.ms/sloCm and that is definitely causing the problem.

Loading...