Support will be provided with delays until 15 December. We are sorry for the inconvenience.
We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Priority: Medium
  • Status: Closed
  • Closed by: Fred (fred)
  • Closed on: 01.12.19, 19:37
  • Reason: Closed
  • Comment: Glad to help!

Ticket #15485 - Brand in Product Miniature

I don’t know why in the category page (ex. https://telestampiamonoi.it/3-stampe) the brand name in the product miniatures no longer appears.
On home page, product page, and carousels appears, but not in category pages.
But in category page, on left column i have a carousel with special products. And there appears. (img01)

img01.jpg (139.3 KiB)

This ticket does not depend on any other tickets.

Marek (marek) 04 Sep 2019, 11:45

all data is generated in the PrestaShop core (category controller). I have no idea why the manufacturer name is not available. In the sidebar all data is generated in the module what we can manage

Walter Fontana (cmgroup-web) 04 Sep 2019, 12:08

So, there is no solution? In your demo, brand appears. I try to found a solution in prestashop forum, but they tell me to contact theme developer.
you don't know how can i do?

Walter Fontana (cmgroup-web) 04 Sep 2019, 12:10

once i paid Alex (I don't remember the exact name) for some custom changes. It is possible to get help from him?

Alex Support (Admin) 04 Sep 2019, 15:50

Hi. Yes I can help you :) . I will write you back tomorrow

Walter Fontana (cmgroup-web) 04 Sep 2019, 16:09

Thanks Alex. If you find a solution, before could you tell me how much it costs?
Thanks a lot

Walter Fontana (cmgroup-web) 06 Sep 2019, 09:23

Hi Alex,
do you have any news?
however yesterday I was modifying a product, and saving appeared, only on that product, the Brand on the category page.
Saving another time disappeared. I don't understand which is the bug.

Alex Support (Admin) 06 Sep 2019, 14:12

Hi. Now I'm trying to find the solution. It will cost about 10 euro ;)

however yesterday I was modifying a product, and saving appeared, only on that product, the Brand on the category page. Saving another time disappeared

Where you did the modification and what the modification?

Walter Fontana (cmgroup-web) 06 Sep 2019, 15:06

I add a code in "Riferimento". I don't know the name in english of "Riferimento". See the screenshot.
Today the product also are loaded very slowly. I don't know why!

once all the brands disappeared and then reappeared only by updating a product. i really think that is a bug.

img01.jpg (134.3 KiB)
Alex Support (Admin) 06 Sep 2019, 16:27

"Reference" it's not related to the Manufacturers. It's just product number, for example product identical id number from manufacturer or your catalog.

Done the modification. I don't know why Prestashop removed manufacturer from there... Very interesting.

Added to the file themes/alysum/templates/catalog/_partials/miniatures/product.tpl
also created there backup file (if you update the theme for example) product–bkp.tpl

the code

  
{* modif_alex           *}
          {assign var="pka_manufacturer" value=Manufacturer::getNameById($product.id_manufacturer)}
          {if $pka_manufacturer}
            <h6 class="product-brand ellipsis">{$pka_manufacturer}</h6>
          {/if}
{* /modif_alex           *}

Total cost for this modification 15 euro. Sorry but spend some time to find the solution.
Do you need some other modification? Or only that?

Walter Fontana (cmgroup-web) 06 Sep 2019, 16:58

Hi Alex,
thanks but now i have in search page and in carousel (left column in category page) two Manufacturer name.

The problem was only in the list of category pages

Alex Support (Admin) 06 Sep 2019, 17:32

Oh. Sorry for that. Fixed :)

Also I see you have wrong files/folders permission it should be 644/755
It's important for security. You can change it for whole site folder in your hosting panel file manager or just write to hoster, mostly they do that for free ;)

Walter Fontana (cmgroup-web) 09 Sep 2019, 09:34

Hi Alex,
it is possible to do that also with Filezilla?
Files should be 644 and Folders 755?

Walter Fontana (cmgroup-web) 11 Sep 2019, 09:48

Alex?

Alex Support (Admin) 11 Sep 2019, 14:10

Hi.
Yes. But it will take about 1 hour. With the hosting administration panel about 1 minute ;)

Here is tutorial how to do that if you want to do that yourself https://www.inmotionhosting.com/support/website/managing-files/change-permissions

Or you can give me access (to my email in my profile) to cPanel and I will do that

Walter Fontana (cmgroup-web) 13 Sep 2019, 09:42

But one file at a time?
Sorry for my question but I changed the file permissions only with filezilla
If you do that how much cost?

Alex Support (Admin) 13 Sep 2019, 09:50

Filezilla it's ok :) But not all folders was changed
https://c2n.me/43zfmXJ
https://c2n.me/43zfqfh
https://c2n.me/43zftdr

I suppose filezilla don't have feature change attributes for subfiles and subfolders?
You need something like that option https://c2n.me/43zfELN

Walter Fontana (cmgroup-web) 16 Sep 2019, 09:24

Ok Alex, now everything seems to be ok.
how can I pay you 15 euros?

Walter Fontana (cmgroup-web) 18 Sep 2019, 13:11

Hi Alex,
I have to know if you could help me with another problem.
I Category Pages i have a filter in left sidebar.
In mobile i have to move the filter in a accordion because the sidebar disappear (img01)
To do that i add an hook with a second filter visible only in mobile width (max-width: 991px)
The problem is that the second filter does not work well. The prices bar desappear and the arrow to open/close di filter does not work.
if disabled the filter in sidebar instead works well.

Do you have a solution to make the two filters work on the same page?
Could you tell me how much it costs?

img01.jpg (259.3 KiB)
Alex Support (Admin) 19 Sep 2019, 08:34

Hi. I suppose the better way is disable accordion filter and adjust left sidebar for mobile devices.
As I see left sidebar just disabled for mobiles in the CustomCSS https://c2n.me/43EYhtz
It's not difficult modification. So it will cost about 5-15 euro
On mobile do you need these blocks? https://c2n.me/43EYswA

Walter Fontana (cmgroup-web) 19 Sep 2019, 09:26

Yes, i disabled the left sidebar with css.
The problem is that in mobile the filter must be closed (better in a accordion) because is too big and under the sub-categories. as it is now!
I think that move the sidebar there with css is not possible.
Do you have another solution?
For exemple, is not possible disable (not only hide) the filter on sidebar in mobile? Because without that the accordion filter works.

"On mobile do you need these blocks?" No only the filter!

Alex Support (Admin) 20 Sep 2019, 00:20

There is feature in PS "Disable module in mobile" but it also disables Filters accordion. I will try to check what we can do with that and I will write you back ;)

Walter Fontana (cmgroup-web) 20 Sep 2019, 09:26

There is feature in PS "Disable module in mobile" but it also disables Filters accordion Yes, i know!
Thank you for your support, Alex!

Walter Fontana (cmgroup-web) 23 Sep 2019, 09:26

Hi Alex,
some news?

Alex Support (Admin) 23 Sep 2019, 09:57

Hi. Sorry I'm very busy these days. I will try to look at the issue in next few days and write you back

Walter Fontana (cmgroup-web) 23 Sep 2019, 10:27

Ok, thank you

Walter Fontana (cmgroup-web) 26 Sep 2019, 10:41

Hi alex, when you have some time, i have also a problem with e-mail translation. I opened a ticket but we don't find a solution.
Ticket #15654
let me know if you want your 15 euros immediately, or I pay all your work together

Alex Support (Admin) 28 Sep 2019, 23:09

Now it seems ok the filter. Please check
You can send money after all modifications ;)

Ok. I will take a look at the email issue and write you back ;)

Walter Fontana (cmgroup-web) 30 Sep 2019, 11:16

Hi Alex,
the filter seems to have some problems
1) dont'show the price bar (unless you check an option like "Quadrato" or "Rettangolare")- img01
2) I can not select two options together. it shows only the last option - img02
3) Is possible to add the button clear all? - img03

Can you tell me how much is this work for filter?

img01.jpg (255.9 KiB)
img02.jpg (224 KiB)
img03.jpg (127.8 KiB)
Alex Support (Admin) 01 Oct 2019, 23:48

Hi.
1), 2) Try it with the "portable devices" mode https://c2n.me/43RZSZs
I've added the condition in the code. If device is mobile/tablet don't load all modules in the left sidebar.
This condition won't work if you just reduce the browser window on the desktop.

3)
Just add to the CustomCSS the code for @media (max-width: 991px)

#js-active-search-filters.active_filters, 
#content-wrapper-left #_desktop_search_filters_clear_all {
  display: block !important
}

;)

#js-active-search-filters.active_filters, 

it's if you need to show active filters https://c2n.me/43S0k6q
if you don't need it you can remove this line

Walter Fontana (cmgroup-web) 02 Oct 2019, 12:32

Thank you so much Alex, Now all work fine!
I have only two questions
1)In "mobile mode" i try to select ipad pro, and in this case, does not load the left-bar. Do you now if is possible remove that problem, or in all mobile device can't load the left-bar?
2) When I select an option in the filter the page scrolls up (at the top of the page). Is possible remove this scroll?

Sorry, but before do that could you tell me how much it costs? Because all this works are for my Boss, so he decides whether to do it or not!

Alex Support (Admin) 03 Oct 2019, 00:00

1) added the condition.
Widget Filter will be shown and Left sidebar will be hidden only for portable devices (no matter what the screen resolution is)
Is it ok such behavior?

1) costs 10 euro
2) about 15, maybe more I need to investigate the default PS behavior and change it :)

For now the payment is:

15		Add Manufacturer name to the product, Category page
20		Faceted Search on portable devices hide from left column
10		hide left column for portable devices, show widget filter(faceted search) only for portable devices

Is it ok?

Walter Fontana (cmgroup-web) 04 Oct 2019, 14:05

Yes, 45e is ok!
2) I asked my boss and he told me that if the problem can be solved with 15-20 euros it's ok!
So can you do that and then we pay all works together?

Alex Support (Admin) 06 Oct 2019, 21:56

Hi. Fixed the filter click behavior.
The price exactly as I expected 15 euro :)

Alex Support (Admin) 06 Oct 2019, 22:03

Can you pay with SEPA bank transaction please? It's the best way for me.
If it's ok for you just give me please your email and I will send my iban

Alex Support (Admin) 07 Oct 2019, 13:21

I've send the details

Walter Fontana (cmgroup-web) 07 Oct 2019, 13:34

Ok,
1- can you answer me on the other ticket for the newsletter problem?
2- can you send me an invoice for these works?

Alex Support (Admin) 09 Oct 2019, 22:32

Hi.
1) Yes, I've replied you in that ticket 2 days ago ;) 2) ok. I will send you to email it now

Walter Fontana (cmgroup-web) 10 Oct 2019, 10:50

Hi alex, i received your e-mail with the prices and invoice. my boss is out for work, comes back next week so he pays by bank transfer
Only a question:
1- To translate newsletter subject: I have to go to modules/pspagebuilder/classes/widget/newsletter.php and replace Newsletter voucher and Newsletter confirmation with my custom text?

Alex Support (Admin) 17 Oct 2019, 21:11

Hi. Sorry for waiting. I didn't get notification about your reply...

Just translate directly in that file 'Newsletter confirmation' and 'Newsletter voucher'

Please remind your boss about payment ;)

Alex Support (Admin) 24 Oct 2019, 20:26

Hi. Is everything ok? Please a payment for my previous work ;)

Loading...