Support will be provided with delays until 15 December. We are sorry for the inconvenience.
We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Priority: Critical
  • Status: Closed
  • Closed by: Fred (fred)
  • Closed on: 12.12.19, 11:21
  • Reason: Closed
  • Comment: Glad to help!

Ticket #16348 - Amp Category Page does not show the products

I have the following problems;

- Amp Category Page does not show the products (No products appear on the category page)
- Amp category page filter gives the following error:

{”productsOnPage”:0,”productsPerPage”:12,”pageNumber”:2,”nextPageUrl”:null,”hasMorePages”:0,”static_token”:”5ff562b6a2e2409bc55f24016961afd2”,”items”:[]}

This ticket does not depend on any other tickets.

Fred (fred) 01 Dec 2019, 19:31

Hi, Aytaç Göller.
Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your back office

Aytaç Göller (aytacgoller) 01 Dec 2019, 22:07

I updated the informations.

Fred (fred) 02 Dec 2019, 11:03

I see. First of all you must have enabled HTTPS protocol, read more here http://alysum5.promokit.eu/promokit/documentation/amp/troubleshooting.html

Aytaç Göller (aytacgoller) 02 Dec 2019, 16:43

The problem was resolved after enabling SSL. Thank you. But there is another one. There are sorting properties appear "in the filter box" on the category pages.

wrongField.jpg (47.7 KiB)
Fred (fred) 02 Dec 2019, 20:00

Yes, there are sorting appears. Make sure your filter is configured properly, see Faceted Search module

Aytaç Göller (aytacgoller) 02 Dec 2019, 21:25

Yes i checked that but i could not see anything wrong. Can you please help me about the following issues:

- AMP kategory page filter does not work proper.
- Page builder modul can not load the design page, it stucks. I added a ss.
- Also i want to design my poduct page and category page like yours but i could not be able to find any detailed document, can you please help me on that(added ss)?

Thank you for your support

Fred (fred) 03 Dec 2019, 12:37

1. what exactly wrong with filter, it seems works correctly for me
2. Fixed
3. There is no any detailed documents because all is pretty easy. You have two options, use Default prestashop layout, or use Product Page builder. You can manage that in the Theme Settings → Product page. Nothing more

Aytaç Göller (aytacgoller) 03 Dec 2019, 15:24

Hi,
1- I can not see the same filters on AMP as the desktop version.
2- Thank you
3- It is maybe easy but it looks like there is something wrong. Theme doesn't respond correctly or i do it wrong :/ What I actually need is the original page designs. But the designs are not imported correctly. Can you please change these pages (category and product page) design to original Alysum design. All i want is original pages like below:

*** Also If you go to that page (https://www.no7istanbul.site/tr/bluz-tunik/97-276-cizgili-pullover.html#/renk-kirmizi/beden-standart) you will see there is a forgotten(or mistaken) piece of code, i added ss.

Thank you.

code piece.jpg (50.3 KiB)
Fred (fred) 04 Dec 2019, 10:17

1. I see all the same https://take.ms/SkEVB

3. Original page design is this https://take.ms/zrUJN

4. I'm not able to connect to your server through FTP to fix "forgotten(or mistaken) piece of code"

Aytaç Göller (aytacgoller) 04 Dec 2019, 13:38

Hi,

1- Yes it is fixed in somehow, thank you.
2- If you can give me an e-mail, i can be able to send you the FTP info, if it is possible for you
3- Can you pelase tell me(added ss),

Thank you for your help

screen2.jpg (169.1 KiB)
screen.jpg (72.7 KiB)
Fred (fred) 04 Dec 2019, 17:06

You can give me access through your profile https://support.promokit.eu/index.php?do=myprofile
- to hide discount label use following CSS:

.product-flags .product-flags {display:none}

- to manage filter, go to Faceted Search module

Aytaç Göller (aytacgoller) 04 Dec 2019, 21:06

1- I gave you all ftp information through my profile
2- I do not know how(where) to use that custom css code
3- I checked "Faceted Search Module" before but i could not see how to assign filter to these two pages("https://www.no7istanbul.site/en/new-products" and "https://www.no7istanbul.site/en/prices-drop") and also i could not find changing the title of these pages.

Can you please show me how(where) to do these with SS?

Aytaç Göller (aytacgoller) 04 Dec 2019, 21:22

I solve that (2- I do not know how(where) to use that custom css code) Thank you.

Fred (fred) 04 Dec 2019, 22:17

Go to Theme Settings → Customer CSS

Aytaç Göller (aytacgoller) 04 Dec 2019, 22:20

What I actually need is the original page designs. But the designs are not imported correctly. Can you please change these pages (category and product page) design to original Alysum design. All i want is original pages like below:

Product page: https://alysum5.promokit.eu/en/casual-dresses/3-printed-dress-2835934862836.html

Fred (fred) 04 Dec 2019, 23:58

To use original page designs you have to select "default" page in the Theme Settings → Product page.
Default pages are not imported, it's coded in the theme

Aytaç Göller (aytacgoller) 05 Dec 2019, 08:26

- I use default page but it does not look like the product page of your demo. Can you please check the ss that i added. The main problem is "product comments" and "star rate". Product commen section is not on the correct place and rate stars is not there.
- I already checked "Faceted Search Module" but i could not see how to assign filter to these two pages("https://www.no7istanbul.site/en/new-products" and "https://www.no7istanbul.site/en/prices-drop") and also i could not find changing the title of these pages. Can you please show me how(where) to do these with SS?

Fred (fred) 05 Dec 2019, 09:22

1. Sorry, but I do not see where the problem is. You have the same product page layout as in our demo.
2. Faceted Search module is working on Category page only

Aytaç Göller (aytacgoller) 05 Dec 2019, 09:37

1. Sorry, but I do not see where the problem is. You have the same product page layout as in our demo.

  • "Product Comments" area should be just below the description areas
  • "Grade(with stars)", "Read User Reviews" and "Write Your Review" areas are not there.
Aytaç Göller (aytacgoller) 05 Dec 2019, 09:50

Also "description area" does not appear

Fred (fred) 05 Dec 2019, 10:04

Make sure you are using latest Product Comments module and also make sure it's installed and enabled. That is not product page layout issue, it's a question of configuration

Fred (fred) 05 Dec 2019, 10:04

as for description, you have to add it to the product first

Aytaç Göller (aytacgoller) 05 Dec 2019, 12:19

Also "description area" does not appear

Aytaç Göller (aytacgoller) 05 Dec 2019, 12:34

I checked the module is updated and set correctly. Can you please check these;

  1. Product Comments" area should be just below the description areas
  2. Grade(with stars)", "Read User Reviews" and "Write Your Review" areas are not there.
Fred (fred) 05 Dec 2019, 13:39

There is no stars because no ratings yet https://take.ms/MGruC

Aytaç Göller (aytacgoller) 05 Dec 2019, 13:52

Thank you and ;
1. "Product Comments" area should be just below the description areas?

Fred (fred) 05 Dec 2019, 13:53

we have moved I down in the latest theme version

Aytaç Göller (aytacgoller) 05 Dec 2019, 13:58

Can we please take that comment to the area which is shown on the ss?

Fred (fred) 06 Dec 2019, 13:37

I'm not able to connect to your server through FTP

Aytaç Göller (aytacgoller) 07 Dec 2019, 09:10

I added all the correct info for FTP, can you please check again?

Fred (fred) 07 Dec 2019, 13:50

Still not able to connect.
You can do that yourself.
Open the file /themes/alysum/templates/catalog/product.tpl
find the line

{block name='product_additional_info'}
{include file='catalog/_partials/product-additional-info.tpl'}
{/block}

and move it to any place you want

Aytaç Göller (aytacgoller) 12 Dec 2019, 10:29

Thank you for your assistance and help. Have a nice work.

Fred (fred) 12 Dec 2019, 10:29

you are welcome

Loading...