Ticket #16632 - AMP product combination price problem

Hi, when i go to product page the price looks ok (include tax e.g. 269,99₺) on AMP product pages. But when i click any of the combinations the prices change in to without tax price (reduced tax price). It only happens on AMP not on desktop version. How can i fix that.

Thank you and have a nice day.

Comments

Fred (fred) 13 Jan 2020, 20:54

Which product I have to test? Could you please give me a link?

Aytaç Göller (aytacgoller) 14 Jan 2020, 19:04

any product which has a combination. Problem appears only on the AMP page

Here is a sample:
https://www.no7istanbul.com/tr/giyim/267-838-havuc-kesim-mont#/35-beden-s/44-renk-haki

Fred (fred) 15 Jan 2020, 10:26

But the price is the same with any color or size https://take.ms/G9Nab

Aytaç Göller (aytacgoller) 15 Jan 2020, 15:57

Yes, but when you load the page for the first time it comes with the correct price (which is 329,99₺ for that product) Why it changes to the tax reduced prices when we select any of the combination?

BTW it only happens on amp product page, not on desktop version!

Fred (fred) 16 Jan 2020, 06:23

Sorry, but I still do not see the problem. the price is always the same for me https://take.ms/XFyIN

Aytaç Göller (aytacgoller) 16 Jan 2020, 09:53

It comes with tax included price on first load which is 329,99₺ but when you click on any combination color it changes to tax reduced prices. That is all clear, please go to that product page and check the price before you click any color combination. This only happens on AMP product page. Also i enabled debug mode and sent you the ss with the others.

Thank you

Fred (fred) 16 Jan 2020, 15:09

I see it finally.
I have enabled Debug mode to see the error messages and make a fix, please check it out

Aytaç Göller (aytacgoller) 16 Jan 2020, 18:45

Sorry, i could not understand your point? Yes now the debug mode is on but the issue is still there?

Fred (fred) 16 Jan 2020, 18:50

Sorry, but I don't see the issue, AMP works the same as desktop https://take.ms/nh2H2. I have fixed the error what appears if Debug Mode is enabled

Aytaç Göller (aytacgoller) 16 Jan 2020, 19:43

Sorry but it is not like that on desktop, i checked at least 4 different pc. On desktop it comes with 329,99₺ price when i click on any color,it changes in to 305,55₺, but it happens only on AMP!

Here is the link for Desktop: https://www.no7istanbul.com/tr/giyim/267-841-havuc-kesim-mont#/37-beden-m/44-renk-haki Here is the link for AMP: https://www.no7istanbul.com/tr/mobile/product/267-havuc-kesim-mont#/37-beden-m/44-renk-haki

Please click both of them and you will see the prices are the same (329,99₺) and please click any color then the price will be 305,55₺

Fred (fred) 17 Jan 2020, 10:33

I see the same price by default (without click on color) https://take.ms/CAtz8 and after click on color I still see the same price https://take.ms/Fh7K0

Aytaç Göller (aytacgoller) 18 Jan 2020, 23:55

There is really something wrong that i can understand. When i go to that link: "https://www.no7istanbul.com/tr/giyim/267-841-havuc-kesim-mont#/37-beden-m/44-renk-haki" the price is 329,99₺ by default for both version of the page. Then it changes to 305,55₺ when i click any color. And i can not understand why you see that different.

Can you please add screenshots with url part of the screen then i can compare.

Thank you

Fred (fred) 19 Jan 2020, 20:00

I have recorded a video where I compare desktop and AMP websites at the same time https://take.ms/6jMG5

Aytaç Göller (aytacgoller) 20 Jan 2020, 10:26

Can you please share the url of the page that you visit, i can not see it on the video

Fred (fred) 20 Jan 2020, 10:28
Fred (fred) 20 Jan 2020, 10:54

And what I see there https://take.ms/y7Zq3

I suppose something wrong with your Back office configuration

Aytaç Göller (aytacgoller) 21 Jan 2020, 11:37

Ok, so lets check the logic;

1. You see these pages because you connect from other country (i think) because when i try to connect to site on proxy i saw the same result
2. On my situation, i connect site from Turkey, i see the price correct on desktop (with 8% tax included price) but on AMP product page prices changes into tax reduced when i click any color

that it is not a prestashop settings problem, because while it is working on desktop there is no problem but when i go to AMP page prices changes when i click on any color. That is so simple, please try to see that. This is about amp side. Your theme and prestashop works well on desktop when it comes to amp it act in different way.

If it is possible you can also connect to my computer to see that.

Thank you

Fred (fred) 21 Jan 2020, 12:27

Ok, let's try to connect to your computer, it will be much faster I suppose.
I will also need a tool to connect to your server through FTP to edit files

Aytaç Göller (aytacgoller) 21 Jan 2020, 12:29

I have teamviewer and anydesk? Also can you please send me direct email for sharing pass codes

Fred (fred) 21 Jan 2020, 12:30

I also have Teamviewer
[email protected]

Fred (fred) 21 Jan 2020, 13:00

you have updated your profile, but give me access to your channel https://cpls-mig05.srvpanel.com:2083/ through browser.
I need to connect through Filezilla, like you do that on your computer

Fred (fred) 21 Jan 2020, 13:10

I have updated the file /modules/pk_amp/controllers/front/ajaxProduct.php please check out the problem now

Aytaç Göller (aytacgoller) 21 Jan 2020, 16:58

I checked that, it seems it works about combination prices but now i can not see the images?

Fred (fred) 21 Jan 2020, 23:57

I'm going to completely update your AMP module. But I need direct access to your server through FTP

Aytaç Göller (aytacgoller) 22 Jan 2020, 10:24

Sorry, i could not understand what you mean by saying "direct access through FTP". I miss something :(
I already wrote what i have and you can directly reach everything with that info. Also i sent you other url and by email maybe that works.

Thank you

Fred (fred) 22 Jan 2020, 11:04

You are using FileZilla, right? I need details to connect to your server with FileZilla too

Aytaç Göller (aytacgoller) 22 Jan 2020, 11:08

Ok I think the information that i sent you by email should work

*Also i updated the info on your site

Fred (fred) 22 Jan 2020, 18:53

I have updated AMP, please test it out

Aytaç Göller (aytacgoller) 22 Jan 2020, 20:41

Now it is like before, price changes on color combinations

Fred (fred) 23 Jan 2020, 12:54

I do not understand what is going on there.
Can I try to connect to your computer once again?

Aytaç Göller (aytacgoller) 26 Jan 2020, 13:00

Sorry for being late, sure. Tomorrow we can do that

Wish you a good weekend

Aytaç Göller (aytacgoller) 28 Jan 2020, 11:01

Hi, is it possible to connect my computer to solve that problem?

Fred (fred) 28 Jan 2020, 11:09

May I connect right now?
Give me a password please

Aytaç Göller (aytacgoller) 28 Jan 2020, 11:09

i29d4x

Fred (fred) 28 Jan 2020, 11:24

Strange, now, after fix the error appears for me.
The main problem here is that I see it different from you.
Do you have an idea how to let me see the price exactly like you? maybe you have some regional settings in your back office?

Aytaç Göller (aytacgoller) 28 Jan 2020, 11:38

Sadly, I have no idea. Do you want to connect my computer again?

Fred (fred) 28 Jan 2020, 11:54

Teamviewer doesn't let me to connect, says "it's commercial use".
I'll check out your back office, maybe will find some specific settings.
Could you please also test from another computer?
Maybe you know some Turkish VPN to let me connect from Turkey?

Aytaç Göller (aytacgoller) 28 Jan 2020, 12:11

I do not know any Turkish VPN, we usually use other country's VPN server (not common here, sorry). But if it is conviniant we can also use "anydesk software" for connection.

Aytaç Göller (aytacgoller) 29 Jan 2020, 10:22

Hi, could you find any solution?

Fred (fred) 29 Jan 2020, 12:11

I'm trying to configure Turkish VPN now.
I have another question. Have you tested the price issue under your account? Have you tried to test it as a guest? or as a normal customer account?

Fred (fred) 29 Jan 2020, 12:24

I just configured Turkish VPN and make one more test and again all works correctly – https://take.ms/z8fKl

Aytaç Göller (aytacgoller) 30 Jan 2020, 11:01

Sorry, it is still same here :(

Fred (fred) 30 Jan 2020, 11:18

maybe the problem is on your device? please ask someone else to check that.
Honestly, I have no idea what to do further, because I just do no see any error there. All works correctly for me

Aytaç Göller (aytacgoller) 01 Feb 2020, 16:36

Hi, i have checked that on other devices but it is still same. I do not know why it is like that. If there is nothing else to do then i will accept that issue. Thank you for your support during that time.

Fred (fred) 03 Feb 2020, 11:56

No problem with the time.
Yes, please ask someone else to check that, and let me know