Ticket #16693 - Problem with product display

In some categories the products come out completely unframed. Could you tell me how to solve that?
I leave the web link:
https://www.uniformesycalzados.com/70-servicio

Attachments:

Comments

Fred (fred) 27 Jan 2020, 15:03

Hi, Infoser Sistemas sa.
Please give me a link to that page, and please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your back office

Infoser Sistemas sa (infoser101) 27 Jan 2020, 23:54

We have already loaded the backoffice and ftp keys

regards

Fred (fred) 28 Jan 2020, 10:33

Did you customised theme templates? Try to use original files

Infoser Sistemas sa (infoser101) 28 Jan 2020, 15:38

Just customize the possibilities of the same template, such as colors, fonts and header, but I have not changed any files, it seems strange that only in this category I have this fault and I do not understand why that happens.

Infoser Sistemas sa (infoser101) 28 Jan 2020, 17:25

Hello, I have inspected the colunna, and the content is within a parameter called "font", you can enter the template and find the solution, it is urgent and the customer needs to start selling their products. Thank you.

Attachments:

Fred (fred) 28 Jan 2020, 18:47

There is no any < font> tag in our theme. There are two possible cases – you added it, or some of your module added it.

Infoser Sistemas sa (infoser101) 28 Jan 2020, 23:46

We have not modified any theme or prestashop files
They are the standard files of the installation

On the other hand, this effect does not occur if we activate the standard Prestashop theme. It only happens with the Alysum theme.

We attach chrome inspector windows for two products on the same page and at the same time:

1) The first product is rendered correctly, and the structure of the generated HTML is:

<div class = product-miniature ..>
   <article class = product-miniature ..>
      <div class = "thumbnail-container relative">
        <div class = "thumbnail product-thumbnail relative flex-container">
          <a href=...>

2) The second product is rendered with error, and its html is:

<font face = "Times New Roman">
  <font size = "3">
    <article class = product-miniature ..>
        <div class = "thumbnail-container relative">
           <div class = "thumbnail product-thumbnail relative flex-container">
               <a href=...>

As you can see, the html structure of the correct product is inserted into two Font tags

This html code is necessarily generated by the template, and for some reason it is wrong, but we are unable to find the cause.

Please, we need help, because in this way you cannot deliver the web to the client.

regards
Victor

Attachments:

Product_1_Ok.png (150.1 KiB)
Fred (fred) 29 Jan 2020, 10:33

The text of your product description is dirty https://take.ms/B4xgs. I recommend to use HTML cleaner to get clean code https://html-cleaner.com

I also can disable tags in the theme's code, but I need to know a path to prestashop, because I can't find it in your server