Ticket #16703 - Module in pagebuilder not working

Hi, i’ve a problem with “Alysum” template.
In page builder the template recognize only PrestaShop’s modules but not third party ones, how can i resolve it?
Thanks

Comments

Fred (fred) 29 Jan 2020, 10:21

Hi, Andrea.
That is not a problem of Page builder.
To be able to add a module as a widget, that module has to support prestashop "widgets" feature

Andrea Tarquini (atanet) 29 Jan 2020, 10:46

The module's name is "Ask for a quote", i asked for assistance to devs providing them with access to the backoffice and this was their answer:

We managed to load the module, and added a test widget but we could not save as it frooze and timed out again. This builder must be very resource hungry.
However what we saw, is that the page builder recognizes default Prestashop and own modules only, nothing third party, which is bad. We never saw this behaviour with any builder before.

Fred (fred) 29 Jan 2020, 11:31

Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your server through FTP and Back office

Andrea Tarquini (atanet) 29 Jan 2020, 13:54

Hi,
parameters entered.
I'm waiting.

Fred (fred) 29 Jan 2020, 14:02

I see the following error https://take.ms/J8z8S could you please check it out?

Andrea Tarquini (atanet) 29 Jan 2020, 17:37

try again now. It works for me

Fred (fred) 30 Jan 2020, 11:14

Ok. I don't see that module in the modules list of widget.
What I can do for you more?

Andrea Tarquini (atanet) 30 Jan 2020, 14:24

I would like this form to appear in the list of widgets.
I wrote to the "ask for a quote" module developer and he said that the problem is about the template.
I would like insert the module at the point indicated by the attached image.
How you can see from the dev's site this module is on the right of the menu, which does not happen in your template.
https://addons.prestashop.com/it/preventivi/3725-ask-for-a-quote.html

Attachments:

img1.png (34.3 KiB)
Fred (fred) 31 Jan 2020, 12:16

I understand your idea.
- To be able to add a module through Page Builder, your module MUST support prestashop widgets.
- If you don't see your module in the list of modules in the "Load Prestashop Module" widget (like this https://take.ms/YKaZX) it means your module doesn't support Prestashop widgets

Fred (fred) 31 Jan 2020, 12:17

and doesn't matter which theme do you use!