• Priority: High
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 27.05.20, 16:48
  • Opened by: Sophia Kulakova
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #18131 - Categories page does not work in amp

My product categories page doesn’t work on mobile devices, error 500 writes. Although when I turn off the AMP, everything is in order. I always used amp, what could happen?

Comments

Sophia Kulakova 27 May 2020, 17:25

I found now that the page stops working when I turn on filtering on the category page. What to do ?

Sophia Kulakova 27 May 2020, 17:28

If you update the module and enable, then the category pages in the mobile work. But then filtering on the detoscope does not work. What is the problem? Need some new module? This ps_facetedsearch stopped working with your theme?

Fred 27 May 2020, 20:57

Don't need a new module. AMP works only with ps_facetedsearch module. I can't reproduce the issue, could you please give me direct link?

Sophia Kulakova 28 May 2020, 10:22

Now I updated this module and categories work in amp, but filtering of goods does not work either in amp or in the detoscope. If I put an old version of the module, filtering works on the detoscope, but categories do not work in amp. I can’t turn on the old version and wait until you see what the categories in amp would not work for me. I do not know how to do it better to show you this problem. But at the moment, filtering doesn’t work for me and it worries me

Fred 28 May 2020, 16:48

We make much tests and all works fine with the latest module version. Please make sure you have configured the module correctly

Sophia Kulakova 28 May 2020, 18:58

Now I updated this module and categories work in amp, but filtering of goods does not work either in amp or in the detoscope. If I put an old version of the module, filtering works on the detoscope, but categories do not work in amp. I can’t turn on the old version and wait until you see what the categories in amp would not work for me. I do not know how to do it better to show you this problem. But at the moment, filtering doesn’t work for me and it worries me

Sophia Kulakova 28 May 2020, 18:59

everything is set up as usual for me. But the filter does not work in the computer, look at the category https://amberheart.ru/en/13-sergi-s-yantarem

Attachments:

Fred 28 May 2020, 19:24

The issue has been fixed. Please test to confirm the change https://take.ms/tYMcJ

Sophia Kulakova 29 May 2020, 09:59

Yes, the filter works, thanks, and why it doesn’t show filtering by price, it is turned on and by weight

Attachments:

фиьр.png (63.9 KiB)
Fred 29 May 2020, 10:45

Hi, Sophia,
Please disable all cache what you have in your prestashop, I'll try to check that out

Sophia Kulakova 29 May 2020, 11:05

I read it, the price did not appear on all pages, only in 2 categories: earrings and rings, and there is no slider for switching

Attachments:

цена.png (7.3 KiB)
Sophia Kulakova 29 May 2020, 12:08

Also, the vishlist buttons do not work for me and compare on the category page, although the module is enabled. And it turns out to add to favorites if you go to the product page

Sophia Kulakova 29 May 2020, 13:23

This problem again. What's the matter? I do not understand. I do not make any changes. I just add the goods. And I again have this trouble with images on the category page when you switch the page. Why am I always breaking something, what am I doing wrong?

Attachments:

Fred 29 May 2020, 23:24

But images worked fine before, what exactly did you do?

Sophia Kulakova 30 May 2020, 14:40

Yes, now everything works, apparently I had some kind of failure with the Internet or what, I don’t know. You have not looked at what the problem is with the slider; it appears on some pages, on some pages it does not.

Fred 01 Jun 2020, 10:29

it seems depends on the content (product listing) on current page, that's definitely not the theme's issue

Sophia Kulakova 01 Jun 2020, 10:34

I don’t understand, how does it depend on the content?
And the fact that the filter does not work in amp is also a module problem? When I choose, for example, the size of the ring or the type of fastener, the filter does not work

Fred 02 Jun 2020, 13:04

1. If you will have only one product the filter will not appear, because it has no sense (nothing to filter). If you have two products, the filter will show only options what available in these two products.
2. AMP filter works for me https://take.ms/hur2A

Sophia Kulakova 02 Jun 2020, 15:08

I understand what you mean. It didn’t work when I, for example, in the category of earrings or beads chose the type of fastener, and not another for the category, but now everything really works in amp.

But the detective does not always show the price halfway only when I go, for example, in a subcategory or on some pages of a category.Sent screenshots above

Fred 03 Jun 2020, 17:24

Yes, I see the issue with price slider, but if it works in some pages but not in others that means only the problem with configuration, but I can't say you where to check, because I don't know exactly. I also have to search that, but our support doesn't cover configuration questions

Sophia Kulakova 04 Jun 2020, 14:06

Okay, how can I solve this problem? Who can I contact?

Fred 07 Jun 2020, 17:42

Honestly, I have no idea.
I would recommend to to create a copy of your store and switch it to Classic theme to test out the issue and figure our where is the issue.