• Priority: High
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 20.07.20, 22:13
  • Opened by: Laura
  • Closed by: Fred
  • Closed on: 21.08.20, 12:00
  • Reason: Closed
  • Comment: Glad to help!

Ticket #18670 - Updateing theme and... ERROR 500!!!

Hi Fred,
Updating the theme has given me 500 error in both the frontoffice and backoffice and I have had to restore a backup.

The hosting provider has indicated that the error occurred because a file was missing:

/modules/ph_simpleblog/models/SimpleBlogPostAuthor.php

Could you please check it so I can update the theme to the latest version?

Kind regards.

Comments

Fred 21 Jul 2020, 11:31

Hi, Laura.
Please try to make an update once more and let me know in case some issues, I'll try to help you as soon as possible.
Don't forget to disable all possible cache in your store and server

Laura 21 Jul 2020, 11:41

Hi Marek,
I just updated again and it gives 500 error again.

Can you review it as soon as possible please?

Laura 21 Jul 2020, 11:43

Apache error show this:

AH01071: Got error 'PHP message: PHP Warning: require_once(/var/www/vhosts/mrbolita.com/httpdocs/modules/ph_simpleblog/models/SimpleBlogPostAuthor.php): failed to open stream: No such file or directory in /var/www/vhosts/mrbolita.com/httpdocs/modules/ph_simpleblog/ph_simpleblog.php on line 19\nPHP message: PHP Fatal error: require_once(): Failed opening required '/var/www/vhosts/mrbolita.com/httpdocs/modules/ph_simpleblog/models/SimpleBlogPostAuthor.php' (include_path='/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/pear_exception:/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/console_getopt:/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/pear-core-minimal/src:/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/archive_tar:.:/usr/share/pear:/usr/share/php') in /var/www/vhosts/mrbolita.com/httpdocs/modules/ph_simpleblog/ph_simpleblog.php on line 19\n'

Fred 21 Jul 2020, 13:08

please try now

Laura 21 Jul 2020, 13:19

Hi Fred,
The store is available again but it has lost the original design, the fonts, the header, the Lookbook module is not displayed, the cookie message is not what I have configured, etc.

Fred 21 Jul 2020, 13:24

Yes, that is hard update because we have write from scratch most important module Theme Settings. Unfortunately some things has to be configured once more

Laura 21 Jul 2020, 13:32

How long will it take to reconfigure it?

However, I do not think it is just a configuration work but an error correction: the top bar is not visible, the icons in the header are caked, the amp version returns an error, the menu is moved, etc.

It does not seem prudent to me to post an update that causes errors, updates should be released once they are debugged and with the guarantee that they will not leave the store down.

Fred 21 Jul 2020, 14:07

Unfortunately, there is no another way, only configure once more all as you need. Of restore previous version

Laura 21 Jul 2020, 17:33

I have provisionally restored a backup because amp navigation was still not working.

Is it possible to apply the file where the old configuration is saved and change the name or location for the update to apply it ?.

Performing all the configuration again is a job that takes a long time, has it really happened to everyone and they have not complained? The new update should save previous settings, store sales are at stake. I really can't believe you are posting an update that loses the previous configuration of the entire design

Marianne van der Sluis 23 Jul 2020, 13:47

We had problems too, and put back a back-up. then decided not to update until there is a solution, but I don't know if there comes one?
Greeting Marianne

Laura 12 Aug 2020, 20:30

Hi Fred,
I have finally decided to update the theme to its latest version and it gave me error 500 again.

I have restored the blog module as it happened last time but after a few minutes both the store and the backoffice were returning error 500.

Could you review it please?

These are the error texts of the log:

Error: GET /Backoffice/index.php/improve/modules/manage?_token=0pv4hfiFK9Tq-2iw6Fvqnxt9Rpo5frBjDsj16-He-y4 HTTP/1.0

—x—

Warning: AH01071: Got error 'PHP message: PHP Warning: include_once(/var/www/vhosts/mrbolita.com/httpdocs/modules/pksizeguide/models/SizeGuide.php): failed to open stream: No such file or directory in /var/www/vhosts/mrbolita.com/httpdocs/modules/pksizeguide/pksizeguide.php on line 16\nPHP message: PHP Warning: include_once(): Failed opening '/var/www/vhosts/mrbolita.com/httpdocs/modules/pksizeguide/models/SizeGuide.php' for inclusion (include_path='/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/pear_exception:/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/console_getopt:/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/pear-core-minimal/src:/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/archive_tar:.:/usr/share/pear:/usr/share/php') in /var/www/vhosts/mrbolita.com/httpdocs/modules/pksizeguide/pksizeguide.php on line 16\nPHP message: PHP Warning: include_once(/var/www/vhosts/mrbolita.com/httpdocs/modules/pksizeguide/classes/PksgConfigForm.php): failed to open stream: No such file or directory in /var/www/vhosts/mrbolita.com/httpdocs/modules/pksizeguide/pksizeguide.php on line 17\nPHP message: PHP Warning: include_once(): Failed opening '/var/www/vhosts/mrbolita.com/httpdocs/modules/pksizeguide/classes/PksgConfigForm.php' for inclusion (include_path='/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/pear_exception:/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/console_getopt:/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/pear-core-minimal/src:/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/archive_tar:.:/usr/share/pear:/usr/share/php') in /var/www/vhosts/mrbolita.com/httpdocs/modules/pksizeguide/pksizeguide.php on line 17\nPHP message: PHP Warning: include_once(/var/www/vhosts/mrbolita.com/httpdocs/modules/pksizeguide/classes/PksgConfigDb.php): failed to open stream: No such file or directory in /var/www/vhosts/mrbolita.com/httpdocs/modules/pksizeguide/pksizeguide.php on line 18\nPHP message: PHP Warning: include_once(): Failed opening '/var/www/vhosts/mrbolita.com/httpdocs/modules/pksizeguide/classes/PksgConfigDb.php' for inclusion (include_path='/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/pear_exception:/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/console_getopt:/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/pear-core-minimal/src:/var/www/vhosts/mrbolita.com/httpdocs/vendor/pear/archive_tar:.:/usr/share/pear:/usr/share/php') in /var/www/vhosts/mrbolita.com/httpdocs/modules/pksizeguide/pksizeguide.php on line 18\n', referer: https://mrbolita.com/Backoffice/index.php/configure/advanced/performance/?_token=0pv4hfiFK9Tq-2iw6Fvqnxt9Rpo5frBjDsj16-He-y4

—x—

Error: AH01071: Got error 'PHP message: PHP Fatal error: Uncaught –> Smarty Compiler: Syntax error in template "file:/var/www/vhosts/mrbolita.com/httpdocs/themes/alysum/templates/_partials/logo.tpl" on line 2 "{if isse($page.page_name) && $page.page_name != 'product' && $page.page_name != 'category'}<h1 class="m-0">{/if}" unknown function 'isse' ←- \n thrown in /var/www/vhosts/mrbolita.com/httpdocs/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 2\n', referer: https://mrbolita.com/carrito?action=show

Fred 13 Aug 2020, 10:38

Where I can see that?

Laura 13 Aug 2020, 21:07

Hi Fred,
I fixed those errors, they were:

- The ph_simpleblog module had an error because it was missing a file: I restored it from the backup copy

- The pksizeguide module had a folder left over because it was duplicated, I renamed it

- The file logo.tpl had a wrong function, it put isse instead of isset

But now what I notice is that the other time I updated I saw a new screen to configure the theme but this time I don't see it, I still see the same screen as before, would that be correct?

Because I make changes on the screen called "Alysum settings" but I don't see them reflected in the front office.

I attach some screenshots.

In addition, the header has gone black and has been completely deconfigured and I cannot find the option to return it as it was.

I have already cleared the cache and temporary files.

Attachments:

36.png (156.9 KiB)
37.png (29.6 KiB)
38.png (76.6 KiB)
Fred 14 Aug 2020, 12:16

- But now what I notice is that the other time I updated I saw a new screen to configure the theme - Please make sure you have installed new Theme Settings 2020 module. You can find it in Modules Catalog
- I recommend you to design header with Header Bulder tool and use new module "Header Items" developed specially for header

Laura 14 Aug 2020, 13:20

Hi Fred,
I have installed the module, I am going to proceed to configure it. Edited: error 500 again...

Browsing through AMP keeps giving error 500 and when I try to update the module "Promokit AMP" it returns an error "Could not perform action update for module undefined".

Attachments:

39.png (74.6 KiB)
40.png (5.2 KiB)
Laura 14 Aug 2020, 13:38

Fatal error:

AH01071: Got error 'PHP message: PHP Fatal error: Uncaught Error: Call to a member function getModuleState() on boolean in /var/www/vhosts/mrbolita.com/httpdocs/modules/pk_manufacturers/pk_manufacturers.php:142\nStack trace:\n#0 /var/www/vhosts/mrbolita.com/httpdocs/classes/Hook.php(970): Pk_Manufacturers→hookdisplayHome(Array)\n#1 /var/www/vhosts/mrbolita.com/httpdocs/classes/Hook.php(355): HookCore::coreCallHook(Object(Pk_Manufacturers), 'hookdisplayHome', Array)\n#2 /var/www/vhosts/mrbolita.com/httpdocs/classes/Hook.php(907): HookCore::callHookOn(Object(Pk_Manufacturers), 'displayHome', Array)\n#3 /var/www/vhosts/mrbolita.com/httpdocs/controllers/front/IndexController.php(39): HookCore::exec('displayHome')\n#4 /var/www/vhosts/mrbolita.com/httpdocs/classes/controller/Controller.php(292): IndexControllerCore→initContent()\n#5 /var/www/vhosts/mrbolita.com/httpdocs/classes/Dispatcher.php(515): ControllerCore→run()\n#6 /var/www/vhosts/mrbolita.com/httpdocs/index.php(28): DispatcherCore→dispatch()\n#7 {main}\n thrown in /var/www/vh...\n'

Fred 14 Aug 2020, 17:17

Just rename/remove "pk_manufacturers" folder in the modules folder

Laura 14 Aug 2020, 19:37

It was fixed until I started activating and deactivating modules and the store got a 404 error.

Server log says: "GET /index.php?controller=404 HTTP/1.0"

Please help!.

Fred 14 Aug 2020, 20:02

Where I can see that? Home page works for me https://mrbolita.com

Laura 14 Aug 2020, 20:47

I am configuring the module and intermittently the 404 error comes and goes.

At the moment it has returned and it takes about 20 minutes ... what can I do, what is it due to?

Fred 14 Aug 2020, 21:33

But which module. Could you please give me more details?

Laura 14 Aug 2020, 21:51

The module "Theme settings 2020".

I am setting it up and the store has already got 404 error 4 times.

The first 3 times the error has disappeared after a while, but the error persists and the store keeps showing it. Have you accessed the store to see it?

I have put the text of the log above.

Fred 15 Aug 2020, 11:28

I can't reproduce the issue in Theme Settings. I have tried to change some options and save but it always work.
How to reproduce the issue?

Laura 15 Aug 2020, 12:19

The module "Theme settings 2020".

I am setting it up and the store has already got 404 error 4 times.

The first 3 times the error has disappeared after a while, but the error persists and the store keeps showing it. Have you accessed the store to see it?

I have put the text of the log above.

Laura 15 Aug 2020, 13:52

Hi Fred,
Something new?. The store continues since yesterday with a 404 error.

Fred 16 Aug 2020, 11:04

I can't reproduce the issue in Theme Settings. I have tried to change some options and save but it always work.
How to reproduce the issue?

Laura 16 Aug 2020, 12:10

The store is now in error 404. If you manage to remove it I can check option by option of the Theme Settings which is the one that causes it.

But if I do the opposite, it doesn't solve it: I have reinitialized the configuration and the error persists.

The full error the server shows is: GET /index.php?controller=404 HTTP / 1.0

Fred, I have been with the store without working for 4 days and the only change I have made is the update of the theme. Please help me reset it so I can reconfigure all the options and restore the sale.

Fred 17 Aug 2020, 12:08

I just tested out Theme Settings module once more and it still works fine for me.
Please record a video to let me see what's wrong there. For now I don't see

Laura 17 Aug 2020, 19:12

The store is now in error 404. If you manage to remove it I can check option by option of the Theme Settings which is the one that causes it.

But if I do the opposite, it doesn't solve it: I have reinitialized the configuration and the error persists.

The full error the server shows is: GET /index.php?controller=404 HTTP / 1.0

Fred, I have been with the store without working for 4 days and the only change I have made is the update of the theme. Please help me reset it so I can reconfigure all the options and restore the sale.

Fred 17 Aug 2020, 19:26

I just tested out Theme Settings module once more and it still works fine for me.
Please record a video to let me see what's wrong there. For now I don't see