• Priority: High
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 02.09.20, 11:10
  • Opened by: Daniela Grauso
  • Closed by: Fred
  • Closed on: 17.09.20, 14:58
  • Reason: Closed
  • Comment: Glad to help!

Ticket #18996 - problem with modules

Hello, I have several problems with the theme, I have the feeling that it does not save some settings, active example of the modules, then if I reconnect in the backend I find them deactivated.

then the instagram module doesn’t work, both in amp and in desktop, i tried to uninstall and install to no avail.

in the amp version, in case of products with combination, on the category page, the add to cart button should not be displayed, otherwise it generates a hero but the customer must be invited to the product details page, how is it possible to solve this?

in the case of products on sale, is it possible to display the flag of the discount percentage without decimals?

regards

Comments

Samuele D'Arenzo 04 Sep 2020, 17:39

Per quanto riguarda il fatto che i moduli non si salvino può dipendere dalle impostazioni php del server su cui stai tenendo il tuo sito, è possibile che il massimo di richieste sia inferiore a 1000 e non gestisce quindi correttamente tutte le richieste.
Per quanto riguarda instagram anche io ho lo stesso problema e l'ho già segnalato.
Per quanto riguarda invece ho già segnalato che l'errore del tasto aggiungi al carrello si risolve commentando due righe in un file specifico che adesso non ricordo, però non è una vera soluzione poichè se quelle righe esistono (e riguardano proprio le combinazioni), mi è stato già detto che al prossimo aggiornamento verrà risolto.
Infine, per la flag degli sconti devi modificarla dalle impostazioni del negozio, c'è un'impostazione che ti dice una cosa simile a "mostra gli sconti come valori di differenza anzichè percentuali", ti basta disattivare questa voce e confermare.

Daniela Grauso 04 Sep 2020, 20:01

Ciao Samuele , grazie per la tua risposta, per quanto riguarda le impostazioni php, avevo anche il problema della visualizzazione delle traduzioni, quindi dopo aver impostato le richieste a 3000 ho risolto e forse con questa modifica ha risolto anche il problema del salvataggio :)

Instagram continua a non funzionare, forse dovuto anche ai continui cambiamenti di ig stesso.

Per il tasto aggiungi al carrello nella versione amp non ho ancora una soluzione, se lo disattivo tramite css poi mi scompare anche dalla pagina prodotto, se riesci a ricordare il file da commentare faccio delle prove :)

Per gli sconti vorrei comunque visualizzarli come valore percentuale non valore assoluto, solo che non mi piace che vengono visualizzati anche i valori decimali, esempio se ho uno sconto di 61,17% vorrei che nel flag venga visualizzato solo 61%, non so se è possibile ottenere questo risultato :(

Fred 04 Sep 2020, 20:37

Thank you, Samuel, for the reply.
@Daniela, sorry for the delay. We have small vacation right now but we will be fully available since next Monday and provide you a solution as soon as possible

Daniela Grauso 05 Sep 2020, 12:21

ok Fred

Fred 07 Sep 2020, 11:57

I need credentials to access to your front page https://take.ms/QU2Vi

Daniela Grauso 07 Sep 2020, 14:09

Hi fred, there are no passwords for front page, the problem is on new.dangis.shop

Fred 07 Sep 2020, 14:24

Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your server through FTP

Daniela Grauso 07 Sep 2020, 16:00

Hi fred, I had already completed the form with the access dataHi fred, I had already completed the form with the access data...

Fred 07 Sep 2020, 18:52

Ok, and access to back office of https://new.dangis.shop

Daniela Grauso 07 Sep 2020, 19:19

is in multishop so you can use the same credentials

Fred 08 Sep 2020, 17:37

Instagram is updated and works now https://take.ms/CNhsf

Daniela Grauso 08 Sep 2020, 22:50

ok perfect, instagram now works, for the removal of the add to cart button in the category page in case of products with combinations, is there a solution?

thanks fred

Fred 08 Sep 2020, 22:55

by default if a product has combinations add to cart button will be replaced with "view" button

Daniela Grauso 09 Sep 2020, 16:09

Hi Fred, that's right what you say unfortunately in the amp version, I have the "add" button instead of "view"
button

see screenshot

how can it be solved?

Attachments:

Fred 10 Sep 2020, 13:40

now it should be ok https://take.ms/n4ca2

Daniela Grauso 10 Sep 2020, 15:16

Hi Fred, I checked, for products with only one color variant it is ok, but if a product has multiple colors the "add" button appears. the "add" button is always visible on the Home page.

Thank you

Fred 10 Sep 2020, 15:26

please check it out now

Daniela Grauso 10 Sep 2020, 16:08

Hi Fred, I checked, now it's the opposite with only one color the button is visible, for more colors no, on the Home page the "add" button is always visible.

Thank you

Fred 10 Sep 2020, 16:48

there is no such clear condition in AMP we have to develop this feature

Daniela Grauso 11 Sep 2020, 09:35

it is not possible to use the same function as the desk version

Fred 11 Sep 2020, 11:41

as I can see here the Add to Cart button is not available for any product https://www.new.dangis.shop/35-donna maybe maybe we can just disable it in AMP?

Daniela Grauso 11 Sep 2020, 14:20

in the category page, it can also be disabled in amp, because most of the products will have combinations ... obviously it must be visible in the product detail page.

Fred 11 Sep 2020, 18:37

ok, please disable it for a while, and we add this issue to out ToDo to find a solution in further updates

Daniela Grauso 12 Sep 2020, 18:39

ok so it's like before, can't remove the "add cart" button from the categories page for all products?

Fred 13 Sep 2020, 10:28

Try following CSS to hide Add to Cart button in AMP

.product-miniature > form {display:none}
Daniela Grauso 15 Sep 2020, 19:46

hello Fred for now the solution proposed via css is fine, I have another problem the discount flag, in the desktop version it is visible both in the category and product detail page, while in AMP it is visible only in the product details page and is not visible in the category page . i think it's a bug, i can't find the way to make it display.

thank you

Attachments:

Schermata.pdf (425.7 KiB)
Fred 16 Sep 2020, 11:10

Please make sure labels are enabled in the AMP settings

Daniela Grauso 16 Sep 2020, 15:44

hi fred, everything is enabled, product details are visible, while on the category page no.

Attachments:

Fred 17 Sep 2020, 11:21

missed label is added to AMP https://take.ms/s1NZl

Daniela Grauso 17 Sep 2020, 14:57

thank you