• Priority: High
  • Status: Assigned
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 15.09.20, 14:29
  • Opened by: Luca Siesser

Ticket #19145 - some problems

Hi Fred,

at first, I bought a second license for a new website but I don’t find a way for extending the support for the original one when i have either saved on your website

1. on AMP, Stripe module doesn’t appear
2. on AMP, not available products cannot be ordered when in BO this is permitted and on desktop it works
3. on AMP, available product - https://soundimage.it/mobile/product/337 - cannot be ordered, error is the same, no products available with this.....
4. 2. on AMP, not available products variations cannot be ordered when in BO this is permitted and on desktop it works
5. system status, I’ve an error on PHP version - php_version:7.2.33 (Supported PHP since 5.6 to 7.2) I’ve installed last update the might be compatible with 7.3

Best regards,
Luca

Comments

Fred 15 Sep 2020, 19:37

Hi, Luca.
I have installed the latest AMP module version for you. Please test it out now. All should be ok

Luca Siesser 16 Sep 2020, 09:05

Hi Fred,

thank you very much.
I'm checking and I founded some new things:

1. amp, link to cms and blog, did you change the link structure? the original link was ad es: https://soundimage.it/module/pk_amp/blog and now is https://soundimage.it/module/pkamp/blog I changed manually in the menu, is it necessary to do it on all other link in home page? I've a 500 error on every blog post page on mobile

2. amp, product page.. if i add to the cart a product available or not with the default finish it works, if I do the same after clicking on the finishes, it doesn't any more.. so it's impossibile to add any product to the cart after selecting the finish

3. system status, I’ve an error on PHP version - php_version:7.2.33 (Supported PHP since 5.6 to 7.2) I’ve installed last update the might be compatible with 7.3, is it better to change PHP version?

Luca

Fred 16 Sep 2020, 21:07

1. all links should be updated automatically
2. what is "after selecting the finish"?
2. Just ignore that, it's a mistake

Luca Siesser 16 Sep 2020, 21:34

1. No, none link works, only contact and blog links work after I updated them manually.. none post link work on amp, error 500

2. after selecting the color, try to buy any product after choosing the color.. it doesn’t work.. the only way to buy something it to add it to the cart without select the color and so with the default finish

3. Ok

Fred 17 Sep 2020, 10:49

1. I have tested out all links what I have found and all works fine https://mega.nz/file/gF4DUKiD#gnkZZ_BrJC_FZK6Q1QTnM3q1Qo-OABmCY_s1pobVqbg

2. I have compared this product https://take.ms/wNS6vM and it works pretty similar. In the desktop you are not able to select white color (I suppose it's unavailable) and in AMP when you select white the button Add to cart is disabled

Luca Siesser 17 Sep 2020, 11:35

Hi Fred,

as written before, I manually update these links:
original link https://soundimage.it/module/pk_amp/blog to https://soundimage.it/module/pkamp/blog original link https://soundimage.it/module/pk_amp/contact to https://soundimage.it/module/pkamp/contact because these wasn't updated automatically.

As written yesterday, if you now visit the blog: https://soundimage.it/module/pkamp/blog and than you click on any post listed, you have a 500 error

This wasn't happen before the update, so, please, could you let me know what I can do to have the blog post links working again?

Best regards,
Luca

Fred 17 Sep 2020, 12:20

fixed

Luca Siesser 17 Sep 2020, 12:58

thank you, it works

URGENT, I try to complete an order but when you select the payment method, any, you cannot complete the order - none payment method selected
Differently than before, all payment method are expanded before you select them.. if you can solve this, too, would be great...

Luca

Fred 17 Sep 2020, 22:10

Are you talking about AMP version? if so, try to enable Desktop checkout page in the AMP settings.
Any third party module is not compatible with AMP by default.

Luca Siesser 18 Sep 2020, 08:39

Yes, on AMP, but it worked perfectly before the update, now it's impossible to complete an order
Just to understand, Stripe will be no more supported and will be necessary to enable the Desktop version on AMP?

Through Premium support is it possible to have it working again?

Fred 18 Sep 2020, 10:00

you don't need premium support.
Do you have a backup to restore previous AMP version?

Luca Siesser 18 Sep 2020, 10:08

ok, but if I go with the Premium can I have it working with this version? and possibly to have solved, too, the other things?

Fred 18 Sep 2020, 10:13

Premium support is an instant support through chat, nothing more

Luca Siesser 18 Sep 2020, 12:21

do you plan to add again the Stripe support on AMP or not? if not, do you offer a paid service to add it?

Fred 19 Sep 2020, 11:19

Stripe was worked fine before the module update. Now we have to find our what was changed and adjust AMP module for that. It will take a bit tome, I hope to find a solution on the next week

Fred 21 Sep 2020, 14:14

Please check it out now, it seems works https://take.ms/mJHV7S I have enabled AMP for checkout page

Luca Siesser 21 Sep 2020, 19:01

Hi Fred,

yes... the module looks to work.. or better he looks to verify if the digits are correct but I cannot complete the test with test card number because I cannot click on - order with obligation to pay - ordine con obbligo di pagamento - see attached..
The link is always disabled, even if I select money transfer or COD.. stripe module looks to work but the link to complete the payment is always disabled and I've the alert, no payment method is selected..

I recorded a brief video - https://www.dropbox.com/s/ozyi6fii6n5f2ft/Registrazione%20schermo%202020-09-21%20alle%2018.54.41.mov?dl=0

Luca Siesser 29 Sep 2020, 16:43

Hi Fred,

any news?? Could you take a look to the video?

Luca

Fred 29 Sep 2020, 17:05

We currently working on that.
You can enable Desktop checkout page in AMP settings for a while

Fred 29 Sep 2020, 17:30

Please test it out now, it seems works

Luca Siesser 24 Oct 2020, 09:21

Hi Fred,

the payments modules now works but I founded another problem in the products page, when you add a product to the cart, the price for the product added appears without vat.. kindly, take a look to this video - https://www.dropbox.com/s/aea8rdbd1dlpa4z/Registrazione%20schermo%202020-10-24%20alle%2009.14.22.mov?dl=0

Best regards,
Luca