• Priority: High
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 16.02.21, 11:14
  • Opened by: Damien
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #20779 - Faceted search on category page

Hello,
Is it possible to have the faceted search module displayed next to the product only and not on the top left? (see screenshot)
Thank you!

Attachments:

screen_ok.jpg (289.8 KiB)

Comments

Fred 16 Feb 2021, 13:50

try following CSS

#category #left-column {margin-top:200px}
Damien 16 Feb 2021, 15:14

That works but the problem is that the header content of the category page (description) is different from one category to another so the height is not the same on each category.
It would be great if the content of the left column aligned with the filter

Fred 16 Feb 2021, 22:41

Could you please give me a link to a page where I can see the issue?

Damien 17 Feb 2021, 10:51

I think i got it.
I need to change the files category.php and layout-both-columns.php
Thank you

Fred 17 Feb 2021, 11:04

ok, let me know if you will need some help

Damien 11 Mar 2021, 10:56

I have a big problem with product page
https://www.sharing-boutique.com/fr/short-tibetans/1075-tibetan-red-rubis.html The content does not load. Do you have an idea why?

Fred 11 Mar 2021, 10:57

What did you do before? It can't brake itself

Damien 11 Mar 2021, 11:01

That's the problem. I don't remember having modified anything.
My client noticed that and tell me that did not work.
Oh i have changed that file: layout-both-columns.tpl
Could it be the problem?

Damien 11 Mar 2021, 11:18

I have modified this file layout-both-columns.php
by adding this

            {if (isset($pkts.cp_category_preview) && $pkts.cp_category_preview == 1)}
<div class="block-category relative">
    {if file_exists("{$pkts.cat_img_path}{$category.id}.jpg")}
    <img src="{$category.image.large.url}" width="1110" height="500" alt="{$category.name}">
    {/if}
    {if (isset($pkts.cp_category_description) && $pkts.cp_category_description)}
    <div class='category-desc-wrap{if file_exists("{$pkts.cat_img_path}{$category.id}.jpg")} img_exist{else} no_img{/if}'>
    <h1 class="h1">{$category.name}</h1>
    {if $category.description}
        <div id="category-description">{$category.description nofilter}</div>
    {/if}
    </div>
    {/if}
</div>
{/if}

and that seems to be the problem that break the product page

Damien 11 Mar 2021, 11:43

Ok i confirm that the problem came from this file layout-both-columns.tpl and the file category.tpl that i also have modified.
In fact i wanted to center the category description in a two columns layout. So i have modified those files but i am not as good as you and that broke the site :)

Fred 11 Mar 2021, 11:48

But did you solve the problem now?

Damien 11 Mar 2021, 11:56

Nope :(

Fred 11 Mar 2021, 11:57

try to restore original file

Damien 11 Mar 2021, 12:01

Oh i mean yes i solve the product page product. It is correctly displayed now.
But i did not found a solution to center the category descriptionb on a two columns layer

Fred 11 Mar 2021, 12:54

Please show me at a screenshot how do you want to move the description

Damien 11 Mar 2021, 14:14

This is what i try to do (see attached file)

Attachments:

example_sharing (242.9 KiB)
Fred 11 Mar 2021, 19:28

Try following CSS https://take.ms/m955K

#category .block-category {
    position: absolute;width: 100%;top: 0;left: 0;
}
#category #main, #category #content-wrapper-left {
    position:static
}
#category #wrapper {
    padding-top: 200px;position: relative;
}