• Priority: Medium
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 01.03.21, 21:20
  • Opened by: claudio couto
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #20917 - theme installation

Hello,

I bought the theme yesterday,but I can’t install this theme. Every time I try to install, it always gives me a different error. I’m 2 days trying to install the theme, but I can’t.

If I provide data to my control panel, could you install the theme?

Comments

Fred 01 Mar 2021, 21:21

Hi, claudio couto.
Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your Back-office and Server through FTP and we will try to install it for you

claudio couto 01 Mar 2021, 21:35

Hello Fred,

thanks for the quick response.

I have already filled in the data. Thank you very much!

Fred 01 Mar 2021, 21:39

I see the first potential problem. You have outdated Prestashop. Could you please upgrade it to the latest version first?

claudio couto 01 Mar 2021, 21:58

I have installed the latest version.

But in that version, I can't select the theme to choose. Can you give it a try? Thanks!!

Fred 01 Mar 2021, 22:07

as I can see you have some modules which generates JS errors in your back office. You have to disable or uninstall them to continue to work

claudio couto 01 Mar 2021, 22:22

can you tell me which modules they are?

Practically deactivated all the modules and continues equal.

Fred 01 Mar 2021, 22:33

I don' have access to your back office anymore. But as I remember that was modules from previous theme, like this one hrxcmscategoryslider

claudio couto 02 Mar 2021, 00:31

you are the best!

That was it. I deleted the previous theme, and the theme's modules, and I can now work correctly with this new prestashop version.

claudio couto 02 Mar 2021, 02:21

I have just installed the theme, and still seeing its functionality, I noticed that I can't access any product on the site, always appearing error 500.

claudio couto 02 Mar 2021, 09:52

I have just installed the theme, and still seeing its functionality, I noticed that I can't access any product on the site, always appearing error 500.

Fred 02 Mar 2021, 09:56

let me check...

Fred 02 Mar 2021, 10:01

I have enabled Debug Mode and found out the issue is caused by third party file /public_html/override/controllers/front/ProductController.php

Just remove it, it seems a part of your old theme

claudio couto 02 Mar 2021, 22:13

Hi Fred,
to not face the problems with modules and the previous theme, I decided to start from scratch the construction of the shop.

I created a subdomain, where I will configure the shop, and once everything is ok, I will import the products from the main domain.

But, just installing prestashop, and starting to install the theme, without installing other modules I noticed several errors.

1st - The "Favorites" page shows 404 error
2nd - The "Recently Viewed" page 404 error
3º - The "Compared Products" page 404 error
4th - The "Wishlist" page 404 error
5ª All the functions of the movil do not work - 404 Error

:(

claudio couto 02 Mar 2021, 22:56

I also discovered that no blog post works. I always get Error 500

Fred 02 Mar 2021, 22:58

Hi, Claudio.
I assume you are doing something wrong. Could you please install the theme like described in the video tutorial?

claudio couto 02 Mar 2021, 23:04

OK Fred. I will remove this subdomain, and create it again.

Can you give me the link of the installation tutotial? see if this time everything works well :)

Thanks!!

claudio couto 03 Mar 2021, 14:51

Thanks Fred. It must have been some problem with my host.

I re-installed today, and everything works correctly.

Now, in the "Theme Settings" part, I can't change the typography/colors. I tried several times, and it doesn't change the typography/colors (background, header, footer....).

Thank you very much for your support!

Fred 03 Mar 2021, 15:24

Please make sure you have disabled CSS Smarty cache on your performance settings.
We will add "clear cache" feature in the next update