• Priority: High
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 02.03.21, 10:32
  • Opened by: Paolo Carilli
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #20920 - Uncaught TypeError: Cannot read property 'switchErrorStat' of undefined

Hi,

I have many times this problem in shop

Uncaught TypeError: Cannot read property 'switchErrorStat' of undefined
    at r (theme.js:1)
    at HTMLDocument.<anonymous> (theme.js:1)
    at u (core.js:39)
    at Object.add [as done] (core.js:39)
    at m.fn.init.m.fn.ready (core.js:39)
    at Object.<anonymous> (theme.js:1)
    at e (theme.js:1)
    at Object.<anonymous> (theme.js:1)
    at e (theme.js:1)
    at Object.<anonymous> (theme.js:1)

I must refresh website. When this error show - menu does not open, filters do not work, etc.

Attachments:

Comments

Fred 02 Mar 2021, 11:20

Hi, Paolo Carilli.
The only error I see is caused by Captcha module which is not configured, see the screenshot https://take.ms/QMgds

Paolo Carilli 02 Mar 2021, 12:03

Hi,
Captcha module is configured but the error is always there

Attachments:

Fred 02 Mar 2021, 18:38

The issue has been fixed. Please test to confirm the change

Paolo Carilli 04 Mar 2021, 12:32

Hi,
after clear cache site the bug returns (but it doesn't always)

Attachments:

Fred 04 Mar 2021, 13:18

I have checked out different pages and don't see the error.
Is that error break some page? Or you can see it in console only?