• Priority: High
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 03.03.21, 19:34
  • Opened by: Alexandra Loire
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #20950 - builder bug

firstly I had a lot of problemes to activate theme , with this error

L’action installer est impossible pour le module pkcaptcha you should activate contactform module

since I didn’t find any solution , I removed all instance of pkcaptcha and contactform in the theme.yml

since then I could activate the Theme

but builder is bugging and I have a blank page in frontoffice

error is:

[PrestaShopDatabaseException]
Table ‘alexandrmzf613.ps7_pagebuilderprofile’ doesn’t exist<br /><br /><pre>SELECT b.id_pagebuilderprofile FROM `ps7_pagebuilderprofile` b LEFT JOIN `ps7_pagebuilderprofile_shop` `bs` ON b.`id_pagebuilderprofile` = bs.`id_pagebuilderprofile` WHERE (b.`isdefault` = 1 AND bs.`id_shop` = 1 AND b.`is_menu` != 1 AND b.`is_footer` = 0 AND b.`is_header` = 0 AND b.`is_amp` = 0) LIMIT 1</pre>
at line 769 in file classes/db/Db.php

764. if ($webservice_call && $errno) {
765. $dbg = debug_backtrace();
766. WebserviceRequest::getInstance()→setError(500, ‘[SQL Error] ' . $this→getMsgError() . ‘. From ' . (isset($dbg[3][’class’]) ? $dbg[3][’class’] : ‘‘) . ‘→’ . $dbg[3][’function’] . ‘() Query was : ' . $sql, 97);
767. } elseif (_PS_DEBUG_SQL_ && $errno && !defined(’PS_INSTALLATION_IN_PROGRESS’)) {
768. if ($sql) {
769. throw new PrestaShopDatabaseException($this→getMsgError() . ‘<br /><br /><pre>’ . $sql . ‘</pre>’);
770. }
771.
772. throw new PrestaShopDatabaseException($this→getMsgError());
773. }
774. }
DbCore→displayError - [line 385 - classes/db/Db.php] - [1 Arguments]
DbCore→query - [line 663 - classes/db/Db.php] - [1 Arguments]
DbCore→getRow - [line 697 - classes/db/Db.php] - [2 Arguments]
DbCore→getValue - [line 272 - modules/pspagebuilder/classes/profile.php] - [1 Arguments]
PsPagebuilderprofile::getDefaultProfile - [line 383 - modules/pspagebuilder/pspagebuilder.php] - [1 Arguments]
PsPageBuilder→processHook - [line 202 - modules/pspagebuilder/pspagebuilder.php]
PsPageBuilder→hookDisplayHeader - [line 990 - classes/Hook.php] - [1 Arguments]
HookCore::coreCallHook - [line 414 - classes/Hook.php] - [3 Arguments]
HookCore::callHookOn - [line 927 - classes/Hook.php] - [3 Arguments]
HookCore::exec - [line 575 - classes/controller/FrontController.php] - [1 Arguments]
FrontControllerCore→initContent - [line 37 - controllers/front/IndexController.php]
IndexControllerCore→initContent - [line 306 - classes/controller/Controller.php]
ControllerCore→run - [line 518 - classes/Dispatcher.php]
DispatcherCore→dispatch - [line 28 - index.php]

Comments

Fred 03 Mar 2021, 23:22

Please update credentials in your profile https://support.promokit.eu/index.php?do=myprofile to access to your Back-office
I can't login with current credentials
Il y a une erreur.
Ce compte employé n'existe pas, ou le mot de passe est erroné.

Alexandra Loire 04 Mar 2021, 07:44

its updated

be aware we can't update Shop URL in your back office: new URL is: http://www.collectionprivee-7cp.fr

Fred 04 Mar 2021, 09:23

I see an error caused by "mercanet" module. Please try to disable it

Alexandra Loire 05 Mar 2021, 12:26

ok I unactived the module so it worked
but can't access to theme settings ( it odesn't appear on the menu)

so I uninstalled the theme and tried a fresh install , but still Have that error:

L'action installer est impossible pour le module pkcaptcha. Avant d'installer ce module, vous devez installer le(s) module(s) suivant(s) :
- contactform

any clues?

Alexandra Loire 05 Mar 2021, 15:53

Globally I just need this theme to work in the oldstyle version
please help

Fred 05 Mar 2021, 16:10

I never seen such problem before. Please try to install "contactform" module. It's a native prestashop module and it should be available in your back office
As for the Theme Settings module, try to reset it

Alexandra Loire 05 Mar 2021, 18:41

I already tried both ... didn't worked..

Please help

Fred 05 Mar 2021, 23:50

I just configured everything for you, please check it out

Alexandra Loire 09 Mar 2021, 12:37

Hello, ok cool it works well

but instagram module do not load any content
I downloaded the last version of module and followed everything ( it says connected: sceenshot attached) but no feed)

another question, could you please load the mobile version as your live preview sample "oldstyle"

Attachments:

Capture.PNG (52.4 KiB)
Alexandra Loire 09 Mar 2021, 14:44

And a new bug

In revolution slider, we couldn't upload a new image ( never appears) so I tried to reset the module.

and it is now totally bugged

will we have so much bugs all the time by simply using your modules??

please help

Thanks

Fred 09 Mar 2021, 18:56

will we have so much bugs all the time by simply using your modules? - NO
- mercanet - is not our module
- instagram - something was recently was changed in instagram side and we just updating our module to keep it compatible
- revolution - I just make a reset and now it works fine

Alexandra Loire 11 Mar 2021, 20:23

Ok fine many thanks

Could you please explain how you resetted "revolution" module because when I tried before your intervention it didn't work ( via the button reset in BO)
Concerning Instagram I sent you screenshots of the module version 2.1 , doesn't work , are you updating it or is it a problem my side? I excatly followed the youtube video

Fred 12 Mar 2021, 10:22

There is some strange bug in prestashop what doesn't allow to reset modules. Try following trick to reset the module
- Open the file /ROOT/classes/Hook.php
- add following line

return true;

before line 217:

$cache_id = 'hook_namebyid_' . $hook_id;

- remove "return true;" when the module will be reinstalled

Alexandra Loire 12 Mar 2021, 12:39

ok great many thanks for the Tip

concerning the instagram module , you didn't answered yet, any clues?

Fred 12 Mar 2021, 14:13

The module is not connected to your Instagram account https://take.ms/DVU0m

Alexandra Loire 22 Mar 2021, 09:54

Cant connect because I still have :
{"error_type": "OAuthException", "code": 400, "error_message": "Invalid platform app"}

all configurations seems correct please look attched pics

Attachments:

cap_1.JPG (81.4 KiB)
cap2.JPG (12.6 KiB)
cap_3.JPG (22.5 KiB)
cap_4.JPG (74.6 KiB)
Fred 22 Mar 2021, 10:34

Something wrong configured in your Facebook App, please check out video tutorial once more

Alexandra Loire 30 Mar 2021, 18:37

ok now it finally worked on desktop , but no image on AMP

Fred 30 Mar 2021, 23:35

The issue has been fixed. Please test to confirm the change

Alexandra Loire 01 Apr 2021, 09:53

OK nice ! Is it normal that instagram video post or multiple image posts do not load..... is there an upgrade upcoming to choose what posts will load on prestashop ... for example with a dedicated hashtag whitin selected posts ?

Many thanks

Fred 01 Apr 2021, 10:22

The module doesn't support video format.
The only option available is to load latest images

Alexandra Loire 08 Apr 2021, 12:17

okay since then I bought an instagram module that could feed with a hashtag,
but when I add prestashop module in layout builder for homepage and amp it doesn't appear in the list of modul.

how can i load it?

Fred 08 Apr 2021, 12:50

Any third party module is not compatible with AMP by default. We have "AMPified" all prestashop pages and our own modules for the theme but we are not able to "AMPify" every third party module.

Fred 08 Apr 2021, 12:50
Alexandra Loire 15 Apr 2021, 11:50

hello
I have a major probleme: all modible page load blank

can you please help?

Thanks!

Fred 15 Apr 2021, 11:51
Alexandra Loire 16 Apr 2021, 12:41

hello
I have a major probleme: all modible page load blank

can you please help?

Thanks!

Fred 16 Apr 2021, 13:07