• Priority: High
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 09.05.21, 00:45
  • Opened by: Sophia Kulakova
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason:

Ticket #21476 - update

Please help me, after updating the presta shop, the theme template is not installed.

Comments

Sophia Kulakova 09 May 2021, 01:14

I restored the previous version of the site and everything is fine. Tell me, what could this problem be connected with? And yet I can not update the theme, it also gives an error

Fred 10 May 2021, 12:40

I have no idea what was wrong. I need to see the problem to try to figure out whats's wrong.

Sophia Kulakova 10 May 2021, 18:13

Do you have the opportunity to look? I need to update the presta, because the Facebook pixel module is not installed. And I need it for my store on Facebook and Instagram

Fred 10 May 2021, 23:05

Hi, Sophia.
I can't understand the problem you have. As I can see the template is working fine.
As for the Facebook Pixel module, you have to install it.
As for the Instagram module, you have to add it to your home page

Sophia Kulakova 10 May 2021, 23:23

yes, everything is working fine now, because I made a backup. but I need to update presta shop to the latest version. I can't do this because the theme doesn't turn back on.

Fred 10 May 2021, 23:25

I'll be offline tomorrow, but on Wednesday I can try to help you.

Sophia Kulakova 13 May 2021, 09:28

It would be great if you could help me. thank you, I’ll be waiting

Fred 13 May 2021, 09:29

Sorry, the ticket was closed by mistake.
We are working on a solution

Fred 13 May 2021, 09:34

Please try to update your prestashop once more, and I'll fix the problem

Anonymous Submitter 13 May 2021, 09:35
  • Ticket details edited

It would be great if you could help me. thank you, I’ll be waiting

Sophia Kulakova 13 May 2021, 09:40

Ok I will update now and write to you

Sophia Kulakova 13 May 2021, 09:53

I have updated. The topic is not put back

Fred 13 May 2021, 09:53

ok

Fred 13 May 2021, 09:53

Let me check...

Sophia Kulakova 13 May 2021, 09:59

of course i am waiting

Fred 13 May 2021, 09:59

as I can see you have wrong files and folders permissions

Permissions for all files should be set to "644"
Permissions for all folders should be set to "755"
Sophia Kulakova 13 May 2021, 10:04

What does it mean, how to fix it

Fred 13 May 2021, 10:06

that is not related to the theme or prestashop configuration.
Please ask your hosting support to help you

Sophia Kulakova 13 May 2021, 10:08

ок. Thank you, I already wrote to them

Fred 13 May 2021, 10:12

ok.

Sophia Kulakova 13 May 2021, 10:26

What actions do we need to do in the admin panel to see the error you are describing? Please describe step by step.

Fred 13 May 2021, 10:37

just go to your server via FTP and see the CHMOD of any file or a folder

Sophia Kulakova 13 May 2021, 10:39

Thank you

Fred 13 May 2021, 10:41

No problem

Sophia Kulakova 13 May 2021, 10:52

here's what I was told on the hosting .
We use [Site Isolation](https://beget.com/insulation), so the standard 700 rights are sufficient both from the point of view of performance and from the point of view of security. I don't think it's because of your rights.

Fred 13 May 2021, 11:01

Ok, ask them the following.
There is an error

Unable to load template 'file:_partials/heading.tpl' in '/pspagebuilder/views/templates/front/widgets/widget_gallery.tpl'

The file "_partials/heading.tpl" is available in the directory "/public_html/themes/alysum/templates/_partials" why it's unable to load?

Sophia Kulakova 13 May 2021, 12:43

that's what they answered me.
Permissions can be changed via chmod

Changed:

skulakova@flareon:~/amberheart.ru/public_html [0] $ find -type f -exec chmod 644 {} +
skulakova@flareon:~/amberheart.ru/public_html [0] $ find -type d -exec chmod 755 {} +
skulakova@flareon:~/amberheart.ru/public_html [0] $ 

To your question, he answered the following: As I see, there is such a file on the server now:

skulakova @ flareon: ~ / amberheart.ru / public_html [0] $ find -iname 'widget_gallery.tpl'
./modules/pspagebuilder/views/templates/front/widgets/widget_gallery.tpl
skulakova @ flareon: ~ / amberheart.ru / public_html [0] $ realpath ./modules/pspagebuilder/views/templates/front/widgets/widget_gallery.tpl
/home/s/skulakova/amberheart.ru/public_html/modules/pspagebuilder/views/templates/front/widgets/widget_gallery.tpl
skulakova @ flareon: ~ / amberheart.ru / public_html [0] $
skulakova@flareon:~/amberheart.ru/public_html [0] $ sed -n 15998,16005p strace.log 
13:06:18.612960 sendto(3, "K\0\0\0\3SELECT `id_module` FROM `ps_module` WHERE `name` = \"pkproducttabs\" LIMIT 1", 79, MSG_DONTWAIT, NULL, 0) = 79
13:06:18.612998 poll([{fd=3, events=POLLIN|POLLERR|POLLHUP}], 1, 1471228928) = 1 ([{fd=3, revents=POLLIN}])
13:06:18.613061 recvfrom(3, "\1\0\0\1\1I\0\0\2\3def\17skulakova_prsh2\tps_module\tps_module\tid_module\tid_module\f?\0\n\0\0\0\3#B\0\0\0\5\0\0\3\376\0\0\2\0\5\0\0\4\376\0\0\2\0", 5306, MSG_DONTWAIT, NULL, NULL) = 100
13:06:18.613213 stat("pkproducttabs", 0x7ffc8ecc3b40) = -1 ENOENT (No such file or directory)
13:06:18.613281 sendto(3, "K\0\0\0\3SELECT `id_module` FROM `ps_module` WHERE `name` = \"pkproducttabs\" LIMIT 1", 79, MSG_DONTWAIT, NULL, 0) = 79
13:06:18.613320 poll([{fd=3, events=POLLIN|POLLERR|POLLHUP}], 1, 1471228928) = 1 ([{fd=3, revents=POLLIN}])
13:06:18.613386 recvfrom(3, "\1\0\0\1\1I\0\0\2\3def\17skulakova_prsh2\tps_module\tps_module\tid_module\tid_module\f?\0\n\0\0\0\3#B\0\0\0\5\0\0\3\376\0\0\2\0\5\0\0\4\376\0\0\2\0", 5206, MSG_DONTWAIT, NULL, NULL) = 100
13:06:18.613437 access("/home/s/skulakova/amberheart.ru/public_html/modules/pkproducttabs/pkproducttabs.php", F_OK) = -1 ENOENT (No such file or directory)
skulakova@flareon:~/amberheart.ru/public_html [0] $ 

He also said that he did not see the module indicated by the error:

skulakova_prsh2@flareon.beget.ru[skulakova_prsh2]> SELECT `id_module` FROM `ps_module` WHERE `name` = "pkproducttabs";
Empty set (0,00 sec)

skulakova_prsh2@flareon.beget.ru[skulakova_prsh2]> 
skulakova@flareon:~/amberheart.ru/public_html [0] $ stat /home/s/skulakova/amberheart.ru/public_html/modules/pkproducttabs/pkproducttabs.php
stat: cannot stat '/home/s/skulakova/amberheart.ru/public_html/modules/pkproducttabs/pkproducttabs.php': No such file or directory
skulakova@flareon:~/amberheart.ru/public_html [1] $ 

And asked to ask: Check with the support, Template, regarding the compatibility of the Template with the current version of the CMS Installation.

Fred 13 May 2021, 14:14

Do you use any additional cache module or a service?
I edit the file /public_html/modules/pspagebuilder/views/templates/front/widgets/widget_gallery.tpl but nothing is changed in the front page

Is the credentials to connect to your FTP are correct?

Sophia Kulakova 13 May 2021, 14:22

Yes, I use Memcached on the hosting.
Software that implements in-memory data caching service based on the hash table paradigm. In the case of starting the Memcached service, this will be your private service accessible only to you. FTP accesses seem to be correct

Fred 13 May 2021, 14:28

please try to clear the cache.
As I can see all theme and modules files are correct, so the problem is definitely on server side

Sophia Kulakova 13 May 2021, 14:31

I have now disabled this cache program. Check, please

Fred 13 May 2021, 15:11

Hi, Sophia.
We spent too much time on that with no result.
Could you please restore a backup?

Sophia Kulakova 13 May 2021, 15:16

yes I understand that you have wasted a lot of time. But I need to install a new facebook module, and it is installed only on the latest version of the page. If everything is in order on your part, I will try to solve the problem on the hosting side. thanks for the support

Sophia Kulakova 13 May 2021, 17:35
I edit the file /public_html/modules/pspagebuilder/views/templates/front/widgets/widget_gallery.tpl but nothing is changed in the front page


Please, you can tell me what changes you made so that I can retell the hosting technical support, and they reproduce them from their side in order to check the problem

Fred 13 May 2021, 17:36

I already added changes into that file, but the problem is global and I currently can't find the solution

Sophia Kulakova 13 May 2021, 18:06

This was written to me on the hosting, but I still can't put the topic. What does it mean

However, as I understand it, your template is now being rendered:

skulakova@flareon:~/amberheart.ru/public_html [0] $ stat /home/s/skulakova/amberheart.ru/public_html/modules/pkthemesettings/views/templates/hook/maintenance.tpl
  File: /home/s/skulakova/amberheart.ru/public_html/modules/pkthemesettings/views/templates/hook/maintenance.tpl
  Size: 3754      	Blocks: 8          IO Block: 4096   regular file
Device: 802h/2050d	Inode: 185839038   Links: 1
Access: (0644/-rw-r--r--)  Uid: ( 4654/skulakova)   Gid: (  601/newcustomers)
Access: 2021-05-09 02:04:47.446319655 +0300
Modify: 2020-10-01 11:06:09.922150368 +0300
Change: 2021-05-13 13:21:45.651317808 +0300
 Birth: -
skulakova@flareon:~/amberheart.ru/public_html [0] $ 

I 1 added:

skulakova@flareon:~/amberheart.ru/public_html [0] $ sed -n 41p /home/s/skulakova/amberheart.ru/public_html/modules/pkthemesettings/views/templates/hook/maintenance.tpl
			<h4>{l s='Notify me 1 when ready' d='Modules.Pkthemesettings.Comingsoon'}</h4>
skulakova@flareon:~/amberheart.ru/public_html [0] $ 
Fred 14 May 2021, 12:17

As I can see the website is working now.
Did you find a solution? or restored a backup?

Sophia Kulakova 14 May 2021, 14:22

Backup. Maybe you can help me install the new fb modulehttps://addons.prestashop.com/ru/products-social-networks/50291-prestashop-facebook.
In order not to update the topic. I do not understand what kind of error he gives me

Fred 15 May 2021, 14:27

I spent almost one hour to try to find a solution, but no success.
The problem you have is definitely not related to the theme. Our support doesn't cover such problems, sorry

Sophia Kulakova 16 May 2021, 14:52

hello, I asked the webmaster to see what the problem might be, he says that one of the theme modules conflicts with the facebook module, and for the same reason, the theme is not installed in the new version of prestashop. He said that there was a theme update for my version 1.7.7.0 and it was better to install it. But I can't, an error occurs, can you please update my topic so that we can continue to look for the problem and try to install the fb module

Fred 17 May 2021, 10:20

1. I have installed the Facebook module to our local server and demo with no problems or conflicts
2. I have updated the theme to the latest version - https://take.ms/34xBX But there is no major changes, so I'm not sure that will help