• Priority: Medium
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 12.05.21, 19:33
  • Opened by: Giorgio Bagnasco
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #21503 - Brand pages + options + "Create account" fields

Hi,

BRAND’S PAGES - https://shop.ioi.it/it/brand/2-corpootto

1. In the brand pages the brand logo image isn’t visible, it possible to show it?

2. and / or it’s possible to edit these page like category-pages?

3. or, at least, it’s possible to insert the left sidebar with the “Faceted Search”?

ALL BRANDS PAGE - https://shop.ioi.it/it/brands

It’s possibile to edit it, like Category Page?

I dont’ know why, but there are stille 2 of the old brands logo that I replaced Ok I can overwrite them on FTP But it’s not strange that PS didn’t overwrited them during image replacement?

CREATE ACCOUNT PAGE FORM - https://shop.ioi.it/it/login?create_account=1

How is possible to edit and change these fields?

I’ve set some mandatory fields, like VAT Number (P.IVA), Address, Phone, etc but they aren’t showed o neither insertable or editable by User admin page.

We also bought a module to manage some Custom Fields for the B2B registration we need, but it’s better to use native ones, like VAT Numbers, etc for all the internal PS procedures.

USER MENU We’re noticing some flickering / malfunctions on the “User menu” in the Header .
It seems a conflict between the 2 dropdown menus, the User and the Main menu.
Do you already know, and maybe already solved, this little issue?

Thanks in advance and have a good evening / day.

Comments

Fred 13 May 2021, 11:43

BRAND’S PAGES
1. But where it should be visible? Yes, there is no logo on that page
2. There is no such option
3. Faceted Search is a native Prestashop module, it works on Category page only
ALL BRANDS PAGE
1. there is no such option
2. That is not theme's problem. Try to regenerate images through back office
CREATE ACCOUNT PAGE FORM
1. There is no an option in the theme to edit the form. Go to Customer Settings in your back office, there should be an option to manage some form fields
USER MENU
What browser do you use? Because I don't see the issue in Safari and Chrome

Giorgio Bagnasco 24 May 2021, 16:26

Hi,

and thanks always for your great support.

BRAND'S PAGES
1. It could be possible to show at least the logo image at top left position?
3. Understood, this is another non-sense thing of Prestashop, the Faceted Search module should work anywhere, because when there are lot of products of a brand, you can't filter anything.
Anyway, I managed to change the layout of the page, will search an alternative module but without great confidence to find it.

ALL BRANDS PAGE
Another ugly page: true that it will be not greatly viewed, as you can arrive there only by the breadcrumbs.
I understand that maybe these aren't high priorities for Prestashop Team, but I think that a very good PS Theme like yours could deal better with these, and maybe, manage to help to customize them.

CREATE ACCOUNT PAGE
Ok, we're working on it, hope quite solved.

USER MENU
I've taken a video, done using Chrome. It happens very often, maybe you can have some ideas to manage it
It does very often the same also the language selection menu
I think is a conflict of the 2 menus, that are overlapping.
https://shop.ioi.it/Ioi-shop-menu-malfunction-20210524_153834.mp4

TRANSLATIONS
I can't find where to translate some expressions, modules titles, etc attached 2 images of BRAND'S PAGE and PRODUCT PAGE (I think is the widget Product Footer)

Thanks in advance.

Fred 25 May 2021, 15:44

1. It requires code customization. Unfortunately we don't have free time now.
3. ok
4. Try following CSS code to make the page looks like this: https://take.ms/w6M5i

.brands-list ul {
    flex-direction: column;
}
.brands-list ul li {
    display: flex;
    justify-content: flex-start;
    align-items: left;
    width: 100%;
    text-align: left 
}
.brands-list ul li .brand-img {
    width:200px;
    min-width:200px;
    margin-right: 30px
}
.brands-list ul li .brand-products {
    min-width:100px;
    text-align:right
}

4. Menu fix:

#header .headerbuilder .header-3 .dd_container {transform: translateY(0)}

5. Translations. I can't fint where those wordings are located in the front office, please give me a link

Giorgio Bagnasco 27 May 2021, 23:23

Hi, thanks for your help.
We'll ask a developer to help us to customize the Brand's page.

The translations are in every blank Category:
https://shop.ioi.it/it/brand/1-prontixte

and in any Product Page: at the bottom
https://shop.ioi.it/it/occhiali-montatura-materiale-organico-iniettato/6-90-prontoleggo-harmony-occhiali-da-lettura-premontati.html

Thanks

Fred 28 May 2021, 11:24

Try to use Search to find the wording you want to translate https://take.ms/XtRKKJ

Giorgio Bagnasco 29 May 2021, 15:28

Thanks, but in the Alysum theme's translations, that phrase is already translated

I should translate also the child theme?
But it's impossible to do it, it never shows all the options, it remain at 0 expressions in wait loading mode after an error about directory IT missing from /var/vache

I also tried to copy the "Translations" directory from the "Alysum" to "Alysum Child" theme directory.

Fred 30 May 2021, 11:29

You don't have to translate child theme. Only parent Alysum

Giorgio Bagnasco 31 May 2021, 21:52

Thanks, but in the Alysum theme's translations, that phrase is already translated

I should translate also the child theme?
But it's impossible to do it, it never shows all the options, it remain at 0 expressions in wait loading mode after an error about directory IT missing from /var/vache

I also tried to copy the "Translations" directory from the "Alysum" to "Alysum Child" theme directory.

Fred 01 Jun 2021, 10:02

But I see it's translated in the front page https://take.ms/NaPYW

Giorgio Bagnasco 03 Jun 2021, 11:24

Thanks, but in the Alysum theme's translations, that phrase is already translated

I should translate also the child theme?
But it's impossible to do it, it never shows all the options, it remain at 0 expressions in wait loading mode after an error about directory IT missing from /var/vache

I also tried to copy the "Translations" directory from the "Alysum" to "Alysum Child" theme directory.

Giorgio Bagnasco 03 Jun 2021, 11:25

Hi, thanks for your help.
We'll ask a developer to help us to customize the Brand's page.

The translations are in every blank Category:
https://shop.ioi.it/it/brand/1-prontixte

and in any Product Page: at the bottom
https://shop.ioi.it/it/occhiali-montatura-materiale-organico-iniettato/6-90-prontoleggo-harmony-occhiali-da-lettura-premontati.html

Thanks

Giorgio Bagnasco 03 Jun 2021, 15:11

Ok, I'm sorry.
I was assuming that the site was automatically presented in Italian, matching the browser language (and country), as set in configuration.
So, there is another bug of Prestashop?

Ok thanks

Fred 03 Jun 2021, 21:54

Try to disable these options https://take.ms/Eq1Dv